Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Bug: Finish Units in Non-Finish HQs

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Gary Grigsby's War in the East Series >> Tech Support >> Bug: Finish Units in Non-Finish HQs Page: [1]
Login
Message << Older Topic   Newer Topic >>
Bug: Finish Units in Non-Finish HQs - 2/15/2012 8:10:23 AM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
The German High Command Tourism Board scored a major coup in convincing all the Finish Engineering Battalions to take a sun (and artillery) filled holiday near the Black Sea.

I see virtually all the Finish Engineering Battalions down south attached to a german army group.
Post #: 1
RE: Bug: Finish Units in Non-Finish HQs - 2/15/2012 8:56:09 AM   
Helpless


Posts: 15630
Joined: 8/27/2004
Status: offline
Is this human or AI?

_____________________________

Pavel Zagzin
WITE/WITW/WITE-2 Development

(in reply to PMCN)
Post #: 2
RE: Bug: Finish Units in Non-Finish HQs - 2/15/2012 9:35:45 AM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
It is the AI. I have no idea how they got their but they have been there for a while.

(in reply to Helpless)
Post #: 3
RE: Bug: Finish Units in Non-Finish HQs - 2/15/2012 5:28:03 PM   
Joel Billings


Posts: 28839
Joined: 9/20/2000
From: Santa Rosa, CA
Status: offline
We've had reports of this in the past. The only way we have any chance of figuring out why this is happening is if we get a repeatable save before the German turn where if you run the save the AI will always move specific units to areas they shouldn't. If you can get us that kind of a save, we'll take a look.

_____________________________

All understanding comes after the fact.
-- Soren Kierkegaard

(in reply to PMCN)
Post #: 4
RE: Bug: Finish Units in Non-Finish HQs - 2/15/2012 9:23:58 PM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
Joel...I have saves going back, well lots of turns, but what I don't know is what turn the AI moved the units out of finland. I can't even recall exactly when I first noticed them in combat (probably in may sometime when the Germans were probing my lines in the centre) but frankly the front was quiet for several weeks before that so the Engineers could have been moved south any time in the last 30 or so turns. I'm pretty sure I didn't see them when I was conducting my winter offensive but otherwise I don't know which turn to send you. I am playing the game as the soviet...can I just load up the german save and look?? I'm pretty sure I have the data you want I'm just not sure how to find it...

(in reply to Joel Billings)
Post #: 5
RE: Bug: Finish Units in Non-Finish HQs - 2/16/2012 6:24:12 AM   
Joel Billings


Posts: 28839
Joined: 9/20/2000
From: Santa Rosa, CA
Status: offline
I'm not sure, but I think if you load up the AI's auto save the AI will start in. However, I think you can click on the top buttons and bring up the commander's report. By doing this you might be able to locate some support units that are in the wrong place and trace them back through turns until you find when they first went there. Then you need to rerun from an earlier save to see if it happens again. I know it's painful, but unless we are able to catch it in the act, Gary's not going to be able to lock those wondering Finns in place.

_____________________________

All understanding comes after the fact.
-- Soren Kierkegaard

(in reply to PMCN)
Post #: 6
RE: Bug: Finish Units in Non-Finish HQs - 2/16/2012 8:11:10 AM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
Joel,
I will give this a try over the weekend. I need a bit of time in a block for this sort of hunt and peck search. If it works I'll send you the file and if it doesn't work we can discuss if there are other options.

Otherwise the 3rd Reichs Reiseburo ist sehr effektive! "Komt Sud Junge! Sehen Sie Wundershone land, Bekommen Sie eine freundlich frauen. Essen und Trinken ohne ende!"*

Either that or someone got the immigrant song started a bit too early.
*My written German needs more practice.

(in reply to Joel Billings)
Post #: 7
RE: Bug: Finish Units in Non-Finish HQs - 2/18/2012 12:26:06 PM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
Alright...I found possibly the problem. I will attach the axis 2-26 save and the axis 3-5 save. In the 2-26 save the Finnish engineer battalions are present, in the next save they are absent (and I know I never attacked the finns in february).

Likely then the AI re-created the units in OKH and then they got distributed as regular german units.

I wish there was a way to pause the execution of the AI but looking through the OOB page helped speed up the process and then I called up the commanders report to make sure of it...while pausing air recon.

I have save game files going back to turn 17...so the last 40 turns or so (current turn is 57-ish) let me know if you want any more information.

Attachment (1)

< Message edited by Paul McNeely -- 2/18/2012 12:28:26 PM >

(in reply to PMCN)
Post #: 8
RE: Bug: Finish Units in Non-Finish HQs - 2/18/2012 12:30:00 PM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
right here is the second file...well it iwll be after I edit it as I can't seem to upload directly when making the message...

If you need files further along let me know and I will attempt a bubble sort to find the finns when they come back...

Hope this helps fix the issue.

Attachment (1)

< Message edited by Paul McNeely -- 2/18/2012 12:31:07 PM >

(in reply to PMCN)
Post #: 9
RE: Bug: Finish Units in Non-Finish HQs - 2/18/2012 6:36:32 PM   
Joel Billings


Posts: 28839
Joined: 9/20/2000
From: Santa Rosa, CA
Status: offline
I looked at your two saves. At the start of the Axis turns there are 10 eng/construction support units for the Finns. I don't see any difference. Can you give me the name of a unit that you think disappears?

_____________________________

All understanding comes after the fact.
-- Soren Kierkegaard

(in reply to PMCN)
Post #: 10
RE: Bug: Finish Units in Non-Finish HQs - 2/19/2012 12:44:31 PM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
err what? The trouble is I have to do it quickly maybe I messed up the save dates...but in the march one the finish engineering battalions vanish from the Finish High Command OOB...

Let me go look at things again...I had been dreading a reply like this...


Ok...I looked again...and I see them there in that march save as well...so I went through the turns forward and got 9.4.42 and at that point all the named engineering units in the finish high command vanish from the OOB display when I looked so no Fin Engineering Bn at all.

Let me know if they are there with you or what.

Attachment (1)

< Message edited by Paul McNeely -- 2/19/2012 12:59:46 PM >

(in reply to Joel Billings)
Post #: 11
RE: Bug: Finish Units in Non-Finish HQs - 2/20/2012 3:35:12 AM   
Joel Billings


Posts: 28839
Joined: 9/20/2000
From: Santa Rosa, CA
Status: offline
I loaded your latest save and I see 7 FI engineer battalions, 6 in the High Command and 1 in a Corps HQ. I let the AI run through the turn and at the end of the turn all 7 were in the Finnish High Command. Not sure what's going on, but they are still there when I look at the save.

_____________________________

All understanding comes after the fact.
-- Soren Kierkegaard

(in reply to PMCN)
Post #: 12
RE: Bug: Finish Units in Non-Finish HQs - 2/20/2012 10:52:22 AM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
Joel, I just opened up that save and although I see a bunch of construction battalions in the Finnish High Command, there are no engineering battalions in it, or the two armies attached to it.

I'm gobsmacked and have no idea how to proceed. I am running 1.05.54 currently, but these saves were made under 1.02.xx (not really sure exactly)--if that makes any difference.

(in reply to Joel Billings)
Post #: 13
RE: Bug: Finish Units in Non-Finish HQs - 2/20/2012 4:56:08 PM   
Joel Billings


Posts: 28839
Joined: 9/20/2000
From: Santa Rosa, CA
Status: offline
I don't know what to say. When I load the turn 43 axis save, there are 6 Fin engineer units in the Finnish High Command. These saves are from one year ago. I assume you are saying you're still seeing the Finnish battalions in the south when playing a more up to date version of the game? I can't say for sure if something is going on because the saves are so old. If they are not there for you when you load, but are there for me when I load, I'm not sure what's going on. You don't have anything more recent with this problem?

_____________________________

All understanding comes after the fact.
-- Soren Kierkegaard

(in reply to PMCN)
Post #: 14
RE: Bug: Finish Units in Non-Finish HQs - 2/21/2012 12:08:52 PM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
I have only the one game, and I took a break when the patching was hot and heavy to wait for things to settle down, that is why the save game date is so old. I was playing yesterday and judging from combat the turn before the finns are in the south, we are skirmishing a bit to the east of oddessa, and west of the Dnepr and they showed up in one of the attacks. I can send you the latest axis auto save and you can see they are not in Finland if you want. I've been trying to find the save where they leave, from what I can tell the turn before the one I have posted above they were in Finland.

Just to be clear here, there are probably 6 construction battalions in the Finnish High Command in that april 42 save, but the engineering battalions are not there. Lets make sure we aren't missunderstanding each other on this point. I agree there are construction battalions in the Finnish High Command but I see no Engineering Bn there.

If you want I can send you the latest Axis save game file (under 1.05.54 and only a few days old) and you can check that the finn's engineering bn have migrated south. But like you I don't know what to suggest outside that. In the German summer 42 offensive I've seen them show up in battles in southern russia on 4-6 occasions since it started in may so I know they aren't where they should be. I'm sorry this isn't going as smoothly as I hoped it would. I will load up that april save and see if the Finn Eng Bn are there or not as well just to check one more time.

(in reply to Joel Billings)
Post #: 15
RE: Bug: Finish Units in Non-Finish HQs - 2/21/2012 5:09:29 PM   
Joel Billings


Posts: 28839
Joined: 9/20/2000
From: Santa Rosa, CA
Status: offline
Here's what I see in the turn 43 save.




Attachment (1)

_____________________________

All understanding comes after the fact.
-- Soren Kierkegaard

(in reply to PMCN)
Post #: 16
RE: Bug: Finish Units in Non-Finish HQs - 2/21/2012 5:59:37 PM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
I just looked in that save and that is what I see as well (using the oob button). Either the first two times I looked my eyes were decieving me or else this is some sort of random glitch. I'll attach the turn two turns before my latest...this will be axis turn 56. See if the Finns are in the finnish high command or not. I am fairly sure that during that turn they launch attacks that have them showing up down south. But to be clear here, I am not sure if this was the turn or not it could be the one before or the one after but regardless they should be in the south...attached to one of the Panzer Korps or else a Panzer Group/Army HQ...I think, they seem to show up when a Pz division attacks.

I'm sorry this is not going straight forward. I am also completely unsure why two times I checked the file for the april turn and no finns then I check a third time and they are there plain as day. I appreciate your patience, but believe me (or not I guess) I am not leading you around the mulberry bush on purpose here.

Attachment (1)

< Message edited by Paul McNeely -- 2/21/2012 6:07:16 PM >

(in reply to Joel Billings)
Post #: 17
RE: Bug: Finish Units in Non-Finish HQs - 2/21/2012 7:08:47 PM   
Joel Billings


Posts: 28839
Joined: 9/20/2000
From: Santa Rosa, CA
Status: offline
No problem. On your last save they are all in Kaanas Army HQ. This save is from Feb 12 2012. Where are they on turn 57? Maybe they are moving at the start of the turn, or maybe they are moving and then moving back? Or maybe they never moved but somehow got into combat. You are actually seeing them listed as attached to German HQs?

_____________________________

All understanding comes after the fact.
-- Soren Kierkegaard

(in reply to PMCN)
Post #: 18
RE: Bug: Finish Units in Non-Finish HQs - 2/21/2012 8:56:36 PM   
Denniss

 

Posts: 6721
Joined: 1/10/2002
From: Germany, Hannover (region)
Status: online
If that save was made with an old game version it may be a bug fixed in later versions, loading the save with a current game version may have this issue fixed upon loading.

_____________________________

WitE dev team - (aircraft data)
WitE 1.08+ dev team (data/scenario maintainer)
WitW dev team (aircraft data, partial data/scenario maintainer)
WitE2 dev team (aircraft data)

(in reply to Joel Billings)
Post #: 19
RE: Bug: Finish Units in Non-Finish HQs - 2/21/2012 9:00:55 PM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
I am seeing them occasionally show up in combat, if memory serves usually when a Pz division is attacking. The first time they did the Germans were trying to break my line in the centre and were assaulting accross a river and they showed up. I saw their particular finnish weapons (the SMG if memory serves) show up during combat. It has been around 6 times or so that I have seen them...plus I see them listed in the units in the attack window. I watch the attack at lvl 5 usually so I have plenty of time to check the attacking forces out.

I can say they don't seem to be consistantly showing up...so maybe they are moving in and out. Is there something that looks for engineers in the code? I saw them the first time when the Germans were conducting accross river attacks and the last times they showed up they were attacking heavily dug in troops. I just looked in turn 57 they are in the kannas army, and the same is true of turn 55. Yet in the last turn or two I saw them show up at a battle again (I'm at 58 so 56, or 56). It is either that or else I am confusing another type of engineering battalion. I recal seeing a name like xxth FI Engineering Bn ...could also be Fl Engineering Bn in there with the finns when they showed up.

This crazy behavior is starting to make me think I've been seeing things ... next time they show up I'm taking a screen shot!

Denniss, I orginally saw the behavior under 1.02.xx but the last turns when I saw it again were under 1.05.54. But unfortunately it seems to be the worst kind of computer bug to track down...one which isn't consistant.

< Message edited by Paul McNeely -- 2/21/2012 9:04:39 PM >

(in reply to Joel Billings)
Post #: 20
RE: Bug: Finish Units in Non-Finish HQs - 2/21/2012 9:27:26 PM   
Denniss

 

Posts: 6721
Joined: 1/10/2002
From: Germany, Hannover (region)
Status: online
Press pause during combat, create a screenshot and upload it here.


< Message edited by Denniss -- 2/21/2012 9:31:38 PM >


_____________________________

WitE dev team - (aircraft data)
WitE 1.08+ dev team (data/scenario maintainer)
WitW dev team (aircraft data, partial data/scenario maintainer)
WitE2 dev team (aircraft data)

(in reply to PMCN)
Post #: 21
RE: Bug: Finish Units in Non-Finish HQs - 2/21/2012 11:26:49 PM   
Joel Billings


Posts: 28839
Joined: 9/20/2000
From: Santa Rosa, CA
Status: offline
Do you mean 1.05.45? It is possible this was fixed in a AI fix after 1.05.45. I vaguely recall Gary saying something about a routine that tries to get engineers for attacking against forts, but don't remember the context. He made many AI changes during the past 2 months and this may have been something that became more visible, and then possibly fixed (but only I'm guessing/hoping at this point). If you are willing, you should upgrade to the latest public beta (or in a few days/week, upgrade when the version becomes official).

_____________________________

All understanding comes after the fact.
-- Soren Kierkegaard

(in reply to Denniss)
Post #: 22
RE: Bug: Finish Units in Non-Finish HQs - 2/22/2012 3:13:47 AM   
randallw

 

Posts: 2048
Joined: 9/2/2010
Status: offline
I also saw some Finnish units, like Eng types, in a German command, the last campaign I started. That was probably with the 1.05.43 patch and I started a new campaign since then, with the 1.06 beta installed a day or two ago.

(in reply to Joel Billings)
Post #: 23
RE: Bug: Finish Units in Non-Finish HQs - 2/22/2012 8:33:02 AM   
PMCN

 

Posts: 623
Joined: 9/8/2000
From: Germany
Status: offline
I am playing with the latest release version (non beta) 1.05.xx, whatever xx is. I plan to update to the 1.06.xx non-beta version when it is released. I'm just not a big fan of beta's unless I am officially testing them.

Thanks for the support randallw, I was seriously starting to wonder if I was somehow imagining things! If I had been updating my AAR then I would have had all the data as I tend to write down all the units involved etc for the write up. Come to think on it, it should still be in my AAR I recall writing something about tourists. Probably I should cast ressurection on it...and sumerize the last 6-8 weeks of skirmishing near the black sea, including the daring break out of two trapped guards divisions (well ok not so daring as the lone SS mot bde holding the barn door closed got hit by 3 divisions, and a couple of brigades and blown out of position...though that idiot bde had more men then most of my divisions muster).

Next time it happens I will definitly make a screenshot! But I hope it is something that got fixed, since it was a tad odd.

(in reply to randallw)
Post #: 24
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Gary Grigsby's War in the East Series >> Tech Support >> Bug: Finish Units in Non-Finish HQs Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.168