Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[ROTS 1.5.0.8] Station moved in a wrong place

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> [ROTS 1.5.0.8] Station moved in a wrong place Page: [1]
Login
Message << Older Topic   Newer Topic >>
[ROTS 1.5.0.8] Station moved in a wrong place - 6/10/2011 9:03:26 PM   
Volcano

 

Posts: 52
Joined: 3/25/2010
From: France
Status: offline
I just started a new game as Human in an even clusters galaxy of 1400 stars. A short time ago, I saw a pirate frigate attacking one of my research stations, built near a black hole. The frigate was repelled by the stations weapons but managed to severly damage the station before jumping out. Then I selected the station and click on the "queue up construction ship to repair station" button. The construction ship arrived soon, and I saw the message announcing the end of the repair, but when I looked at the station, I saw what the attached screenshot is showing...




Needless to say, my jaw fell down to floor level...

Attachment (1)

< Message edited by Volcano -- 6/10/2011 9:17:58 PM >


_____________________________

Do not awake the dormant volcano...
Post #: 1
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/10/2011 9:12:40 PM   
Data


Posts: 3909
Joined: 1/3/2011
Status: offline
If the CS somehow moved to the repair while it was still building the mining station than that could explain this. But it's improbable to say the least.
Did you know what that particular CS was doing prior to receiving the repair order? Better yet, do you have a save game that covers the attack and subsequent repair so that we can take a look? It's an "interesting" anomaly

_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to Volcano)
Post #: 2
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/10/2011 9:16:23 PM   
Volcano

 

Posts: 52
Joined: 3/25/2010
From: France
Status: offline
I have an autosave made 6 minutes before this screenshot, I don't remember if it was made prior to the attack, but I'll check this.

Edit : and the answer is... the autosave was made during the repair !

< Message edited by Volcano -- 6/10/2011 9:24:29 PM >


_____________________________

Do not awake the dormant volcano...

(in reply to Data)
Post #: 3
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/10/2011 9:23:02 PM   
Data


Posts: 3909
Joined: 1/3/2011
Status: offline
It can be further in the past, the important thing is for the attack to occur at some point so that we can reproduce this.

_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to Volcano)
Post #: 4
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/10/2011 9:26:45 PM   
Volcano

 

Posts: 52
Joined: 3/25/2010
From: France
Status: offline
I see, but the only other savegame I can give you was made two ingame years before the attack, that's a bit much...


_____________________________

Do not awake the dormant volcano...

(in reply to Data)
Post #: 5
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/10/2011 9:48:33 PM   
cookie monster


Posts: 1693
Joined: 5/22/2005
From: Birmingham,England
Status: offline
Use the autosave or you will live to regret it!

(in reply to Volcano)
Post #: 6
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 7:38:10 AM   
Data


Posts: 3909
Joined: 1/3/2011
Status: offline
Let's say you load that, run the game at 4x speed and check if the attack occurs....if so, make a manual save just before it or even upload it as it is and we'll also run the game at 4x until we get there.

_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to Volcano)
Post #: 7
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 9:51:43 AM   
Volcano

 

Posts: 52
Joined: 3/25/2010
From: France
Status: offline
I ran the savegame up to the moment of the attack, but the attack didn't occur again, sorry, all I can give you is the autosave... I can also give you the normal save if you want to try to reproduce the bug.

< Message edited by Volcano -- 6/11/2011 10:40:46 AM >


_____________________________

Do not awake the dormant volcano...

(in reply to Data)
Post #: 8
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 10:36:17 AM   
Data


Posts: 3909
Joined: 1/3/2011
Status: offline
We can at least try so yeah, please upload them.....let's try and awake the dormant bug

< Message edited by Data -- 6/11/2011 10:37:44 AM >


_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to Volcano)
Post #: 9
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 10:47:49 AM   
Volcano

 

Posts: 52
Joined: 3/25/2010
From: France
Status: offline
Saves uploaded under names : "VolcanoAutosave1bugstations" and "Volcanobugstationsbeforeattack".

PS : you should clean up the FTP server from all the old files sent by players which you don't need anymore ^^


< Message edited by Volcano -- 6/11/2011 10:48:21 AM >


_____________________________

Do not awake the dormant volcano...

(in reply to Data)
Post #: 10
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 10:51:46 AM   
Data


Posts: 3909
Joined: 1/3/2011
Status: offline
that's Matrix's job (at Elliot's request I suppose). Personally I'm glad they keep them and I guess it doesn't hurt if they have the space for it....even with DW big saves

_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to Volcano)
Post #: 11
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 11:01:36 AM   
Volcano

 

Posts: 52
Joined: 3/25/2010
From: France
Status: offline
As you like it ^^ Let's hope these two savegames will help to kick Murphy and his law out of this game !

< Message edited by Volcano -- 6/11/2011 11:02:18 AM >


_____________________________

Do not awake the dormant volcano...

(in reply to Data)
Post #: 12
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 11:11:09 AM   
Data


Posts: 3909
Joined: 1/3/2011
Status: offline
Well, no luck leaving the game do it's job....so I'll edit a pirate frigate near the station. We should guess the proper moment to do it as I suspect this issues happend when the CS had a particular mission; fortunatelly we can keep an eye on all three of them in the left bar. Will report back.

_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to Volcano)
Post #: 13
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 11:21:31 AM   
Data


Posts: 3909
Joined: 1/3/2011
Status: offline
ok, so first frigate edited in destroyed the base
got another idea, since we know the second base is the narg 2 mining station I went to narg 2 and kept an eye on the CS ships...sure enough, the tenacious beggar got a mission at some point to build a mining station there
so we can save at this point and begin testing with attacking the research station. Now I have to go to work so I'll come back to this later.

_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to Data)
Post #: 14
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 11:35:41 AM   
Data


Posts: 3909
Joined: 1/3/2011
Status: offline
Ok, so I reproduced the issue. Here are the steps:

1) The CS goes to build the mining station at Narg 2

2) The research station is attacked and damaged (have located the nearest pirates and used a frigate of theirs to attack it)

3) Queue repair and the CS responds immediatelly while the mining station is not yet finished -> bug

4) The CS completes the mining station at the new location and then repairs the research station

5) The mining station at narg 2 magically dissapears from there although when the CS left it had only 14 components unbuilt.

Will test some more things but this is clearly a bug, queing should not work like this.

EDIT:

6) Even worse, the CS goes to refuel after this and then goes to build something else; all the CS seem to forget about the actual Narg 2 location now that the mining station is built.
I'll destroy it to see if that changes this behavior, we should at least have a workaround for this.

< Message edited by Data -- 6/11/2011 4:33:59 PM >


_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to Data)
Post #: 15
RE: [ROTS 1.5.0.8] Station moved in a wrong place - 6/11/2011 11:58:56 AM   
Data


Posts: 3909
Joined: 1/3/2011
Status: offline
Ok, so destroying the useless mining station does not trigger any of the CS to build another one at the proper location. I let the game run for two years with no luck; if this is somehow taken of an AI list than restarting the game may clear this and allow a CS to rebuild the mining station but I'll not try that.

I've also tested with a manual CS, let the tenacious beggar begin to construct a few components on auto, then put it on manual (and the construction continued), then queue the repair at the research station -> same behavior, no change.

And one really funny detail: while the CS was building the mining station on top of the reasearch station the mining station at Narg 2 was also completing lol. Once it finished it destroyed itself and only the badly placed one remained.

I guess the only workaround we have is to use the editor to correct all this but we'd have to catch the issue when it's happening.
Well spotted, Volcano, I'll stop my ranting at this point

< Message edited by Data -- 6/11/2011 4:37:26 PM >


_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to Data)
Post #: 16
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> [ROTS 1.5.0.8] Station moved in a wrong place Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.168