Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Bug or very strange behavior

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Bug or very strange behavior Page: [1]
Login
Message << Older Topic   Newer Topic >>
Bug or very strange behavior - 7/28/2009 3:50:12 AM   
pompack


Posts: 2559
Joined: 2/8/2004
From: University Park, Texas
Status: offline
Discrepancy: TF speed setting does not seem to change speed but it does change fuel consumption

Test Configuration: Guadalcanal scenario, H2H with Japanese and Allied stand-down. Create three task forces (TF 1, 2, 3) at Lville, each with a single cruiser (Astoria, Quincy, Vincennes respectively), all cruisers with zero damage and max speed of 32(9), cruise speed of 15(4), and a fuel level of 10,000. Note that a speed of 15 knots will really travel 9 hexes in two phases.

Set all three TF destinations to Sydney, with TF 1 set to “cruise”, TF 2 set to “mission” and TF 3 set to “full”.

Turn-Total distance (1,2,3)-Fuel remaining (1,2,3)
1 -------4,5,5-----------------9838,9795,9795
2------14,14,14---------------9430,9430,8344
3------23,23,23---------------9065,9065,6899
4------32,32,32---------------8699,8699,5454

Now the turn 1 distance was half the other turns, but I assume that is a scenario startup anomaly

The critical point is that at the end of turns 2,3,and 4 all three task forces were in the same hex, yet the TF set to “Full” was using more fuel.

Note that the TFs set to “cruise” and “mission” were traveling the correct distance each turn and using the expected amount of fuel. TF3, set to “Full” was traveling at cruise speed but using fuel for full speed.

EDIT: forgot to mention in test setup that Historical First Turn is OFF
Also note that column two list the total distance each TF had traveled since test inception

< Message edited by pompack -- 7/28/2009 3:18:02 PM >
Post #: 1
RE: Bug or very strange behavior - 7/28/2009 5:24:47 AM   
n01487477


Posts: 4775
Joined: 2/21/2006
Status: offline
I've seen this in WITP too, where you have 2 TF's in the same hex going to the same destination, different movement speeds and they end up in the same hex next turn and the next, with different fuel consumption. If this happens, I move them into different hexes for a turn and then it works fine ...

--Damian--

(in reply to pompack)
Post #: 2
RE: Bug or very strange behavior - 7/28/2009 1:31:04 PM   
Erik Rutins

 

Posts: 34726
Joined: 3/28/2000
From: Vermont, USA
Status: online
Pompack,

One thing in your report is confusing me. You list the TFs as having moved different distances each turn, but you report they ended up in the same hex? Is the distance traveled you list your estimate of how far they _should_ have moved, but not how far they _actually_ moved?

Regards,

- Erik

_____________________________

Erik Rutins
CEO, Matrix Games LLC




For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to n01487477)
Post #: 3
RE: Bug or very strange behavior - 7/28/2009 3:14:11 PM   
pompack


Posts: 2559
Joined: 2/8/2004
From: University Park, Texas
Status: offline
quote:

ORIGINAL: Erik Rutins

Pompack,

One thing in your report is confusing me. You list the TFs as having moved different distances each turn, but you report they ended up in the same hex? Is the distance traveled you list your estimate of how far they _should_ have moved, but not how far they _actually_ moved?

Regards,

- Erik

Erik:
Sorry for the lack of clarity

Column two lists the total distance each TF had moved since test inception

On turn one, TF1 only moved four hexes, while TF2 and TF3 each moved five hexes
On turn two, TF1 moved ten additional hexes, while TF2 and TF3 each moved nine additional hexes and all TFs ended the turn in the same hex 14 hexes away from the start point (L'ville)
On turn 3 each moved nine hexes ending in the same hex 23 distant from start
on turn 4 each moved nine hexes ending in the same hex 32 distant from start


I repeated the test and got the same results

Just for grins, I created exactly the same test in stock WitP (well almost, Sydney was not on the map so I set the destination as the lower left corner of the map). I got the expected result with TF1 and TF2 in the same hex and TF 3 way ahead of them.

EDIT: forgot to mention in test setup that Historical First Turn is OFF


< Message edited by pompack -- 7/28/2009 3:16:00 PM >

(in reply to Erik Rutins)
Post #: 4
RE: Bug or very strange behavior - 7/28/2009 8:18:15 PM   
Quixote


Posts: 773
Joined: 8/14/2008
From: Maryland
Status: offline
My results are the same as Pompack's - the Full Speed setting doesn't move TFs at full speed. I tested in the Coral Sea scenario, and tried several different TF types instead of just surface combat, but had no more luck than Pompack.

(in reply to pompack)
Post #: 5
RE: Bug or very strange behavior - 7/29/2009 2:18:27 AM   
jwilkerson


Posts: 10466
Joined: 9/15/2002
From: Kansas
Status: offline
We think we've isolated the issue an have an internal test build that seems to have resolved the issue. We will definitely have a fix for this in patch 01.

Looks like this issue was introduced in recent beta builds - as an "unintended consequence" - very unintended - since the offending change was related to ship damage and control of same.

Thanks for finding this guys!!!


_____________________________

AE Project Lead
New Game Project Lead

(in reply to Quixote)
Post #: 6
RE: Bug or very strange behavior - 7/29/2009 4:19:01 AM   
pompack


Posts: 2559
Joined: 2/8/2004
From: University Park, Texas
Status: offline
Each of us serves in his own way

(and it's a lot more fun than finding bugs for a living)

(in reply to jwilkerson)
Post #: 7
RE: Bug or very strange behavior - 7/29/2009 4:39:59 AM   
erstad

 

Posts: 1944
Joined: 8/3/2004
From: Midwest USA
Status: offline

quote:

ORIGINAL: pompack


Now the turn 1 distance was half the other turns, but I assume that is a scenario startup anomaly



Not an anomaly, per se. WITP only has the day impulse for the first turn. I assume AE is the same. (Think of the scenario starting at dawn, not dusk the night before)

(in reply to pompack)
Post #: 8
RE: Bug or very strange behavior - 7/29/2009 11:53:26 AM   
Barb


Posts: 2503
Joined: 2/27/2007
From: Bratislava, Slovakia
Status: offline
I can see mine TFs set to Cruise speed to move on Normal speed. Could it be the same?
Or is the "bombardment run" routine overruning cruise speed to get "in and out" during the phase?


_____________________________


(in reply to erstad)
Post #: 9
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Bug or very strange behavior Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.137