[Logged] ERROR: Object reference not set to an instance of an object. (Full Version)

All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support



Message


JFS737 -> [Logged] ERROR: Object reference not set to an instance of an object. (2/21/2021 2:42:11 PM)

Hi,
I was playing AEGEAN IN FLAMES with the latest .exe from a few days back from 2/15/21 at 1:57 AM. No other mods. I save the game each night, and after playing last night for hours... I did so. I closed the program, shut down the computer and when I tried to run it today (the saved file and ALL the Autosaves) I get the error in my Subject line.
All other scenarios run fine. This is 5 hours of my time from last night and REALLY hoping to save my progress and not have to go back and do it all again. It's a large and complex scenario. Can I get any help with this ? Kind of a big deal for me not to lose a night as I don't get to do that very often. DXDiag Attached.
I will attach the log from last night in the next message.

Thanks for ANY HELP !! :)





JFS737 -> RE: ERROR: Object reference not set to an instance of an object. (2/21/2021 2:43:51 PM)

Second message to include the CMO Log files




JFS737 -> RE: ERROR: Object reference not set to an instance of an object. (2/21/2021 2:50:36 PM)

Last one with the .save file I'm trying to run. Hmmm .... this forum won't let me upload a .save file. I will will rename it to XXXXX.ZIP from the .SAVE so to read it or load it just rename it back to .save

Thanks again




thewood1 -> RE: ERROR: Object reference not set to an instance of an object. (2/21/2021 3:53:47 PM)

You can also just use the built in zip capabilities in Windows. The forum only likes jpg, txt, and zip files.




KnightHawk75 -> RE: ERROR: Object reference not set to an instance of an object. (2/21/2021 8:22:19 PM)

@JFS737
Looks like something happened during the original save (producing a corrupted save file) as the order of nodes appears all screwed up. Might want to look though your exceptionlog.txt to see if what if anything may have been logged prior to trying to reload the save the first time as that will help identify where additional error handling needs to be added.

From the looks of it seems like something went wrong with a submarine (S 360 Inonu [Type 209-1400] guid:6446eb8d-959b-4d9c-a339-aa49cf398e11) while trying to save the magazine data and it ended up writing what should have been the rest of the units insides the mag entry for that sub (instead of closing out the mag entries and finishing the rest of the unit) and then it wrote the rest of the other nodes for the save file inside the sub's node instead of outside of it. It could probably be manually repaired if you don't mind losing the sub and have no save (or autosave) from before this.




JFS737 -> RE: ERROR: Object reference not set to an instance of an object. (2/21/2021 9:09:45 PM)

Hi,
Thanks for the info. On the Exception log, the file date modified is 2018, inside... the latest entry was from 2018. Not sure that is going to provide any info. On the rest of the info, thanks and wow.. I take it a text editor will not suffice? Not sure I can deal with a .sav file, and if I could, what would I fix in order to make it work? In any case, seems like I may be SOL. What a bummer, many hours down the tubes. All the Autosaves are bad as well, last save is from about 5 or 6 hours of gameplay back. Unless an easy answer drops in my lap, maybe I'll just take a break and restart the old save file later. Ouch.

Thanks
John




michaelm75au -> RE: ERROR: Object reference not set to an instance of an object. (2/22/2021 5:15:08 AM)

You may not have the game option on to save to the exception log?




KnightHawk75 -> RE: ERROR: Object reference not set to an instance of an object. (2/23/2021 3:31:20 AM)

quote:

ORIGINAL: JFS737

Hi,
Thanks for the info. On the Exception log, the file date modified is 2018, inside... the latest entry was from 2018. Not sure that is going to provide any info. On the rest of the info, thanks and wow.. I take it a text editor will not suffice? Not sure I can deal with a .sav file, and if I could, what would I fix in order to make it work? In any case, seems like I may be SOL. What a bummer, many hours down the tubes. All the Autosaves are bad as well, last save is from about 5 or 6 hours of gameplay back. Unless an easy answer drops in my lap, maybe I'll just take a break and restart the old save file later. Ouch.

Thanks
John

Yeah it'll take a little more than notepad.

Try the attached Post4967163_KH_Patched.zip, I can't speak to what else may be a little wonky, but I patched it such that the save does load under build 1147.16 without error and plays for a minute or two so without issue (I didn't test much more than that). Technically all I did was remove the unit where things got screwy and closed the tags where they in theory should have been closed. Suggest you play in the editor mode and maybe add back in a fresh copy of that sub on whatever side and missions etc it might have been on. I'm curious to know how it turns out.





WSBot -> RE: ERROR: Object reference not set to an instance of an object. (2/23/2021 4:28:21 AM)

0014413




JFS737 -> RE: ERROR: Object reference not set to an instance of an object. (2/24/2021 4:51:27 PM)

Wow,
Thank you VERY much! I got the file and it loads and runs for a few minutes fine. I can't play again properly for a day or 3, but I'll let you know. I have not replaced the sub and may not as I don't want to look at the scenario too much in the editor. If it hangs, I'll go into it. Thank you again!! I am excited to pick up on this and many hours of effort on my part has now been restored. Really appreciate it and I'll let you know in a few days if it's going along ok.

Regards,
John




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.0390625