Problems starting the game in Steam (Full Version)

All Forums >> [New Releases from Matrix Games] >> Armored Brigade >> Armored Brigade: Tech Support Forum


zeeschuimer -> Problems starting the game in Steam (9/26/2020 4:33:24 PM)


Now have the problem that the game does not start in Steam.
I get the startmenu and there is something strange already.
It tells me Nationpack: France - Belgium.
Now I don't have that nation pack (yet).
I only have the plain game and no mods or whatsoever.
Next, I get errorcode 51.

Now when I install the game from the downloaded files from Slitherine, there are no problems and the game runs without any problem.
So it seems Steam related.

I have no problems with any other game, even Matrix or Slitherine which i have quite a few.
I checked my anti-virus, firewall, other apps, but I don't find anything that points to this.
The other apps swithed off, one-by-one, no result.
Can you help me out?

Veitikka -> RE: Problems starting the game in Steam (9/26/2020 5:32:28 PM)

By the 'startmenu' you mean the Matrix launcher that has the DLC background texture, or something else?

The Steam error code 51 is an access violation error. Do you get the UAC prompt asking about making changes to the system?

In this thread it's suggested that Internet security programs can be causing the issue:

zeeschuimer -> RE: Problems starting the game in Steam (9/29/2020 3:42:12 PM)

See the attachment for what i mean with the start menu.
The UAC question is only generated when I assign the exe-files to run as administrator.
But when saying 'yes'I get an access violation.

Ok, I send you the same as I sent to Paolo from Support:

It happens more often to more games as I Google for it.
To me this seems as a shortcoming of steam.
On the other hand Slitherine has a contract with Steam in order to get her game promoted and sold.
I as client of both companies now seem to have to sort out where the problem is.
Donít you think this is the World upside down?
I will contact Steam as well, but I expect they will point at you.
It is like buying a car driving on fuel of company X.
Now the car doesnít drive, who is responsible?
You should know, not me.
I only drive the car ( the game in this instance) and pay both the car and the fuel.
Donít you think it is reasonable you find out as you sell your stuff through Steam?
The producer is responsible for things it produces to work properly, not the reseller.

I did everything I could find to solve this, even removed Steam completely from my computer including from the register.
Reinstalled steam and tried to run it. Same result. Faultcode 51.
Switched off antivirus and Firewall. Same result.
Switched off applications one- by -one. Same result.
Now EVERY other game I play through Steam works, only not this one.
Before you mention graphics drivers or audio drivers, they are updated.
The game runs when I download it from the Slitherine website, it just will not run on Steam.
Now I don't think I'm a beginner with computers and programs as I have them since 1987.
(Dos-8080 processor time...)
One shouldn't be a professor in computer science to run a b....y game?

Veitikka -> RE: Problems starting the game in Steam (9/29/2020 5:33:06 PM)

I have to say that my team is developing the game, Slitherine Production develops their launcher, and Steam develops the Steam client. I don't know what is the relationship between Slitherine Production and Steam, but to my development team they're pretty much like black boxes and we know hardly anything about their tools and methods. Unlike fixing a physical car that is taken back to the shop and examined there, I cannot replicate your issue here on my system and see what's wrong. In many cases all I have are the reports from the customer, and I have to make guesses to isolate the issue. These days there's a vast variety of different hardware and software combinations, and they can behave unpredictably.

Anyway, the DLC background texture is used by the Matrix launcher. That's normal and should not be related to this issue.

One difference between AB and many other games is that our game writes to the folder where the game is installed, and not to the Windows 'My Documents' folder. What is the drive and directory where Steam installs the games on your system?

I believe the Matrix launcher is not allowed to run ArmoredBrigade.exe. Have you tried running autorun.exe as administrator? Or Steam as administrator?

zeeschuimer -> RE: Problems starting the game in Steam (10/1/2020 11:17:39 PM)

For some reason this forum blocks what i answered you.
No it was not naughty...
So I add it as txt file.

Veitikka -> RE: Problems starting the game in Steam (10/4/2020 7:54:35 PM)

Good to hear you got it working. This might come handy to someone later, so I'm posting it here.


ORIGINAL: zeeschuimer
Hey Veitikka,

Let me start to tell you I solved the poblem after a 2 weeks puzzle.
I'm glad I wrote down everything I did and recorded it on OBS.
If you want the recording, I can send it to you.
I have Steam installed on a different drive (in my case a 1 TB Samsung QVO SSD) as Steam expands and I already had it once I had to reinstall as the drive was getting to small.
Next to that:
Operating System: Windows 10 Home 64-bit
CPU : AMD Ryzen 5
RAM : 32,0GB Dual-Channel Unknown @ 1066MHz (15-15-15-36)
Motherboard : Micro-Star International Co. Ltd B450 GAMING PLUS (MS-7B86) (AM4)
Graphics : 4095MB NVIDIA GeForce GTX 1650 (ASUStek Computer Inc)SLI Disabled
Sound : Corsair USB Dolby 7.1 Adapter
Operating System: Windows 10 Home 64-bit

So not a Stone Age machine and suitable for my purposes.
I play quite heavy games on it with ease (Squad, Post Scriptum)
Next to that I have quite a library of Matrix games running without problems.

Well, ofcourse developers are like a black box, it all happens in the brains.
Actually the game is a very nice product and I really hope more DLC's will come available.
Thing is,as perfectionist I am, I want it to run and if have it in my Steam library, I want it to run smoothless from there as well. But hey, I managed to get it running.

Now I only stated what I found not right and that included the nation pack thing.

Allright, I ran it as administrator, tried different compatability modes. None of these made any difference.
Running it after full installation from the installation files, downloaded from Slitherine, worked perfectly. So yes, I knew it had something to do with the connection between you and Steam. that conclusion can be drawn as any other game just runs without a single problem.

Allright, then what did I do to make it run?

1. fully removing Steam including the register of all steam related keys.
2. Reinstall steam including the Steam Service,
3. Make sure it runs on your account without any of the games in the library installed,
4. Make sure Steam runs as administrator,
5. Install Armored Brigade, start it and check fault code 51. (With me it did still)
6. Close Armored Brigade start up screen,
7. Restart the machine and if Steam make sure doesnít announces anything anymore about updates or anything,
8. Switch off all 3 network options of the firewall (Domain, Local and Public networks)
9. In F-Secure switch off Virusprotection
10. In F-Secure switch off Deep Guard,
11. In F-Secure switch off Ransomware protection
12. In F-Secure switch off Anti-Malware Scan Interface (AMSI)
13. In F-Secure switch off Web traffic scan (free translation, I donít know what itís called in the English version)
14. Start Armored Brigade and check if it will start up now (In my case it suddenly did!)
15. Now reverse the settings from step 8-to 13 one by one and start the game each time an item is switched on again, just to make sure.

I hope you have enough information this way.

Now I will start making scenarios

zeeschuimer -> RE: Problems starting the game in Steam (10/5/2020 8:45:37 PM)

Exactly why I share it, my man. Good you were able to post it. One note, I have the anti-virus through my internet provider, so there is like a shell around it. I think it is the same for the product direct from F-Secure. What is and remains weird, if you switch it of just by disabling anti-virus and firewall, it didn't work. It really has to be done in this follow up.

Page: [1]

Valid CSS!

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI