Independent Aliens nessecary? (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds 1 Series



Message


Unforeseen -> Independent Aliens nessecary? (7/15/2020 8:43:23 AM)

For some reason erasing them with the editor is causing my game to crash, took me all night to figure out what was causing it.




RogerBacon -> RE: Independent Aliens nessecary? (7/15/2020 1:33:46 PM)

Yes. In my Bacon mod I have a setting for users to override the lowest setting for independents, which has a default value of 150. The lowest value you can use is 1. I remember when I set it to zero there it crashed due to a divide by zero error. If you are deleting independent planets post-galaxy creation instead of manipulating the seed factor then your error is something different but I suspect it related. It does make me wonder whar happens in a game where the last independent planet is conquered. Maybe leave one indy and invade it and see what happens.




Unforeseen -> RE: Independent Aliens nessecary? (7/15/2020 6:37:40 PM)


quote:

ORIGINAL: RogerBacon

Yes. In my Bacon mod I have a setting for users to override the lowest setting for independents, which has a default value of 150. The lowest value you can use is 1. I remember when I set it to zero there it crashed due to a divide by zero error. If you are deleting independent planets post-galaxy creation instead of manipulating the seed factor then your error is something different but I suspect it related. It does make me wonder whar happens in a game where the last independent planet is conquered. Maybe leave one indy and invade it and see what happens.


Hey Roger! I changed the setting you mentioned to 1, it didn't immediately take effect. First game after changing it, it still spawns the independents but with very low pop. Backed out, created a new game and there were none. So far no crashes. I suspect since I was deleting them at the very beginning of the game there was some issue internally where the game was perhaps attempting to do something with them, and they were no longer there so it got confused? Who knows. Thanks for the fix!




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.03125