Problems with Uncommon Valour (Full Version)

All Forums >> [Current Games From Matrix.] >> [World War II] >> Uncommon Valor - Campaign for the South Pacific



Message


Leonidas048 -> Problems with Uncommon Valour (7/28/2003 11:32:21 PM)

Hi i bought Uncommon Valour a few weeks ago but after studying it for a while i decided because of lack of space to uninstall the game but when it was in the process of uninstalling it stopped and came up with a file problem saying that a Main App file had parameter error so i cancelled it then decided to uninstall the game from Wins Explorer which i cleared it from the directory.
But now when i went to reinstall the game i cant do it it has Go to main menu on the screen and when i set the wizard install setup instead i get the uninstall procedure repeating itself and stopping at that same problem file now it seems i am unable to play the game if theres a bug with the disk it is to late for me to return it to my retailers hope someone can help thanks.




Mr.Frag -> (7/29/2003 12:03:54 AM)

Since you didn't post what version of Windows you are running, I'll have to be pretty generic in my answer...

Run Regedit (click start button, select run, type in regedit)

Hit Ctrl-F (Find)

In the box that pops up, enter Uncommon Valor. Select it and delete it.

Exit out and re-run the installer now.




Leonidas048 -> (7/29/2003 12:14:25 AM)

Thanks for your prompt reply.My apologies for not being more detailed as i was in a bit of a state thinking i had lost the game my system is Windows 98Second Edition my computer is 466celeron with 256 RAM if this is any help i will try and do what i can then let you know if you need to evaluate what you said with my windows details i ll be around thanks.




Leonidas048 -> (7/29/2003 12:26:55 AM)

Hi i just done that i went into run at Startup and typed in Regedit but nothing happened.Maybe you now know my windows system it might help you to know what i should do.Also i notice the name of the game is still on my add & removal setup in my control panel setup and it still does the same thing there.Also when i copied all the files onto my h/drive it comes up unable to read data files so i cant d/load it that way hope you can help thanks.




Mr.Frag -> (7/29/2003 1:24:01 AM)

Might be regedt or regedt32 in Windows 98, been a long time since I played with it ...

Do a File search for reg*.exe if neither of the two above work.

This will not remove the software from the uninstall list as that is a separate reg key, but it should allow the software installer to think the software is not installed so it WILL all you to re-install the code.




Leonidas048 -> (7/29/2003 2:24:34 AM)

Hi there whoever you are i would like to thank you for your help.It wasnt as clear as you made out.But i found in windows directory the file called regedit and saw different folders i look in one or two then looked at one called software there under the Matrix folder i found Uncommon Valour with several files for registering etc so i deleted the whole lot and Matrix.Now ive just put in my disk and found the install switch.So thanks a lot for your help i got pretty depressed thinking i had lost Ģ30 and i didnt want to reset my computer as much as its a bit unstable at times so i know where to look next time with a similar problem and a good thing we have the forums well back to the jungle and take on the Japs.




Leonidas048 -> (7/29/2003 2:31:47 AM)

Hi there my enthusiasm was unfortunately premature i pressed the install icon and after the install wizard ran through it then again ask me again to uninstall the game and the same thing keeps happening so God knows what is playing up well any ideas someone thanks.




Mr.Frag -> (7/29/2003 4:03:22 AM)

Ok, now that you are a regedit expert ;)

Run it again. This time, you are looking for a different registry key.

This one will be hiding in the Uninstall key section ...

Search for "Uncommon Valor" without the quotes.

It should look something like this on the right side:

DisplayName REG_SZ Uncommon Valor 2.0
UninstallString REG_SZ C:\....\iun6002.exe "C:\....\irunin.ini"

Kill this one off as well as the one we were discussing before making a note of the C:\?windows?\iun6002.exe's location.

Go in and ensure you delete this iun6002.exe file after deleting the registry keys.

Shutdown and restart your system.

When you look under add/remove programs, Uncommon Valor should no longer be there.

Now do the install again. Sorry I can't be more help, but I haven't seen Win98 in many years so i am going off what I would do in Win2000/XP to fix ...




Leonidas048 -> (7/29/2003 5:10:55 AM)

Hi there thanks for your prompt attention but this time i think your advise has confused me.Ive gone into Regedit again and there are six different directories i found one sub directory called Control Panel under the Hkey Current Users there are install folders but not uninstall ones.The six directories in the Regedit file is-
HKey Classes Root
HKey Current User
HKey Local Machine
Hkey Users
HKey Current Config
HKey Dyn Data
This is what i have in the main Regedit file i looked through these files but cannot see what you told me to look for.I hope given you these details will make things a bit clearer for you to help me guide through each sorry if i seem to be awkward but its a pity this game behaved like it did i ll have to be more careful next time when this sort of thing happens hope to hear from you soon.




Mr.Frag -> (7/29/2003 5:32:12 AM)

As soon as you load Regedit, click on the VERY TOP LEFT entry. (My Computer)

Press Ctrl-F (to open find)

enter Uncommon Valor in the find box

You are looking for one that looks like my previous note shows as far as the entries on the Right side.

The left side will be uncommon valor 2 or 1 (not sure which CD you have).

Delete this left side key (uncommon valor xxx) ONLY! Do not delete anything else as you could completely kill your machine.

There should not be more then 3-4 matches to the search, one will be my original post, one will be my uninstall post, the others could be various other things.

The one you are looking to match on will have the iun6002 entry (this is the Uncommon Valor uninstaller assuming v 2.0 CD), it could also be a slightly different number (1.0 CD).

You can check which it is by looking in your windows directory for a iun****.exe file ...




wobbly -> (7/29/2003 5:36:17 AM)

How about doing a search for uncommon valor in the registry and deleting all keys involved with it.
Do an F3 type in uncommon valor
and then keep pressing F3 and deleting the keys until you get through the registry.
Try to delete as far out in the tree as you can. What I mean by this is don't delet form the root - be very specific about which keys you delete (like duh!!)
I would (although it does sound a little too late) take a backup of your registry. Take a copy of hkey local machine most specifically.




wobbly -> (7/29/2003 5:36:54 AM)

Mr Frag - you're just too quick out of the blocks!




Mr.Frag -> (7/29/2003 6:06:05 AM)

I feel for him, been there and done that a few too many times with various uninstallers that once hooked take a degree in Rocket Science to unhook from your machine. UV is pretty simple compared to some.

I always take extreme care with walking people through registry changes as deleting the wrong key can make you have to reload your machine. Always better to delete too little and have to try again then too much and not being about to try again ever ;)




Marc von Martial -> (7/29/2003 6:13:52 AM)

Just a quick question, did you purchase the game via our european distributor "Just Play" ?




Leonidas048 -> (7/29/2003 3:13:51 PM)

Hi there thanks for all of your advise i will try your methods but i am replying to Marcs interest to know which dist of game i have its the version dist by Just Play i d tried to get in touch with them and registered on their tech support but all they did was to thank me for joining and sent me no password to log in to get support so here i am.I let you know how i get on with your help thanks.




Leonidas048 -> (7/29/2003 3:27:58 PM)

Hi there i done both of the ideas you mention but it cannot find anything just my new setup root directory in my new drive when i tried to reinstall the game i ll keep trying until someone has a new idea thanks.




Leonidas048 -> (7/29/2003 4:43:13 PM)

One final thing i want to clarify the only place where i can find the name of the game is on my Add/Remove box in the Control Panel where its remained if thats any help thanks.




Mr.Frag -> (7/29/2003 8:54:59 PM)

What is the label of the CD? Uncommonvalorv20 or Uncommonvalorv10 ? (need to know what version you have)




Leonidas048 -> (7/29/2003 11:41:36 PM)

Hi there read your last message if you mean it should tell me what version i have on the CD disk i dont mean to sound stupid but i cant see anything it just says its dist by Just Play and the usual logos of the different distributors but it is the latest version 2.30 or something like that sorry if im not much help i appreciate all that you are doing looks like i ll have to wait until i get a new computer its really messed things up see you soon.




Mr.Frag -> (7/30/2003 12:37:09 AM)

If you open up My Computer, you will see your CD drive, with the name of the CD inserted. That is the volume label I am talking about. It is not anything written on the CD that you see with your eyes. Sorry about not being clearer, after 25+ years in computers, one assumes the language ;)

This is going to get interesting if it is the 2.30 version, as I have never seen it so I don't know what to look for as they may have changed what is used as an installer. :(




Marc von Martial -> (7/30/2003 1:06:28 AM)

The Just Play version is the latest version of UV , that is 2.30.

It is possible that Just Play made an error with the uninstall routine, although I doubt that. You will have to contact Just Play regarding this. Not much we can do here at Matrix, since thereīs no way to check the installer routine Just Play coded.

All I know is that we didnīt have this problem with our installer / uinstaller.




Mr.Frag -> (7/30/2003 1:47:16 AM)

Anyone else happen to also have this version?

I need a registry export to help further as I don't want to walk you into a dead machine.

To get a registry exported, you go into Regedit and use the export option on the File menu. (Full option instead of selected branch)

This file will be rather large (20-40 Megs) so you will need to compress it down to a email'able size to send it to me. It will compress down to 2-3 Megs.

To do the compression, you will need one of a million odd utilities for compressing files. (I personally like [url]www.winace.com[/url])




Leonidas048 -> (7/30/2003 1:47:44 AM)

Hi there thats what i tried to do before i got in touch with you.I reg on their site and all they did was to send me a thank you for reg but gave me no password to get in to explain my problems thats why i came to you.I ll try again and see if i can get through thanks for your help anyway.




Leonidas048 -> (7/30/2003 2:25:23 AM)

Hi i done as you said opened up the Export Registry files and then it shows me a box with all the Window system files which one do you want ? Or do i have to winzip the whole window system.Hope to hear from you soon.




Mr.Frag -> (7/30/2003 3:39:57 AM)

The export option should give you the ability to save the entire registry out to a file (you give it a name).

It will be called namegiven.reg

You will need to compress it up to be able to email it due to the size.

I just need that one file compressed, winzip is fine. Once you have that, tell me the size and I'll give you am email address that can handle the size.

I can not honestly remember all the options in the Windows 98 registry editor tool (I seem to recall there are two versions of the tool, one that gives you just the registry, the other that opens a whole bunch of extra files in other windows.)




Leonidas048 -> (7/30/2003 4:15:11 AM)

Hi there i found what you said so i have zipped all the files there.I named it namegiven.reg the file looks like a block of small blue towers there another one already done something like ADLPFd or something like that ive zipped the files anyway if you give me your email now thanks for you help.See you soon.




Mr.Frag -> (7/30/2003 5:00:21 AM)

Check your Private Mail here if it doesn't automatically pop a window when you come here.




Mr.Frag -> (7/30/2003 10:29:44 AM)

Evil! They are using Installshield now. Heres what we need to do:


Open a MSDOS prompt:

Copy this exact line and paste it into your dos prompt then hit enter.

DEL "C:\Program Files\InstallShield Installation Information\{64C33129-B37A-4AE8-B357-004C3E420AAE}\*.*"

That will take care of the actual installer which is killing you.

Next is to clean the registry entry:

Load up Regedit and do a Find again, Copy this into the find box:

64C33129-B37A-4AE8-B357-004C3E420AAE

It should match up and find this key:

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\{64C33129-B37A-4AE8-B357-004C3E420AAE}]

Delete just that branch on the left side (make sure just the above 64C33129-B37A-4AE8-B357-004C3E420AAE is highlighted.

You should then be a happy camper!

Edit (quotes added to command to deal with dos vs windows naming)




Leonidas048 -> (7/31/2003 4:17:57 AM)

Thanks for your trouble i will try it tomorrow thats quite a bit to write out in Dos and the rest of it i need to concentrate and do carefully.Is this something you are familiar with or tried it out?Well i let you know tomorrow what happens i ll keep my fingers cross but will this sort of thing happen each time i uninstall the game if it happens again what should i do or will this method you told me will clear up the obstruction?Thanks anyway.




Leonidas048 -> (7/31/2003 4:55:47 AM)

Hi there ive just read your instructions again one question i need to ask as ive never messed around with my computer like this before how do i go about pasteing that instruction in the MSDOS prompt can you explain actually how i do that from the Dos sorry if i sound rather stupid but i dont want to mess my computer up more thanks for your help.




Page: [1] 2   next >   >>

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
3.417969E-02