problem transporting Canadian unit (Full Version)

All Forums >> [New Releases from Matrix Games] >> WarPlan



Message


Dalwin -> problem transporting Canadian unit (6/8/2020 1:21:27 AM)

I had a Canadian corps ready in time to defend France. I had no trouble shipping it there, but I was unable to ship it out when it was time for the BEF to leave. The Canadian unit would always show that it had zero transports available.

Isn't he supposed to be using the British ones? Also, if that is not so and Canada has zero, how was I able to ship him to France in the first place? To my understanding, transports are not single use items like landing craft.

Before it is suggested, no Canadian transports (or transports of any kind) have been sunk up to that point. The ports in question (I tried more than one) were not damaged and the UK had no trouble evacuating from those same ports.




AlvaroSousa -> RE: problem transporting Canadian unit (6/8/2020 3:36:56 PM)

Are you sure you had plenty of transports? You might have moved something and not have had enough.




Dalwin -> RE: problem transporting Canadian unit (6/8/2020 11:12:52 PM)

I am very sure. The UK had approximately 160 free transports at the time. Other units were able to leave after the Canadians were not allowed to. Also when the Canadian unit was selected it showed zero transports available, but changing to a UK unit would then show 160.

Clearly the Canadian unit is not being allowed to use UK transports, though somehow I was able to ship it to France in the first place.

Answers like maybe I can read in game basics like number of transports, is simply denial. Here is a bug. Denying it is not going to get it fixed.




AlvaroSousa -> RE: problem transporting Canadian unit (6/8/2020 11:59:20 PM)

The UI I need to fix so it shows UK transports.
Did you try to embark it even though it said zero.

I will run some tests.




Dalwin -> RE: problem transporting Canadian unit (6/9/2020 7:39:41 AM)

The option to embark was greyed out. I did try to click the button anyway. I thought something may have been wrong with the first port (Dunkirk or Calais) even though it was not in enemy ZoC. I moved it to Cherbourg instead, but on the next turn was still unable to transport.

It is not just that it is showing zero transports. It is actually not trying to use the British ones at all. I did make some more Canadian ones, but those went straight to the British pool as they are supposed to.




AlvaroSousa -> RE: problem transporting Canadian unit (6/9/2020 2:15:00 PM)

Ok I'll look. I haven't had this problem but new bugs arrive every time. Thanks for finding this. I'll do some testing today.




sillyflower -> RE: problem transporting Canadian unit (6/9/2020 4:24:10 PM)

On a related note, I did try a while ago to do an invasion with a canadian xx using canadian landing craft. It would not let me because I didn't have any LCs. I had 20 canadian LCs but I didn't have any UK ones




AlvaroSousa -> RE: problem transporting Canadian unit (6/9/2020 4:38:18 PM)

It should all transfer to UK and be used by Canada. Next beta this week will have this.

I will you there are so many things in a WW2 Wargame like this that are so hard to realize when developing. I understand why most games are 1 unit 1 hex this simpler. And the more complex games are just land battles. Putting it all together is tough. But I learned a lot and WP2 will be even better.




Dalwin -> RE: problem transporting Canadian unit (6/10/2020 10:00:20 PM)

Perhaps it has only been a graphical glitch after all. I tried again to evacuate the Canadian unit and succeeded even though transports still shows zero. I hope my opponent regrets not killing him instead of letting him hold Cherbourg for 3-4 turns after France surrendered.

While we are talking about the display of support assets for minor countries, it should also show the stockpile of the parent country in the minor country production screen. This makes it a lot easier to decide which support units the minor country should build. I find that in the long run a lot of their production goes to that.




AlvaroSousa -> RE: problem transporting Canadian unit (6/11/2020 3:48:31 AM)

Yes that is what I missed when I changed the way it works




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
2.246094E-02