division by zero (Full Version)

All Forums >> [Current Games From Matrix.] >> [Napoleonics] >> Empires in Arms the Napoleonic Wars of 1805 - 1815 >> Tech Support


tx_fella_2010 -> division by zero (12/23/2019 2:15:33 PM)

Hello there,

I tried to post a screenshot, but, as I am not yet at 10 posts I can't. My old account I couldn't recover.

I used to play this game a lot back 5-10 years ago. I recently got interested in Napoleanic era again so I re-downloaded and installed. I get "Division by zero" error floating off the bottom right hand of the screen - hundreds of pop-ups of this error but the game menu screen is appearing behind them. Only thing I can do is task manager close the task.

I followed Zakblood's install guide - DR1.05 to 1.022.

Running 3840x2160 laptop in 1600x900 resolution. Win10 Pro. Tried uninstall, reinstall. Checked 96DPI setting is used in regedit - 100% scaling set in Display. Tried Win XP Compat Sp2 and Sp3 and even Win 8. Tried to let the program troubleshoot itself.

Any ideas?


pzgndr -> RE: division by zero (12/23/2019 4:29:18 PM)

Haven't seen division by zero in a long time. I have found the old original installer to be finicky with newer comprehensive patches. You cannot simply install the original and immediately install the patch.

What we suggest is:
1. Perform a clean original installation.
2. Start the game and open a scenario, to set configurations.
3. Reboot.
4. Install the patch and then any hotfix EXE.
5. Be sure to set compatibility to WinXP SP2 and run as Administrator.

This should be done for the last official v1.22.02 patch/hotfix and separately for the v1.23.00 beta and v1.23.04 beta hotfix. Just rename the beta directory as \Empires in Arms Beta or something like that. Hope this helps. Enjoy!

tx_fella_2010 -> RE: division by zero (12/23/2019 7:10:43 PM)

Hi Bill,

Thanks for the quick reply.

Seems to still have the same problem. I kicked back to the earliest installer I could find on the current download page. Got a slightly different result - got the division by zero error box, about a hundred of them rolling off the screen, then the program just closed.

Any other thoughts or ideas? I have never encountered this before with any of my old matrix titles so it's new to me as well.


pzgndr -> RE: division by zero (12/23/2019 9:31:08 PM)

I donít know. Maybe run uninstall, reboot, and try again. Is the original game install running ok? Then reboot and install the comprehensive patch. Which version are you running, v1.22.02 or the v1.23.04 beta, or both? If still not working, maybe someone else has a suggestion or Matrix tech support could help.

Page: [1]

Valid CSS!

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI