Two bugs (Full Version)

All Forums >> [New Releases from Matrix Games] >> WarPlan >> WarPlan Open Beta Versions



Message


sawtooth9993 -> Two bugs (12/18/2019 1:02:47 AM)

1. Disembarked a British unit in France to go back to Britain. All was well until I moved a French fleet onto the disembarked British unit (to help escort it). Upon doing this, the disembarked British unit disappeared and all I could see or interact with was the French fleet. This was all before a French surrender.

However, upon doing this with another British unit and French fleet, everything worked out great and the fleets merged successfully.

I think the key difference is that the broken fleet was set to do not repair. This is the fleet that, when merged with my disembarked British unit, made the Brits disappear.

2. I have a British fleet docked in Norway, which is currently at war with Germany. Upon selecting the British fleet, I cannot move it. I have oil stockpiled and 3 supply in each ship. Splitting the fleet does not help. They are in fleet mode. When selected, the map does not "darken" to indicate the range which the fleet can travel. Nothing changes and I get no movement markers to even attempt a move.

To my knowledge, I have installed the open beta correctly.

Thanks!




AlvaroSousa -> RE: Two bugs (12/19/2019 12:08:52 PM)

I'll take a look at this




AlvaroSousa -> RE: Two bugs (12/19/2019 2:20:56 PM)

Ok I read this but I am not following could you please verify your statement.

BUG (A)
#1 you disembarked a unit (a land unit from a fleet to land)
#2 you moved a french fleet to escort a disembarked UK land unit now on the land and not in a fleet
#3 now the UK land unit on land vanished but the fleet stayed.

Note that the UK land unit is on land and you moved a fleet to it's location by the end of the interaction. Is this right?

BUG (B)
You might be in a frozen port if this was an early game when WarPlan 1st came out. So please specify the hex location you mean.




sawtooth9993 -> RE: Two bugs (12/20/2019 2:15:17 AM)

Sorry, I misspoke.
Bug A
1. EMBARKED a UK land unit (land unit from land to fleet) on a French port
2. Moved a french fleet to escort the EMBARKED UK unit
3. When the fleets merged, the embarked UK unit disappeared, leaving only the French fleet

I did the same thing with another unit. Same scenario, just a different French fleet, different French port, different UK land unit. This one worked fine, no issues. There was the difference in that this fleet was set to repair/upgrade, while the broken fleet was set to do NOT repair/upgrade.

Bug B
This happened using the open beta combined with update v1.00.04, so this was probably not the case. The hex was 148,75. A game reload fixed the issue, but it's a bug nonetheless (unless I borked the open beta install).




AlvaroSousa -> RE: Two bugs (12/20/2019 2:24:00 AM)

Ok. Now I get it. That is weird. I will try to replicate it. The repair has nothing to do with the load/unload. This is something else.




AlvaroSousa -> RE: Two bugs (12/20/2019 3:18:21 PM)

I can't replicate this error.

Please do the following if it happens again send me the output.txt log

Error game logs are here
C:\Users\"your user name"\AppData\LocalLow\Kraken Studios\WarPlan\output_log.txt




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
2.099609E-02