Map edge loop error (Full Version)

All Forums >> [New Releases from Matrix Games] >> Strategic Command Series >> Strategic Command WWII: World at War >> Tech Support



Message


pjg100 -> Map edge loop error (8/5/2019 9:30:23 PM)

In a solo hot seat game, I moved the US west coast carriers south to the "South America" loops. At the end of the turn, I received a message that the ships were in transit. However, four or five turns later they have not shown up. Seems like a bug.




BillRunacre -> RE: Map edge loop error (8/6/2019 3:09:48 PM)

Hi

I've checked the scripts and no issues are jumping out at me, and if the Loop fails they should return to their original starting position 2 turns later.

Are you able to give me the hex coordinates they're sailing from?

For reference, here are each script's starting and finishing locations:

#NAME= Pacific To South American Coast (North)
#START_POSITION= 295,82
#START_POSITION= 295,83
#START_POSITION= 295,85
#START_POSITION= 295,86
#START_POSITION= 295,88
#START_POSITION= 295,89
#FINISH_POSITION= 2,83
#FINISH_POSITION= 2,85
#FINISH_POSITION= 2,87
#FINISH_POSITION= 2,89
#FINISH_POSITION= 4,84
#FINISH_POSITION= 4,86
#FINISH_POSITION= 4,88
#FINISH_POSITION= 4,90
#FINISH_POSITION= 6,85
#FINISH_POSITION= 6,87
#FINISH_POSITION= 6,89
#FINISH_POSITION= 6,91

#NAME= Pacific To South American Coast (Middle)
#START_POSITION= 295,94
#START_POSITION= 295,95
#START_POSITION= 295,97
#START_POSITION= 295,98
#START_POSITION= 295,100
#START_POSITION= 295,101
#FINISH_POSITION= 6,96
#FINISH_POSITION= 7,97
#FINISH_POSITION= 8,99
#FINISH_POSITION= 9,100
#FINISH_POSITION= 8,95
#FINISH_POSITION= 9,96
#FINISH_POSITION= 10,98
#FINISH_POSITION= 11,99
#FINISH_POSITION= 10,94
#FINISH_POSITION= 11,95
#FINISH_POSITION= 12,97
#FINISH_POSITION= 13,98


#NAME= Pacific To South American Coast (South)
#START_POSITION= 295,109
#START_POSITION= 295,110
#START_POSITION= 295,112
#START_POSITION= 295,113
#START_POSITION= 295,115
#START_POSITION= 295,116
#FINISH_POSITION= 7,115
#FINISH_POSITION= 9,115
#FINISH_POSITION= 11,115
#FINISH_POSITION= 7,117
#FINISH_POSITION= 9,117
#FINISH_POSITION= 11,117
#FINISH_POSITION= 7,119
#FINISH_POSITION= 9,119
#FINISH_POSITION= 11,119
#FINISH_POSITION= 7,121
#FINISH_POSITION= 9,121
#FINISH_POSITION= 11,121




pjg100 -> RE: Map edge loop error (8/6/2019 8:24:26 PM)

They entered the loop at 295,82. One on the first Allied turn, the second on the second Allied turn. As of the 1/5/1940 Allied turn, they have not emerged on the other side.




BillRunacre -> RE: Map edge loop error (8/7/2019 3:09:16 PM)

Thanks, I'll run a test on it.




pjg100 -> RE: Map edge loop error (8/11/2019 8:39:49 PM)

Started a new solo hotseat game. Ran the US west coast carriers down to two different loops (295, 85; 295, 94) on the second and third Allied turns. It is now 12/8/39, and neither of the carriers has appeared off of South America (or anywhere else). Also, I ran the corp in Washington, D.C. to the eastern Beaver loop on the first turn; it has not yet appeared in Beaver. So, something is broken.




pjg100 -> RE: Map edge loop error (8/12/2019 11:14:24 PM)

Following up on this - it is now Jan 5, 1940 and the US CVs and corp have finally appeared in the destination hexes. They went into the transit loops in the first and second Allied turns.




BillRunacre -> RE: Map edge loop error (8/13/2019 6:17:10 PM)

Thanks for the update.




pjg100 -> RE: Map edge loop error (8/13/2019 6:19:59 PM)

So I reloaded some of the prior turns in hotseat and hit "replay prior turn" to see what would happen. It appears that this bug has something to do with whether I run a replay of the prior turn. If I don't, the units never complete the loop. If I do, they show up when expected.

Also, I noted that if I load an old turn and hit replay, it shows replay of the same side's prior move (e.g., it shows the Allies' prior move when starting an Allied turn), not a replay of the other side's prior turn. However, it correctly shows a replay of the other side's prior turn when playing subsequent turns.




Hubert Cater -> RE: Map edge loop error (8/15/2019 7:08:37 PM)

Hi PJG100,

I'm not able to repeat the loop issue, and it could just mean that whatever the issue was under Hotseat, it is now fixed on our end for the next update. I just suggest this as there was an issue we discovered that did not have beginning of turn DECISION events fire, and perhaps the error was related to that.

Regarding the replay of your prior moves when starting the turn, this is correct as it allows players to review previous moves of an incompleted turn when playing with more than 2 players under Hotseat.

For example, if you are playing as the USSR and your friend is playing as the US, you can review his moves before you play your moves and so on. Then once the turn is completed, your opponenet will see all the moves combined.

Hope this helps,
Hubert




pjg100 -> RE: Map edge loop error (8/15/2019 8:52:29 PM)

Thanks Hubert.




pjg100 -> RE: Map edge loop error (8/22/2019 6:29:17 PM)

I am playing another solo hotseat game from the start (1939) and this problem has surfaced again. I ran the US carriers down to the Pacific to Atlantic transfer loops and some US land units to the east coast Beaver transfer loop. It is now late 1940 and all of these units have disappeared, never to be seen again. I have been replaying prior turns every turn. So there is definitely a problem here. I checked the scripts and the transfer loops are there; they are just not working. The Gibraltar loop works fine. Please let me know if you have any idea as to how to retrieve these lost units.




BillRunacre -> RE: Map edge loop error (8/22/2019 8:39:37 PM)

I don't know, it's very odd. It would be good to know if anyone else is experiencing this (or not)?




Hubert Cater -> RE: Map edge loop error (9/10/2019 9:13:43 PM)

Hi PJG100,

I was able to repeat this and the error, it is under rare circumstances which explains why it was not easy to repeat, but it will be fixed for a future update.

Hubert




pjg100 -> RE: Map edge loop error (9/11/2019 9:53:26 PM)

Thanks Hubert.




pjg100 -> RE: Map edge loop error (10/5/2019 5:44:16 AM)

This is still a problem in 1.05.




Hubert Cater -> RE: Map edge loop error (10/9/2019 4:53:20 PM)

Can you confirm that this is with a new start to the campaign?

If so, can you confirm what mode you are playing? Hotseat, AI, PBEM++?

Thanks,
Hubert




pjg100 -> RE: Map edge loop error (10/9/2019 7:14:07 PM)

Thanks for looking into this Hubert. It was a new game started under 1.05. Hotseat, single computer. Same issue - US carriers entered the loop in the Pacific south of San Diego and did not exit on the other side, and a ground unit entered a ground loop in the US southeast and did not exit on the other side. No exit after two Allied turns; I exited the game after that so don't know if they might have shown up on some subsequent turn.




Hubert Cater -> RE: Map edge loop error (10/10/2019 6:49:03 PM)

Hi PJG100,

I just can't repeat it. Could you give me exact steps? If you can, please include all your details such as if you are saving in between, reloading a turn and so on.

Could you also provide which campaign you are using and what turn you are in. For example, if you start with the 1943 campaign and work through the first few turns to achieve using the loops, i.e. Axis turn and then the subsequent Allied turn, does it happen for you?

Thanks,
Hubert





pjg100 -> RE: Map edge loop error (10/10/2019 8:57:17 PM)

1939 campaign. Hotseat, one computer, playing both sides. First Allied move, one west coast carrier goes to the northernmost transfer hex, and one land unit (the corp, I think) on the east coast forced marches to a transfer hex in the southeast US. Second Allied move, the second US west coast carrier goes into the loop, same transfer hex. Saving at the end of each turn. Playing through in one session, not quitting and reloading in between. I don't recall whether I played back prior turns. No US units appear on the other end of the loops by the fourth Allied turn. I quit the game a few days ago, probably saved over it. Hope that helps.




Hubert Cater -> RE: Map edge loop error (10/12/2019 11:26:39 AM)

Thanks for the info and I've tried repeating the exact steps as described and simply cannot repeat it. Is there anything else you could provide, perhaps you were playing the last turn replays in between, passwords were applied to the two sides or not etc.?

I'm just looking for some odd combination that might be creating this just for your end for some reason.




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
4.296875E-02