Steam not running error (Full Version)

All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support


RevReese -> Steam not running error (4/3/2019 12:59:14 PM)

Hi everyone,

I am experiencing the following error upon trying to launch Command from Steam:


"It appears you are running Command in Steam mode, but the Steam client does not appear to be running. Please ensure the Steam client is running before starting Command. The game will now exit"

I have posted on the Steam forums but thought i would post here as recommended on the forums.

I am running Windows 7 64 and using the latest version of Command with all expansions and DLC.

I am running the latest build of Steam too and it is not installed under Program Files or Program Files x86.

I have tried starting Steam in Offline mode and restarting again in online mode and same problem.

The Command.exe is set to run as admin by default and i cannot seem to change this, clicking "change settings for all users" removes the tick but upon closing the window the box is ticked again.

I have tried adding the steam_appid.txt file to the game directory as suggested and though it seemed to work for others, it did nothing for me.

I have tried rebooting my system numerous times to no effect, the problem remains.

I have verified the game integrity via Steam numerous times again without issue.

I have tried using the NetFxRepairTool.exe from Microsoft though this did nothing either.

I have disabled the Steam Overlay and DirectWrite.

I have only installed the Scenario Pack 40 and the database images and descriptions manually (not via steam workshop).

I have tried moving Command to internal HDD rather than external just in case as I have had one or two games in the past that needed moving to internal but same problem.

I am using Avira AV and ZoneAlarm firewall neither of which throw up any issues.

The only thing that works that i can find to try is run Steam in Admin mode (this works and loads the game normally but it is inconvenient to have to keep switching Steam to admin mode every time i want to play) I never used to have this problem, Command used to run just fine from a Standard user account in the past.

I am prompted for admin password every time i click play on the main launcher, just before the above error message comes up.

I seem to have run out of further ideas so if anyone can help me i would be very grateful!

Thank you for your time.

RoryAndersonWS -> RE: Steam not running error (4/3/2019 3:34:17 PM)

Hi, perhaps try uninstalling and reinstalling Command via steam? Then verifying that the directory is completely deleted. It sounds related to Command.exe being set to run as admin by default.

RevReese -> RE: Steam not running error (4/3/2019 5:02:30 PM)

Hi, thanks for your reply.

I uninstalled and deleted every trace of Command from my system then reinstalled but exactly the same issue, it prompts for admin then gives the steam not running error.

You are right though, command.exe is set to run as admin by default though i cannot change this.

I am at a loss as others have fixed the problem by using at least one of the methods i have tried.

Stonedog -> RE: Steam not running error (4/3/2019 6:14:07 PM)

It did not need to be fixed till the latest update, yesterday or so.That was the first time I ever had that happen to me with any game, and thats in 10 years on Steam.

Heres what you can do if you wish, though I would like to know if this is a bug from the latest build or if theres is a reason it was changed/happened so suddenly.\

OK,Try doing this

Right click Command in Steam Library---Lclick Properties---Dialog box pops up go over to the LOCAL FILES TAB and click that TAB--------Lclick LOCAL FILES......Then find your Command .exe ---Rclick COMMAND.exe ---in pop up box Lclick Properties---- Pop up box it should be the second TAB named COMPATABILITY, Lclick this and in the box that says run Command as ADMIN UNCKECK this and then LClick APPLY at bottom right corner of the box---L Click OK.

Close everything out and then I highly recommend rebooting both your machine and of course STEAM. If this does not work for you, it may be that you need to Disable STEAM CLOUD SAVES in your Steam settings.

Hope it helps, and curious as to why this is happenig so if you find out please send me a message here on Matrix.


Stone Dog

RevReese -> RE: Steam not running error (4/3/2019 6:45:28 PM)

Hi thank you for your reply.

I originally noticed this beginning of December 2018 but was just told on the Steam forum that it is normal to have to run steam as admin so i dropped it until finding another post with someone having the same issue and how they fixed it.

I cannot untick the "run as admin" box it is greyed out unless i click "change settings for all users" then the box is unticked.

However, on clicking ok, it is ticked again.

I did try to see if there was an option to only deselect cloud saves for Command, sadly i couldn't find one and i don't want to turn it off globally for all my other games.

Edit: I did try turning cloud saves off but nothing changed.

Can you think of anything else i could try?

Stonedog -> RE: Steam not running error (4/3/2019 6:56:32 PM)

Yes, and I am sorry that I did not think of this before. YOU need to be logged in as the ADMIN in order to change this on your System most likely is why you are seeing the error. If its been there since December , then this is the first time its ever triggered for me, also seems like a Dev Reply here would have told you in detail thats what it was, and exactly how to fix it. Thats the first I have even heard that, I believe you when you say that, but thats not been the case for me, and no one else on Steam has posted much about it that I have seen though I am going to go look. Believe me, on STEAM this would have been a "End of World conspiracy issue" in the forums so I would have noticed by now I think.

Still, I may be wrong but I do not believe I am. Just log onto your system as ADMIN and the change it. Also you might run Steam in Admin mode while doing it but that should have nothing to do with the changing of the .exe. Keep me posted please Sir, if you do not mind on how this works for you. Happy to help again if its need too.

Stone Dog

Stonedog -> RE: Steam not running error (4/3/2019 7:09:21 PM)

To simplify the Admin you can just Right click the Folder Command is installed in and choose OPEN as Admin , or it will be a very similar name but will have the AS ADMIN command in it. If that does ot work then you will have to either boot into Admin or log off current windows account and then log back into Windows as the Admin. Also you might disable Steam Cloud Saves , if you have not already. It has a nasty habit when its enabled of writing back over anything you delete,Edit,Save in Steam otherwise and you will think that the fix has not worked, when you actually did not even test it due to the CLOUD SAVE re-write of the very thing you tried to change.


Stone Dog


C:\Program Files (x86)\Steam\steamapps\common\Command Modern Air Naval Operations

RevReese -> RE: Steam not running error (4/3/2019 7:36:02 PM)

Hi Stonedog thanks again.
I logged off my standard account and logged in as Admin changed the run as admin option under compatibility no problem..

But, upon logging back in on my account, the run as admin was ticked again as before putting me exactly back where i was!

I posted in the steam discussion forums in December about this issue but received no useful replies then, i have reopened that thread now and been posting in another thread by someone with the same problem.

Between all of us i am sure we will get it running!

Stonedog -> RE: Steam not running error (4/3/2019 7:46:54 PM)

Something is up, I changed mine with no issue at all. I always run my system as Admin(4 kids will teach you to be the only one able to do that fast [:)] ) , I just ran Steam in admin mode and went to the .exe and unchecked it then hit the apply box for the .exe properties and was done. What version Windows are you running, because you should be able to change that easily, so somewhere we have missed a step getting you into ADMIN or with my poor instructions on the way to do so , in our communication process here .

If you cannot change that, its important that you test another file, of any kind and see if you can change it, test a couple, both in Steam and just a non Steam file. Does not matter which but unless we missed something in the steps, then theres more going on on your end. That said , the actual problem you are having is all to real , and frustrated me for longer than I like till I thought about what would actually cause something like that. There are very few things that do, and the only change that was made for me, was the small updates to my CMANO and the DLC that go with it that happened yesterday, so we know who/how it has occured , just need to sort out the Why , is it in error , or is there a reason they changed it . I have seen no mention of it and I have looked for one, still in process of doing so.

RevReese -> RE: Steam not running error (4/3/2019 8:06:34 PM)

I had logged out and into Administrator completely no problem and changed the setting successfully, but upon logging back in to my account it had reset somehow.

I also, ran Steam as Admin and tried to change the option but it was still greyed out.

I am on Windows 7 64 bit and cannot make changes to steam game .exes or non-steam .exes as i tried a few but the option to run as admin under compatibility was greyed out on all of the test .exe files.

I CAN however right click and "Run as Admin" on all the files and enter the password to open them.

Only FSX:SE and War in the East seem to have this requirement that Steam run as admin, it is odd that it happened for me a lot earlier back in December when everyone else seems to only just have it happen to them.

Stonedog -> RE: Steam not running error (4/3/2019 8:10:11 PM)

OK MAN here is something that is a 100% fix, and if this does not work will tell us if its simply a mistake you or I are making in getting you into ADMIN mode, OR if we need to think about other possibilities...

Simply log in as a Administrator on your Computer and , IF YOU HAVE STEAM INSTALLED IN C DRIVE ......................................... (Referring to Steam itself),.................. Then you need to Navigate in your file manager for which ever version of Windows you run and open up the STEAM folder....C:\Program Files (x86)\Steam is the default installation path. Now in that folder find ... Steam.exe .... Right click that file and then....................... Left Click the tab named COMPATIBILITY ........Now in that box there is a area thats called SETTINGS....CHECK the box there that has " RUN THIS PROGRAM AS AN ADMINISTRATOR" .....GO to the bottom of the pop up you are currently in (STEAM.exe PROPERTIES is where you should be still) , you should have three option ...OK -- CANCEL---APPLY.... Click on APPLY ....and after that if necessarry click ok then close things out and that should enable Steam to run in Admin mode everytime you launch it without any more input from you being required. Its will not hurt anything that is currently running on STeam to run it for all games this way. If someone tell you it will, and if you ask enough someone will, they are simply just wrong.

That will launch STEAM in admin mode which in turn will launch CMANO and any other game you have and should help you with having to always manually doing it for CMANO.

RevReese -> RE: Steam not running error (4/3/2019 8:19:42 PM)

Hi, thanks again, i can run Steam as admin no problem and launch Command that way without issue.

The issue is the fact that it is inconvenient to have to run Steam as admin for only a couple of games when the rest of my steam library does not.
If i have steam launch as admin all the time (which i can do though i don't want to) i will lose access to all the saves and mods from my other games that do not have steam elevated.

I also have a number of games heavily modded and who knows what could happen to them if steam runs as admin constantly!

Thank you for the clear steps though, i appreciate it. [:)]

Stonedog -> RE: Steam not running error (4/3/2019 8:30:39 PM)

Its your Anti Virus thats not letting you change the .exe file or others I bet. Can shortly disable it and change then turn back on. Hope things get solved for you and if you need my help more feel free to shoot me a message .

As far as running Steam in Admin mode, it will have NO affect/effect or impact on any of your other games as running them in admin mode will not hurt any of them. I have done it for as long as I remember , I own a 130 plus AA and AAA Titles, and have many many of them modded. That should truly be a non issue for you. Thought you might want to know that , incase someone has told you otherwise. Whether you have a game Elevated or not will not matter, You can run your STEAM in Normal or ELEVATED mode and they will function as normal, at least the 100 plus I own do and any that would not (God only knows why they might not) would normally tell you not to in its documentation somewhere.

JUST LIKE ONE THAT REQUIRES IT, OR HAS MADE A CHANGE THAT REQUIRES IT AFTER YEARS OF NOT DOING SO, should be doing.! Especially when a user/player is asking for help or comment on a very slow day question wise for the support team. It was not that late when this started .:)

RevReese -> RE: Steam not running error (4/3/2019 8:44:23 PM)

I checked my AV, even disabled it briefly to double check and nothing changed.

I only mention about my other games as i know at least one of them (ETS2)does not recognise mods installed or saves if i run steam as admin, i figured if that does then others may too. [&:]

I will bear in mind your advice though as i have been running steam as admin on and off for those three games for a long time, i just noticed people having trouble more today and thought i would try my luck at a fix.

FSX has always needed admin and so does WitE as far as i know (though War in the West does not). I just want to be able to run Command without closing steam everytime.

I understand that it shouldn't affect anything but i am just not that comfortable running anything as admin unless i really need to.

Stonedog -> RE: Steam not running error (4/3/2019 9:03:03 PM)

I completely understand, and honestly doing so , or having to do so just to run , or make run properly, software, or a game of most any kind is not a fix, but a mask for known problems that either have not yet been solved for that software, or the team simply cannot and fears breaking more of the code if the do so.There are some valid reasons that it can be required , but not many at all.

Man I hope you get it solved, as I am thinking I have failed to give you a step in the process, something that I may do so often I dont even know I do any more.

Feel free to be in touch if I may be of any assistance to you, I rarely post over here, but when I seen your topic I was on it fast, as I am more than curious as to why this occurred. Probably nothing more than a simple error when they were editing the code or debugging it before they pushed the update and nothing more than that. Still...........makes one wonder why its not been acknowledged yet if its that simple, you know :)

Cheers my friend, you may reach me as the User Stonedog if you need too, on Steam. If required , there are more and more clones of me everyday, then Choose the Stonedog Thats lvl 74 or higher 10 years service and has a quote by Napolean or Churchill on his profile.

Stone Dog

RevReese -> RE: Steam not running error (4/3/2019 9:49:49 PM)

Cheers Stonedog, although i am still where i was when i started, someone else reading this could be helped by the steps we have taken.

Hoping it is just a technical oversight and will get sorted quickly, the devs are always working hard on the next update so fingers crossed!

You haven't failed in any way, don't worry about that! lets just hope someone sees this thread and can offer another solution we haven't thought of (or better yet a patch).

Thanks again and have a great weekend!

RevReese -> RE: Steam not running error (4/4/2019 4:49:54 PM)

Just tried moving Command to C: drive as some games have required in the past.
The shield icon on command.exe disappeared and the run as admin tick box was unchecked...until i loaded up the launcher, then it prompted for admin and the box was ticked again with no way for me to change it.

Oh well, now i have exhausted all possible solutions, looks like i will have to run steam as admin every time then (which i do not want to do - certainly not constantly).

Oddly, once it moved to C: and validated itself, it downloaded 18MB, and when i moved it back and validated it (and the shield icon returned), it said all files verified so i don't know what happened there.

michaelm75au -> RE: Steam not running error (4/5/2019 12:18:48 AM)

I don't think you need to run Steam as Admin. I don't on my box.
But something is turning the command.exe to 'run as admin' on regardless. If you turn it off, and then run Command thru Steam and get the Matrix menu, it is turned back on.[&:]

DismalPseudoscience -> RE: Steam not running error (4/5/2019 11:50:49 AM)

Hi team,

I am experiencing this same issue, and no checking/unchecking of the "Run As Admin" boxes for Command or for Steam seems to resolve it.

I am completely locked out of being able to access the game. This has only happened after this most recent fix. I would really appreciate any other suggestions or any possible fix.

Edit: My apologies, tried Steam in Admin mode again and got it to work.

RevReese -> RE: Steam not running error (4/8/2019 3:10:23 PM)


ORIGINAL: michaelm75au

I don't think you need to run Steam as Admin. I don't on my box.
But something is turning the command.exe to 'run as admin' on regardless. If you turn it off, and then run Command thru Steam and get the Matrix menu, it is turned back on.[&:]

That's what is confusing me, i logged in as administrator, unticked the run as admin box then re-logged in as a user and ran the game and the box was ticked again!

I think you may be right that the launcher is turning the flag on, the question is how do we stop it doing this (if we can).

I have tried every fix i can find on here and the steam forums and nothing works, i can only play when steam is restarted as admin which is inconvenient and a security risk.

I know i can run steam as admin permanently but i do not want to do this.

michaelm75au -> RE: Steam not running error (4/8/2019 7:24:49 PM)

Try this.
Find the command EXE in the Steam folder (..\steamapps\common\Command Modern Air Naval Operations ). Un-click the 'run as admin' on the EXE and apply. Double click the command EXE (bypassing the Matrix launcher)

RevReese -> RE: Steam not running error (4/8/2019 7:36:28 PM)

Thanks for your reply.

I cannot change the run as admin tickbox as it is greyed out (but ticked).

The message about steam not running still pops up when running command.exe.

I can click change for all users and it is unticked then but on clicking ok it is ticked again.

Oberst_Klink -> RE: Steam not running error (4/8/2019 8:01:32 PM)

Can you access the properties of the CMANO.EXE in question as admin? Even when you usual user mode, AFAIK, you can hold the Shift-key and right-click on the file's properties. There'a also an option to chance the settings for all users.

Klink, Oberst

RevReese -> RE: Steam not running error (4/8/2019 8:08:55 PM)

I can access the properties tab but i cannot change the admin option as it is ticked and greyed out.
I can change the setting for all users then it is unticked, but as soon as i click ok it is ticked again and greyed out.

Dimitris -> RE: Steam not running error (4/9/2019 5:01:28 PM)

Try this:

RevReese -> RE: Steam not running error (4/9/2019 5:15:12 PM)

Thank you for your reply but i have already tried the text file and it did not work. The only way i can get beyond the launcher is to run Steam as administrator.

Stonedog -> RE: Steam not running error (4/9/2019 10:19:36 PM)

I have not forgot you my friend, and I think its a conflict between zonealarm and steam. Soon as I can get a better answer I let you know.

RevReese -> RE: Steam not running error (4/10/2019 2:07:32 PM)


ORIGINAL: Stonedog

I have not forgot you my friend, and I think its a conflict between zonealarm and steam. Soon as I can get a better answer I let you know.

[:)] i thought that too and disabled my firewall for a short time to see and it made no difference.

I am definitely intrigued to hear more information though.

Edit: Just tried the beta update on steam as posted by Tamas but sadly it did nothing for me, i still have the problem.

marioa -> RE: Steam not running error (4/10/2019 8:14:07 PM)

Hi RevReese

i have the same issue and if this can help i have resolved the problem launching the game from the exe of the only expansion in my library Northern Inferno afther uncheking the box " run as administrator " either in the Northern Inferno folder and in the Cmano folder now i can play the game.
The problem appeared on my computer afther the recent Steam upgrade

RevReese -> RE: Steam not running error (4/10/2019 9:10:05 PM)

Hi Marioa, thanks for your reply.

Sadly, i cannot uncheck the box, it is greyed out.

I can click "change settings for all users" button and the tick disappears, but when i click okay it is back and greyed out again.

Thanks for the suggestion though. [:)]

Page: [1] 2   next >   >>

Valid CSS!

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI