Update v1.10.12d (Full Version)

All Forums >> [New Releases from Matrix Games] >> Warhammer® 40,000® Armageddon™ >> Tech Support


Cataphract88 -> Update v1.10.12d (6/2/2018 7:50:48 AM)

When I tried to apply the latest update, from your home page, I was told I need Steam access, so I had to revert back to my earlier version.

Is there an update available for the non-Steam version of the game, and shouldn't you be making it clearer to users that this is only for Steam? This is the second Armageddon update where this has happened! [:@]

zakblood -> RE: Update v1.10.12d (6/2/2018 9:11:23 AM)

will ask and check why this is happening[:(]

Cataphract88 -> RE: Update v1.10.12d (6/2/2018 7:00:06 PM)

Thanks, Zak. [:)]

zakblood -> RE: Update v1.10.12d (6/2/2018 8:00:45 PM)

no problem, once everyone is back at work, eg Monday etc should get a answer and reply back asap

Cataphract88 -> RE: Update v1.10.12d (6/7/2018 3:30:18 PM)

Hi Zakblood,

Any news for me on this problem yet?

zakblood -> RE: Update v1.10.12d (6/7/2018 4:24:45 PM)

not atm, will ask again sorry and thanks for reminding me to follow it up[;)]

always check the forum links in the members area or site


zakblood -> RE: Update v1.10.12d (6/7/2018 4:31:25 PM)

here you go



zakblood -> RE: Update v1.10.12d (6/7/2018 4:34:01 PM)

tested working, it's just that i use the steam version so it won't let me use it, but it's not for the steam version anyway, this one, it's the site version only


Cataphract88 -> RE: Update v1.10.12d (6/7/2018 9:23:47 PM)

I have downloaded the patch from various locations (Member's Area etc), but after the intro screen, it always gives me the same message: 'Steam Client needs to be running'.

I have never played this game on Steam!

zakblood -> RE: Update v1.10.12d (6/8/2018 4:30:31 AM)

what about the one from the link? as that doesn't ask for steam, as shown, clear browser cache before trying mind you, or you may get the same download you had before

Cataphract88 -> RE: Update v1.10.12d (6/8/2018 10:16:14 AM)

Yeah, I tried the one from the link (and also the auto-updater), always with a clear browser, but I always get the same negative result.

zakblood -> RE: Update v1.10.12d (6/8/2018 10:54:55 AM)

not got anything from support or can't find anything or anybody else with the same issue either, so something just on your end, for me, as i've tried, open a support ticket and see if they can get / dig a bit deeper into it. good luck, away now for a week so hope you get it sorted, and will check in when i'm back

Cataphract88 -> RE: Update v1.10.12d (6/8/2018 4:23:14 PM)

Thanks for looking into this for me, Zakblood, I've done what you suggest.

Enjoy your week!

Splatsch -> RE: Update v1.10.12d (6/10/2018 11:23:03 AM)

Hi, I have the exact same issue !
I wasn't saying anything because I was thinking it would be solved quickly, but you're not alone Cataphract88 [;)]

I tried to install again the update through your latest link zakblood, but nothing changed. And I must add that I don't even have a Steam account, and so never installed the Steam client on my comp' (I'm a DRM-free guy :)).


EDIT : I tried to uninstall totally the game and reinstall it from scratch without any DLC, trying to launch the game after each file installation :
- WH_Armageddon_SetupRelease_100.exe -> OK
- WH-Armageddon-UpdateComp-v11012b.exe -> OK
- WH-Armageddon-UpdateComp-v11012d.exe -> Steam Issue

EDIT2 : I tried again to uninstall it totally. Installed WH_Armageddon_SetupRelease_100.exe -> OK. Used the auto-updater : leads to same issue with Steam.

EDIT 3 : Okay, I sent a message to support explaining things :) I'll let know what are the news as soon as there are some !
And thanks zakblood for your help by the way :)

Cataphract88 -> RE: Update v1.10.12d (6/10/2018 7:16:40 PM)

Hi Splatsch,

Just to let you know that I got the following response, after I raised the problem with Support:

'This a bug and we are waiting that the developer fixes the issue so that we can remaster the file and fix the issue'.

So, it's down to the devs now.

Splatsch -> RE: Update v1.10.12d (6/10/2018 7:25:49 PM)

Hi :)
Thanks for the info !
I just received a similar answer from the support too, telling that they're on it and that they will say to me when it's fixed.

We only have to be patient now :)

Cataphract88 -> RE: Update v1.10.12d (6/22/2018 4:09:59 PM)

Any word on that fix yet? As the game won't work like this. [:(]

zakblood -> RE: Update v1.10.12d (6/22/2018 4:24:14 PM)

will add a note as office is closed atm and see what they say, sorry about this[:(]

Splatsch -> RE: Update v1.10.12d (6/22/2018 8:13:37 PM)

Thanks for your help [:)]

Cataphract88 -> RE: Update v1.10.12d (6/22/2018 11:36:12 PM)


ORIGINAL: Splatsch

Thanks for your help [:)]


Cataphract88 -> RE: Update v1.10.12d (7/28/2018 11:03:29 PM)

More than a month later and still nothing! [sm=Christo_pull_hair.gif]

Splatsch -> RE: Update v1.10.12d (7/30/2018 9:22:30 AM)


ORIGINAL: Cataphract88

More than a month later and still nothing! [sm=Christo_pull_hair.gif]

Yep :S
Have you contacted support again ? If not, I'll do it to remind them that we're still waiting and that we still can't play the game :/

Cataphract88 -> RE: Update v1.10.12d (7/30/2018 10:19:59 PM)

I have sent a reminder to Support.

Splatsch -> RE: Update v1.10.12d (7/30/2018 10:55:03 PM)

Okay !
Let's hope they'll send a fix soon.

VPaulus -> RE: Update v1.10.12d (7/31/2018 9:28:20 AM)

I'm so sorry guys. My fault! I forgot to tell in this thread, that the issue has already been fixed.

Splatsch -> RE: Update v1.10.12d (7/31/2018 8:37:08 PM)

Ahah, this kind of things may happens, no problem ;)

I downloaded the latest version and tried it without and with DLC's : issue totally solved in both cases !
Thank you very much for this :)

...now time to obliterate some Orks again [8D]

Cataphract88 -> RE: Update v1.10.12d (8/1/2018 10:53:45 PM)

Thanks for the fix, my game is working again now. The only puzzling thing is that the intro video has shrunk to the top left-hand quarter of the screen, and I cannot see why this has happened.

Splatsch -> RE: Update v1.10.12d (8/13/2018 12:43:16 AM)

I don't encounter the issue, so I won't be able to try to help you here :/
Hope you'll still be able to play without issue (and find an explanation & a fix) !

Cataphract88 -> RE: Update v1.10.12d (8/13/2018 5:08:22 PM)

I'm not too bothered, more puzzled [&:], after all I've seen the opening vid many times before and the game works fine now.

Page: [1]

Valid CSS!

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI