RE: Bacon Mod + RetreatUE + Das Chrome (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding



Message


idefelipe -> RE: Bacon Mod + RetreatUE + Das Chrome (4/22/2019 6:58:10 AM)

Hey!

I have all installed (correctly, I think). But I see that "frigates" were removed from the possible ships available. Is this a bug in my installation or a feature?

Thanks for this awesome work [&o]




RogerBacon -> RE: Bacon Mod + RetreatUE + Das Chrome (4/22/2019 10:16:17 PM)


quote:

ORIGINAL: idefelipe

Hey!

I have all installed (correctly, I think). But I see that "frigates" were removed from the possible ships available. Is this a bug in my installation or a feature?

Thanks for this awesome work [&o]


In the GameText.txt file frigates were renamed. Here is part of that file:
Cruisers ;Heavy Cruisers
Destroyers ;Light Cruisers
Escorts ;Escorts
Exploration Ships ;Exploration Ships
Freighters ;Freighters
Frigates ;Destroyers




DasTactic -> RE: Bacon Mod + RetreatUE + Das Chrome (5/13/2019 4:31:30 PM)

I've updated the mod-mod in the OP to version 1.77. When I update this I'll conform to using Roger's version numbering from the bacon mod to make it a little easier to check on the versions. So this version has been tweaked to run 1.77 of the bacon mod. Mainly just setting notes and changes to the help files.




FlipsTheSlayer -> RE: Bacon Mod + RetreatUE + Das Chrome (6/6/2019 6:16:11 AM)

Hey, sorry if I'm not understanding this correctly (or if this question was already answered), but is there a way to follow these instructions without specifically using RetreatUE? I'd like to know what I have to do to make Bacon Mod work with the Unleashed Extended II mod. I don't use RetreatUE since I heard it was much more difficult than UEII.




Retreat1970 -> RE: Bacon Mod + RetreatUE + Das Chrome (6/6/2019 3:21:01 PM)

RetreatUE is harder but much more so at the hardest difficulties. Try a medium game or even easy.




FlipsTheSlayer -> RE: Bacon Mod + RetreatUE + Das Chrome (6/7/2019 5:57:09 AM)

Hey so, I've installed the mod per the instructions and everything is working well.

However, the first thing I noticed upon loading up the mod was that the background stars that usually show up when zooming into a solar system aren't there anymore. I read up on the included documentation, which states that this is on purpose and that the original setting that makes the stars show up when zooming in can be turned back on by setting the "backgroundStarsAtZoomLevel" value to 300 in the "Das_BaconSettings" file.

I did this but it made no difference. The stars still don't show up when zooming in. Can anyone help me with this? I really prefer having the stars show up when zooming in, they add to the immersion factor of zooming into a solar system.




rogerbacon51 -> RE: Bacon Mod + RetreatUE + Das Chrome (6/7/2019 12:45:18 PM)


quote:

ORIGINAL: FlipsTheSlayer

I did this but it made no difference. The stars still don't show up when zooming in. Can anyone help me with this? I really prefer having the stars show up when zooming in, they add to the immersion factor of zooming into a solar system.


I just checked and its working. You need to exit Distant Worlds and restart it before you will see the change.




FlipsTheSlayer -> RE: Bacon Mod + RetreatUE + Das Chrome (6/7/2019 6:36:08 PM)

quote:

just checked and its working. You need to exit Distant Worlds and restart it before you will see the change.


But restarting is the very first thing I did after changing the setting. The stars still don't show up when I zoom in though.




altug -> RE: Bacon Mod + RetreatUE + Das Chrome (6/30/2019 10:28:29 AM)

Installed correctly. But sometimes ships, mostly constructors, tries to select to move top left corner of galaxy, and the huge fps drop happens during that. after 10-20 seconds, it turns normal.




rogerbacon51 -> RE: Bacon Mod + RetreatUE + Das Chrome (6/30/2019 2:23:03 PM)

They aren't really moving there (once they did but that bug was squashed long ago). Instead, what is happening is their current target is set to 0,0 and so you see the course pointer set to the upper left corner. It usually happens when the constructor has no mission or is awaiting a supply shipment to finish building something. You can just ignore it.




altug -> RE: Bacon Mod + RetreatUE + Das Chrome (6/30/2019 4:05:02 PM)

I see, thanks for the info, happens to explorers as well, just the fps drop is annoying, its like 4-5 fps when that ship is in close view.




rogerbacon51 -> RE: Bacon Mod + RetreatUE + Das Chrome (6/30/2019 6:49:35 PM)

Try turning off range circles and see if that helps the framerate. You can turn them on or off with !rangecircles in the bacon input box.




altug -> RE: Bacon Mod + RetreatUE + Das Chrome (6/30/2019 7:21:40 PM)

It worked, in fact, turning off travel vectors helped, so I can keep rangecircles on and just turn off travel vectors. thanks again.




Hattori Hanzo -> RE: Bacon Mod + RetreatUE + Das Chrome (6/30/2019 9:21:34 PM)

quote:

ORIGINAL: altug

I see, thanks for the info, happens to explorers as well, just the fps drop is annoying, its like 4-5 fps when that ship is in close view.

what do you mean with "fps drop" ?




altug -> RE: Bacon Mod + RetreatUE + Das Chrome (6/30/2019 9:56:39 PM)

when that 0,0 travel vector bug happens on my side, and the ship is on screen, frame rate drops to 4-5.




Chucktown -> RE: Bacon Mod + RetreatUE + Das Chrome (7/31/2019 4:53:04 PM)

I cant change capital. When i click "set as capital" in colony screen a unhandled exception pops up.




RevReese -> RE: Bacon Mod + RetreatUE + Das Chrome (8/3/2019 3:47:59 PM)

Hi everyone.
I have recently migrated to a new PC requiring a reinstall of DWU and my mods, the problem is i have a load of mods downloaded and cant remember what order to install them in!

At the moment, i have the Bacon Mod 1.77 with DAS UI Bacon over the top of RetreatUE, though DAS's icons are all grey so i have obviously done something wrong when following the instructions!

I am really confused as i know some mods include others like i think RetreatUE includes parts of the AI Improvement mod and TG sound effects.

i want to install RetreatUE
BaconMod
DAS UI Blue
Extended Universe
Extended AI Improvement Mod
GEM
TG Sound Effects.

Please can someone help me out by telling me step by step how to include all these mods (assuming i CAN have all these mods together that is!) I managed before with them all combined into a single theme yet now i cannot seem to replicate it and get an unhandled exception on load (though the game loads fine when clicking continue on this error apart from the grey icons).

I have been at this for ages now and i just want to get back into a game!

Thank you for your time.




Retreat1970 -> RE: Bacon Mod + RetreatUE + Das Chrome (8/3/2019 10:49:38 PM)

The original post has instructions that still work (for me). I'd try again.




RevReese -> RE: Bacon Mod + RetreatUE + Das Chrome (8/3/2019 11:52:20 PM)

Thanks for your reply.

I know i have done something incorrectly as i had it working before on my old machine with these mods.

I think the RetreatUE mod includes Extended Universe and AI Improvement but i am not 100% sure.

I will try again tomorrow, i know this game is worth it!




Retreat1970 -> RE: Bacon Mod + RetreatUE + Das Chrome (8/4/2019 1:49:13 AM)

http://www.matrixgames.com/forums/tm.asp?m=3834204

RetreatUE is this. Scroll down to UEII and read that. All I did was modify the awesome work already done.




RevReese -> RE: Bacon Mod + RetreatUE + Das Chrome (8/4/2019 12:56:20 PM)

Thanks for the link, i see there that RetreatUE does in fact include Haree78's Extended, Icemania's AI Improvement and DAS's Chrome UI mods.
Just to clarify: RetreatUE INCLUDES all the mods listed on that first post? so i do NOT need Unleashed Extended II if i install RetreatUE?




Retreat1970 -> RE: Bacon Mod + RetreatUE + Das Chrome (8/4/2019 7:08:53 PM)

yes and you do not




RevReese -> RE: Bacon Mod + RetreatUE + Das Chrome (8/4/2019 7:46:02 PM)


quote:

ORIGINAL: Retreat1970

yes and you do not


Thank you for the clarification, i am pleased to say all is working well so far.

I was just wondering what mod the images in RetreatUE came from as i really like them, but i like the GEM ones as well and would like to combine them if possible?
Can i just renumber the GEM images and add them in the appropriate places?




Retreat1970 -> RE: Bacon Mod + RetreatUE + Das Chrome (8/6/2019 1:23:18 AM)

Mordachai created the original UE and UEII. RetreatUE is made from that. So if it's not stated in his post in the link I provided, I don't know where he got his materiel. It should be no problem to swap images.




RevReese -> RE: Bacon Mod + RetreatUE + Das Chrome (8/6/2019 3:12:50 PM)

quote:

ORIGINAL: Retreat1970

Mordachai created the original UE and UEII. RetreatUE is made from that. So if it's not stated in his post in the link I provided, I don't know where he got his materiel. It should be no problem to swap images.


Thanks for the clarification, i will have another look over that post and the replies to see if anyone else asked about it.

Would it still be possible to ADD the GEM landscapes to RetreatUE if i renumber them? to clarify, i want them ALL if possible, both GEM and the ones already included in RetreatUE.
I will try it and see what happens but i don't know how i will be able to check if it is working or not without just being lucky and one of my renumbered ones happens to show up in my game!

Sorry for the constant questions!

EDIT: I discovered they are sourced around the internet into a mod called: astradeus-graphics-mod. Now i just need to find a way to merge the 2 graphics mods!

EDIT 2: Just discovered on P13 (p24) of the DW Modding Guide that the game only recognises a small handful of images so i will have to choose between them and renumber my choices correctly anyway.




Murtagh21 -> RE: Bacon Mod + RetreatUE + Das Chrome (8/24/2019 3:03:58 AM)

Hey, love the work you do. I am trying to go through and install this and when I install your patch and then run the batch file the game no longer works. I have have started up the game after every step and it is after I do you patch which causes it. The game starts and seems to run, but throws another exception for small font when trying to gen a world and the world never gens.

This is the text of the first one.

see the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
Microsoft.Xna.Framework.Graphics.DeviceLostException: Exception of type 'Microsoft.Xna.Framework.Graphics.DeviceLostException' was thrown.
at Microsoft.Xna.Framework.Graphics.GraphicsDevice.CreateDevice(GraphicsAdapter adapter, PresentationParameters presentationParameters)
at Microsoft.Xna.Framework.Graphics.GraphicsDevice..ctor(GraphicsAdapter adapter, GraphicsProfile graphicsProfile, PresentationParameters presentationParameters)
at Class1..ctor(IntPtr intptr_0, Int32 int_1, Int32 int_2)
at Class1.smethod_0(IntPtr intptr_0, Int32 int_1, Int32 int_2)
at DistantWorlds.Controls.MainView.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I would post the rest but it flags it and thinks I am posting a phone number which I cant do.

Edit: Strange I didn't change anything, waited a day and its fine. So nevermind I guess. All is good.




Dakkon -> RE: Bacon Mod + RetreatUE + Das Chrome (8/28/2019 12:13:36 PM)

I hadn't played distant worlds in years and I somehow stumbled upon the newest das series on youtube and now I have the bug again. There goes many hours of my spare time.




tofudog -> RE: Bacon Mod + RetreatUE + Das Chrome (10/26/2019 9:29:34 AM)

Hi guys,

maybe some of you fine modders have an idea of what I might have been doing wrong, or what went wrong:

I followed the installation instructions (or so I thought), and I can play for a few (game)years alright.
But then at some point (reloading a save from before changes that point) the minimap you get when looking at ships or planets is replaced by a white box with a red x in it and the following error-message is shown:

System.NullReferenceException: Object reference not set to an instance of an object.
at DistantWorlds.Controls.GalaxyMap.method_6(Int32 int_4, Int32 int_5, Int32 int_6, Int32 int_7, Double double_5, Graphics graphics_0)
at DistantWorlds.Controls.GalaxyMap.OnPaint(PaintEventArgs e)
at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
at System.Windows.Forms.Control.WmPaint(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

(do you need the loaded assemblies list as well?)
Let me repeat that this only happens well into the game. First time around I had 1400 planets and thought that this might be an issue, but the same thing happened with 1000 planets (which I usually do to keep save/load times in check).

Thanks for lending an ear (eye).




MikeLeWatt -> RE: Bacon Mod + RetreatUE + Das Chrome (10/28/2019 6:53:13 PM)

Can you please clarify what the resource extraction cap is for this collection of mods? If it differs from vanilla that is. Thank you.




rjord1 -> RE: Bacon Mod + RetreatUE + Das Chrome (10/28/2019 7:46:08 PM)

quote:

ORIGINAL: tofudog

Hi guys,

maybe some of you fine modders have an idea of what I might have been doing wrong, or what went wrong:

I followed the installation instructions (or so I thought), and I can play for a few (game)years alright.
But then at some point (reloading a save from before changes that point) the minimap you get when looking at ships or planets is replaced by a white box with a red x in it and the following error-message is shown:

System.NullReferenceException: Object reference not set to an instance of an object.
at DistantWorlds.Controls.GalaxyMap.method_6(Int32 int_4, Int32 int_5, Int32 int_6, Int32 int_7, Double double_5, Graphics graphics_0)
at DistantWorlds.Controls.GalaxyMap.OnPaint(PaintEventArgs e)
at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
at System.Windows.Forms.Control.WmPaint(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

(do you need the loaded assemblies list as well?)
Let me repeat that this only happens well into the game. First time around I had 1400 planets and thought that this might be an issue, but the same thing happened with 1000 planets (which I usually do to keep save/load times in check).

Thanks for lending an ear (eye).



The message "Object reference not set to an instance of an object" is a message I have to deal with a number of times in the mods I am making...... I do several hours of developing the mod and when I then taste the changes I may at times get the message "Object reference not set to an instance of an object" due to a typo or other error in the mod.

Are you using a mod other than Bacon Mod + RetreatUE + Das Chrome when you get this error? As you are getting this era well into the game it sounds like the mod is crashing due to an error.

If you are using a mod can you let me know and I will try to find the problem.




Page: <<   < prev  3 4 [5] 6 7   next >   >>

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.0390625