window artifacting (Full Version)

All Forums >> [New Releases from Matrix Games] >> Desert War 1940 - 1942 >> Tech Support



Message


budd -> window artifacting (3/25/2018 2:40:56 AM)

It starts after a few minutes of play and gets progressively worse. Happens at all zoom levels. Install went fine, shut down my AV for install, installed java and uninstalled the old version of java....no hiccups during install. Windows 10, game not installed in programs files, installed on separate drive than OS.

[image]local://upfiles/32191/CB11B148C7CC49D39D0D09D0000CFFB0.jpg[/image]




zakblood -> RE: window artifacting (3/25/2018 6:17:17 AM)

sorry about this budd, so the developer can gather a picture of what maybe wrong,

How to get a DirectX Diagnostic file:

1. click on "START"
2. click "run"
3. type in "dxdiag" and click "OK"
4. check through the tabs and perform all tests
5. click "Save all Information..." and save the text file to a location of your choice

We prefer that DxDiag files be posted as message attachments rather than pasted into the body of the post.

once the report has been made, just attach it to your post with first adding the file to a zip, which is then permitted to attach to the forum




Pip B -> RE: window artifacting (3/25/2018 8:48:29 AM)

I also have an artifact issue, the Icons that appear to show an action ie explosion,recce symbol etc are left on the map after the WEGO phase gradually cluttering the screen. Any ideas? I can do DX diag if i must :) !!!
Other than that the game is brilliant especially the replay feature




budd -> RE: window artifacting (3/25/2018 3:30:19 PM)

here you go




budd -> RE: window artifacting (3/25/2018 7:15:21 PM)

I've tried windowed vs fullscreen, several compatibility modes for exe., no change, still have the window problem.

Windows pop up pretty regularly when hovering over buttons, even when not hovering over buttons and the cursor is off map on left or right.




budd -> RE: window artifacting (3/27/2018 3:58:03 AM)

Been playing around trying to find what starts the problem. I played four turns just using the buttons on the left side without issue. Then i started using buttons on the right side[those 3 buttons], the problems started. It seems that the problems start when i click the orders button right next to the skull, the middle one in the row of three. After i use that button i get windows appearing when i hover over buttons for the rest of the play session until the game becomes unplayable. I've restarted and tested this 3 times, each time after i clicked the orders button the problem started.

Anyone else have problems after clicking that button with the mouse.




BletchleyGeek -> RE: window artifacting (3/28/2018 2:15:10 AM)


quote:

ORIGINAL: budd

Been playing around trying to find what starts the problem. I played four turns just using the buttons on the left side without issue. Then i started using buttons on the right side[those 3 buttons], the problems started. It seems that the problems start when i click the orders button right next to the skull, the middle one in the row of three. After i use that button i get windows appearing when i hover over buttons for the rest of the play session until the game becomes unplayable. I've restarted and tested this 3 times, each time after i clicked the orders button the problem started.

Anyone else have problems after clicking that button with the mouse.


That's pretty consistent, but unfortunately, it is not happening on my system budd. I can cycle through the three different settings that become selectable and the windows pop in and out as normal. I have tried this both for stacks (so you tweak defense orders) and for attacks (that allows you to tweak the intensity of the attack).




budd -> RE: window artifacting (3/28/2018 2:19:48 AM)

OK went through all the buttons and hotkeys, can confirm, for me at least the orders button starts the windows popping in. I don't even have to click it, just hover over it to start the additional windows popping up all over the screen. Here's what it looks like when its really bad, unplayable. Had to crop a bit to fit under the 200kb limit. As long as i don't put the cursor on that button it works fine

[image]local://upfiles/32191/B3748F8103B1462D99C3ADE09C916360.jpg[/image]




BletchleyGeek -> RE: window artifacting (3/28/2018 2:43:46 AM)

Just an idea... to see if this behaviour changes:

1. go and find the shortcut "Desert War 1940-42 (QuickStart)",
2. right click on it and select "Properties"
3. go to the tab "Compatibility"
4. find the "Settings" section
5. Select the option "Override high DPI scaling behaviour. Scaling performed by":
6. On the list box, select the item "System" if it is not selected already.

All of this assumes you're running Windows 10. I can't recall what were the settings like for Windows 8.1.




budd -> RE: window artifacting (3/28/2018 3:51:47 AM)

Well sir, early quick test run indicates that fixed it. Tried all the other compatibility settings except that one. When i get more time i'll run through the tutorial scenario again to be sure. I should of talked to you first, would of saved me some time[:D] ..... Thank you.




BletchleyGeek -> RE: window artifacting (3/28/2018 3:54:20 AM)

Fascinating. That was quite a shot in the dark.

I was having some inconsistencies with fonts etc. on my Surface (that has a Retina display) and that worked for me. So...

Enjoy!




Capt Cliff -> RE: window artifacting (3/29/2018 3:05:50 PM)

Hmmm seems like the same issue that War in the Pacific has with WIN 10. Better fix this pronto!




echo9c -> RE: window artifacting (4/4/2018 6:16:18 PM)

I have the same issue as Pip B: "the Icons that appear to show an action ie explosion,recce symbol etc are left on the map after the WEGO phase gradually cluttering the screen."

I have also found that as budd has stated above, it only seems to happen if I click on the order button on the right hand side of the screen next to the skull button.




Saint Ruth -> RE: window artifacting (4/5/2018 12:50:40 PM)

There is a bug in which you get "floating" icons (explosions/red artillery icons etc) that stick around and don't move/zoom when you move/zoom the map.
This is caused by you zooming and moving the map at the same time.
This of course will be fixed in the next patch, thanks. [;)]




echo9c -> RE: window artifacting (4/5/2018 3:44:10 PM)

Thanks for the response, great game BTW!




budd -> RE: window artifacting (3/23/2019 2:42:07 PM)

Hate to necro this thread but i installed the new update and the artifacting is happening for me again. It starts once i hover over or click [always when i click] the buttons on the right, but just the orders and cycle buttons. I still have the override DPI setting for system checked on the compatibility tab that fixed it before but no joy this time. It pretty much looks just like the screen shots i posted last time.

Have the most recent Java update




budd -> RE: window artifacting (3/23/2019 3:35:00 PM)

I was playing around with the compatibility settings and it seems if i also check "disable full screen optimizations" along with the override DPI settings-system the problem doesn't appear. I just played a couple of turns so far but the problem didn't appear when i hovered over or clicked the buttons on the right.




budd -> RE: window artifacting (3/24/2019 11:33:06 PM)

I spoke to soon, Still have the issue. The game gets unplayable as it gets worse as i go. This happened on the first turn. This time it happened after i clicked the orders button on the right.

[image]local://upfiles/32191/2C7DAEBBDEA64D0280E4946DE40EE3E8.jpg[/image]




budd -> RE: window artifacting (3/24/2019 11:43:32 PM)

DXdiag attached




budd -> RE: window artifacting (3/25/2019 12:28:23 AM)

Did a complete uninstall and re-install with a fresh download, problem persists. It seems if i don't hover over or click those 2 right most buttons on the right side of the screen the problem doesn't start, well at least so far.




Saint Ruth -> RE: window artifacting (3/25/2019 10:34:39 AM)

That's odd as graphics handling hasn't changed at all.
Whcih "2 right most buttons" exactly do you mean?

Is it the same for windowed / fullscreen?




budd -> RE: window artifacting (3/25/2019 5:19:25 PM)

Forgot to check fullscreen/ window mode, I'll do that tonight. There's 3 buttons on the right side, two of them cause this to happen. One is the orders button and the one to it's right who's label escapes me at the moment. All I have to do is hover over the orders button for this artifacting to start. I've tried various compatibility settings, it does get unplayable as once it starts it gets worse as you go.




budd -> RE: window artifacting (3/25/2019 11:10:09 PM)

I was in full screen mode switched to windowed, no improvement. If i hover over or click the orders or cycle units buttons its starts happening. Here's a shot after a hover over the orders button and then open the video option screen.

[image]local://upfiles/32191/259C6340753544EC9A1480A46B798B34.jpg[/image]




budd -> RE: window artifacting (3/26/2019 12:52:37 AM)

Been playing around with it, its weird, as long as i don't put my mouse cursor over those buttons it doesn't happen. I can go right by them, hover over the minimap and all around that area but as soon as i either put the mouse over those buttons or click one the weird windows start happening.




Saint Ruth -> RE: window artifacting (3/26/2019 8:02:50 PM)

I'll have a look. As I said, I haven't changed anything in the code so that's very weird.
You didn't change any graphic settings or anything?




budd -> RE: window artifacting (3/26/2019 10:37:59 PM)

I tried a bunch of compatibility settings, turned them off and on buts that's it.




Saint Ruth -> RE: window artifacting (4/8/2019 2:13:42 PM)

Hi, if I can send you a zipped file, can you test it to see if it fixes the problem?




budd -> RE: window artifacting (4/8/2019 2:50:21 PM)

Be happy to, you sending it through PM or need me to PM you my email?




Saint Ruth -> RE: window artifacting (4/9/2019 11:43:55 AM)

I should have said! Yes, can you pm me your email addr? [;)]




budd -> RE: window artifacting (4/13/2019 1:18:55 PM)

I pm'd you my email address a few days ago, you get it?




Page: [1] 2   next >   >>

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
4.296875E-02