Unable to attack pirate base on owned planet (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series



Message


cato13 -> Unable to attack pirate base on owned planet (12/28/2017 9:32:46 PM)

Hello,

I've recently captured a pirate owned planet after destroying its starbase.

my troops are still on the planet but the attack button is greyed out on the colony screen meaning im unable to destroy the 3 pirate facilities. shouldnt the bases have been destroyed after i won the land battle?

It looks like a bug to me, anyone else came across anything like this before?

ps,

Ive only recently discovered this game and have to say its superb, easily the best 4 x 4 game ive played! [:)]




Shogouki -> RE: Unable to attack pirate base on owned planet (12/29/2017 9:32:57 AM)

This isn't exactly intuitive but this is how it's done. Go to the info page for the planet and select the pirate facility on the facilities tab. Once highlighted it should have the option to be attacked. Know that the bases house an unknown amount of pirate defenders that will pop out when you attack, so make sure you have heavy forces ready if there are multiple pirate facilities present.




cato13 -> RE: Unable to attack pirate base on owned planet (12/29/2017 4:05:41 PM)

yeah well as i explained above the attack button is greyed out on the colony info screen.

its gotta be a bug so il post in the tech forum.

is there any way to edit out these pirate bases since ive no way of destroying them?




rjord1 -> RE: Unable to attack pirate base on owned planet (12/29/2017 4:17:57 PM)

can you post a screenshot?




cato13 -> RE: Unable to attack pirate base on owned planet (12/29/2017 4:42:20 PM)

here ya go

[image]local://upfiles/17185/3D68DD2A22A54974B375D0A0AE638D1E.jpg[/image]

when clicking on a pirate facility the attack button is greyed out. ive attacked pirate bases before this way but never had this issue.




Sabranan -> RE: Unable to attack pirate base on owned planet (12/29/2017 5:41:11 PM)

Check your troops, it looks like the ones listed are still being recruited. If that's the case you'll need to either wait until you have some or drop some on the planet with a troop transport.




stuart3 -> RE: Unable to attack pirate base on owned planet (12/29/2017 7:15:23 PM)

I had this happen once before. If memory serves, I think that the problem was that all of my troop units had taken casualties in the course of capturing the planet and the computer wouldn't then allow me to attack the pirate bases until at least one of them had recruited back up to 100% strength. But the situation did resolve itself over a bit of time.




Shogouki -> RE: Unable to attack pirate base on owned planet (12/29/2017 7:42:34 PM)

The screenshot doesn't look like you have one of their facilities highlighted though?




cato13 -> RE: Unable to attack pirate base on owned planet (12/30/2017 3:49:37 PM)


quote:

ORIGINAL: Shogouki

The screenshot doesn't look like you have one of their facilities highlighted though?



Yes im fully aware i need to highlight the facility before attacking it. [:)]

ive even tried removing all troops from the planet then unloading them there again but the attack button remains greyed out.

i realise at this time of the year game support will be limited but do the devs still support it? its such a great game but this is a game breaking bug for me. i could start another game of course but whats to say this bug wont happen again.





Bingeling -> RE: Unable to attack pirate base on owned planet (12/30/2017 4:35:25 PM)

The game is not likely to receive a lot of patches at this stage, the focus is probably on DW2.

I have never heard of this issue, so I would try with a different set of troops that you are sure that are healthy.




btd64 -> RE: Unable to attack pirate base on owned planet (12/30/2017 4:47:51 PM)

You have all 3 pirate bases. There is a special case for that but I don't remember the solution. I'm away from my computer so I can't look it up....GP




Sabranan -> RE: Unable to attack pirate base on owned planet (12/30/2017 5:19:00 PM)

cato13 can you upload a savegame for us to look at? Might be able to see what's going on if we've actually got it in front of us.




Retreat1970 -> RE: Unable to attack pirate base on owned planet (12/30/2017 6:41:32 PM)

quote:

shouldnt the bases have been destroyed after i won the land battle?


No.

If I remember right you have to fight the 3 bases separately in order (network, fortress, then base).

I have not played in a long time so I'm probably wrong.




stuart3 -> RE: Unable to attack pirate base on owned planet (12/30/2017 7:26:54 PM)

If you click on network, then you fight all three together, with the troops from the planet's population on your side. I have never tried clicking on the base or fortress if a network is present.

But I do believe that you need at least one unit at 100% strength in order to initiate an attack, so check the status of your units in the Troops & Characters tab.





cato13 -> RE: Unable to attack pirate base on owned planet (12/31/2017 8:43:11 AM)

Where can i upload the save game to? its to bug to upload in this post.




Sabranan -> RE: Unable to attack pirate base on owned planet (12/31/2017 8:40:40 PM)

Pretty much any file hosting service will do, if you don't have one already set up then this one will do the job nicely for a single file.

Press "Take me to free" on the first screen, agree to their policy and the upload interface should appear.

Don't bother entering any details, just hit "Add your files", choose your savegame and then hit the three dots beside the transfer button. That should make the option to send the file as a link appear, so select link. Then just hit transfer and wait for it to upload.

Once the upload is done a download link should be generated, so just copy and paste it here.




Hattori Hanzo -> RE: Unable to attack pirate base on owned planet (1/6/2018 7:36:25 AM)

any news here ?




Webbco -> RE: Unable to attack pirate base on owned planet (1/22/2018 7:35:53 PM)

Picking up DW for the first time in years and having a ton of fun after watching Tortuga's Youtube playthrough! However, I have the same problem as the OP - does anyone have an answer to this question?




Shogouki -> RE: Unable to attack pirate base on owned planet (1/22/2018 9:41:37 PM)

You wouldn't be able to upload the save file, would you?




Webbco -> RE: Unable to attack pirate base on owned planet (1/23/2018 9:15:47 PM)

Here's my save game: https://we.tl/NLfJ5J32C8

I am the United Taihe Systems. The colony in question is Obboaf in the Volkan system, sector B6.

Would appreciate your thoughts!




Shogouki -> RE: Unable to attack pirate base on owned planet (1/23/2018 10:46:23 PM)

Sadly I won't be able to check it out till tomorrow night but if it's still not solved by then I definitely will see if I can figure anything out.




Kull -> RE: Unable to attack pirate base on owned planet (1/24/2018 3:47:08 PM)


quote:

ORIGINAL: Webbco

Here's my save game: https://we.tl/NLfJ5J32C8

I am the United Taihe Systems. The colony in question is Obboaf in the Volkan system, sector B6.

Would appreciate your thoughts!


What version do you have? Also, is it using a mod of some sort? I tried to load it with 1.9.5.12 and got a huge page of errors.




Webbco -> RE: Unable to attack pirate base on owned planet (1/24/2018 5:24:28 PM)

It's 1.9.5.12 with Haree's Extended mod.

EDIT: After another look, I realised I changed the theme to DW Extended Universe from the main menu and must have added the Das Chrome UI mod as well (it's been at least a year since I've played DW so forgot about those changes!) Should those mods affect the pirate base attack mechanic of my troops though?




Kull -> RE: Unable to attack pirate base on owned planet (1/24/2018 10:39:58 PM)


quote:

ORIGINAL: Webbco

It's 1.9.5.12 with Haree's Extended mod.

EDIT: After another look, I realised I changed the theme to DW Extended Universe from the main menu and must have added the Das Chrome UI mod as well (it's been at least a year since I've played DW so forgot about those changes!) Should those mods affect the pirate base attack mechanic of my troops though?


I don't have either of those mods, so that's probably why I can't get it to work. I suspect it's referencing files that don't exist in my build.




fruitgnome -> RE: Unable to attack pirate base on owned planet (1/25/2018 7:37:15 AM)

Webbco upload your mod folder somewhere and I will test your savegame one more time.




Shogouki -> RE: Unable to attack pirate base on owned planet (1/26/2018 1:22:40 AM)

I don't have the mods either. You wouldn't happen to have download links for them, would you?




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
2.978516E-02