Problem assigning planes to mission (No-Navigation Zones - landning marshal) (Full Version)

All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Mods and Scenarios



Message


mazex -> Problem assigning planes to mission (No-Navigation Zones - landning marshal) (9/29/2016 9:40:14 PM)

Hi!

Have dusted off an old scenario and are trying to clean it up - suddenly some attack aircraft stopped attacking that I have not changed for years (literaly).

So - when I check them they RTB directly and when I tried in the editor to re-assign them to the same old mission I get:

"Aircraft xxx has not been added to the mission. Reason: Check that there are not No-Navigation Zones close to the target or the landing marshal point"

So - I recreated the mission and realize that before I even assign a target to the mission I get the same error - so it can't be a No-Navigation Zone close to the target as they don't even have one yet... So then to the "landing marshal point" part whatever that means. Tried creating a new base if it was "full" or something but no luck...

Anyone that might have seen it or have any ideas about why?

EDIT: An no - I do not have any No-Fly zones at all defined in the scenario - and it's build 847,1

Regards /Mans




Gunner98 -> RE: Problem assigning planes to mission (No-Navigation Zones - landning marshal) (9/29/2016 10:25:41 PM)

Just a thought that I've had some odd occurrences to some of my very old scenario workings because of DataBase update issues. What I suggest you do is:

1. make an SBR delta Template file (this will save all your platform modifications, ammo etc) If you don't have any don't worry about it.
2. Upgrade to the latest DB (Editor/Database/upgrade)
3. Rebuild current scenario - force 'Deep Rebuild' and 'Apply INI File' (if you made the SBR file)
4. It will ask you the location of the SBR file

This gets rid of a lot of very obscure problems where the upgraded DB overtakes the units you have in the scenario and fixes it.

A purely wild arse guess but if you built the scenario before the modifications to a bunch of the land targets, to adjust the damage module, this may be screwing you up.

If that doesn't do it, I'm not sure

B




mazex -> RE: Problem assigning planes to mission (No-Navigation Zones - landning marshal) (10/1/2016 8:30:59 AM)


quote:

ORIGINAL: Gunner98

Just a thought that I've had some odd occurrences to some of my very old scenario workings because of DataBase update issues. What I suggest you do is:

1. make an SBR delta Template file (this will save all your platform modifications, ammo etc) If you don't have any don't worry about it.
2. Upgrade to the latest DB (Editor/Database/upgrade)
3. Rebuild current scenario - force 'Deep Rebuild' and 'Apply INI File' (if you made the SBR file)
4. It will ask you the location of the SBR file

This gets rid of a lot of very obscure problems where the upgraded DB overtakes the units you have in the scenario and fixes it.

A purely wild arse guess but if you built the scenario before the modifications to a bunch of the land targets, to adjust the damage module, this may be screwing you up.

If that doesn't do it, I'm not sure

B


Thanks for your suggestion! Unfortunately it did not work - there is some problem deeper down ;)

The thing is that I started the mission during the beta and have been expanding it very slowly over the years. Some weeks ago I decided to finish it and started with an upgrade and deep rebuild. Then I have been doing quite a number of versions that have all worked. Finally to consider it finished I decided to do a major cleanup of the events, triggers, actions etc with renaming and some changes to the logic of events. After doing that I started the mission and realized that some strike missions that where not changed since ages did not work.

To try to get to the bottom of this I tried to create a completely "clean" setup so I added a new base (as there is some "landing marshaling issue") - completely new aircraft units and new missions. And I get the same problem. I then took some other existing air unit where the mission assignment worked and tried to assign them to the "fresh" land strike mission and got the same problem. I then tried to assign the "old" problematik attack AC to some other mission (not Land Strike) and realized that it works... Sigh

So - for some reason after my game logic cleanup I get the error message in my original post whenever I try to assign any aircraft to a Land Strike mission. Sure - in my cleaing I must have created some "action" or "trigger" that is not OK (as thats what I have done between this version and the previous one) but the problem that it is impossible to assign any aircraft to a strike mission is definatly a bug...

Will revert to the previous version where everything works fine. If some developer sees this I can send in the scenario where it is possible to reproduce the bug.




Gunner98 -> RE: Problem assigning planes to mission (No-Navigation Zones - landning marshal) (10/1/2016 11:22:40 AM)

Your best to post it on the Tech forum with a save game, perhaps a screenshot of the error message and anything that might help them sort it out.

good luck.




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.015625