[RESOLVED]Major launch bug on steam version (Full Version)

All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support



Message


HalfLifeExpert -> [RESOLVED]Major launch bug on steam version (10/30/2015 9:16:34 PM)

[UPDATE: PROBLEM RESOLVED]

Just updated on steam, not sure exactly what build it is, whichever one is current on steam

I click to play, and the splash screen comes up, without the Windows UAC popup. I click play, and then the UAC window comes up, splash comes up, I press play and steam says CMANO is already running. I can get out of this loop pretty easily, but I cannot launch at all

I verified game cache and it did not help at all

UPDATE: Launching steam in admin mode does work, but obviously due to security concerns I will wait till this is fixed. Also I got a look at the build and it is 757.6

Hope you guys will add a fix in 757.7

also, one small thing, is it possible for updates to retain my settings when installed? I play without autosave and with music off, kind of annoying to have to keep going back and changing that in the settings.




mikmykWS -> RE: Major launch bug on steam version (10/30/2015 11:59:09 PM)

Hi. You can retain your settings unless we update or add something to the file that stores that info which we did with the last build. So in this case sorry.

In terms of your crash issue please reboot and try again. If it still occurs just try reinstalling.

Thanks!

Mike




HalfLifeExpert -> RE: Major launch bug on steam version (10/31/2015 2:59:38 AM)

Fair enough on the settings, just wanted to mention it.

But my actual issue really isn't a crash, its a case of not launching properly.

UPDATE:

Tried rebooting, and reinstalling, neither worked, what did work was this solution someone posed on the steam disscusions, and is probably the key to a patch based solution

https://steamcommunity.com/app/321410/discussions/0/490124466463704480/

Seems like it would be something relatively simple to fix in a patch

also launching in this method bypasses the splash screen for some reason, so perhaps it is an issue of the program for the autorun not having been updated properly in the update.




mikmykWS -> RE: Major launch bug on steam version (10/31/2015 8:44:32 PM)

Pretty sure we did with the newest versions.

Sorry for your troubles but thanks!

Mike




HalfLifeExpert -> RE: Major launch bug on steam version (11/8/2015 4:23:11 AM)

There was a steam client update a couple days ago, and that did not resolve the issue.

Also the issue does not happen on my laptop for some reason. On my laptop install of CMANO/NI, there is no more UAC popup, but upon clicking play, it launches fine, sometimes with a slight delay of the image of the destroyer firing a missile popping up.

This is just strange, as when NI/1.09 first came out, I did not have the now resolved license issue on my laptop install, and now this new issue on my desktop is not on my laptop install.

Its also annoying as I never had any issues until the 1.09 update.

Bottom line, I can launch on my laptop fine, but I cant launch on my desktop without running steam in admin mode or doing a workaround which for some reason avoids the splash screen.




HalfLifeExpert -> RE: Major launch bug on steam version (11/16/2015 8:35:14 PM)

The new update did not fix this launch issue.

It has to be an issue with the program of the Splash screen, as completely bypassing it with the solution I linked does work, with steam not running in admin mode.

I tried setting the autorun.exe to run as admin, and the UAC does come up, but upon clicking play it just gets stuck in a loop of the splash screen popping back up.

The only difference between my laptop install and my desktop install, is that on the desktop, CMANO/NI (and all my games plus the actual install of Steam) are installed on a secondary internal HDD.

I should not have to, and will not do a reinstall onto my primary drive, which does not have a lot of space, as I have never had any issues with this setup until the 1.09 update (first with the license issue, but that was resolved quickly, and now this). My father also has CMANO on steam, but not NI, and also has it installed on a secondary internal drive, and his install has the same issue, and again, no problems until 1.09

And just to be clear, there are no error messages other than Steam saying that CMANO is already running, it is basically a case of not getting past the splash screen menu (clicking "Play Command: Modern Air Naval Operations" and that window just keeps coming back.

Steam admin mode works, but of course is not ideal, and bypassing the splash screen does work, with the linked solution, so from what I can tell it is an issue with the splash screen menu program.




HalfLifeExpert -> RE: Major launch bug on steam version (11/22/2015 1:53:22 AM)

Just wanted to bump this, to be sure you guys saw my update to it.




Dimitris -> RE: Major launch bug on steam version (11/22/2015 5:37:45 AM)

Is this issue persisting with the current version? (B757.10)

And just to be clear, running Steam in admin context avoids the issue?




HalfLifeExpert -> RE: Major launch bug on steam version (11/22/2015 3:43:34 PM)

quote:

ORIGINAL: Sunburn

Is this issue persisting with the current version? (B757.10)

And just to be clear, running Steam in admin context avoids the issue?


Yes it persists in 757.10.

And yes steam in admin mode works

Whatever is causing this has to do with the 757.6 update,in some way, it was the last official one before 757.10, as the issue immediately appeared after installing 757.6 through steam, as in the first startup after the update




VPaulus -> RE: Major launch bug on steam version (11/23/2015 5:33:53 PM)

Unfortunately this seems to be a local issue with your computer, maybe related with your UAC's behaviour or with the interference of one of your Internet security programs.
It is likely a new issue with 1.09 as since 1.09 CMANO now checks for the installation of Command: Northern Inferno, so running this additional check without Admin rights is likely causing your issue.
If this wasn't resolved by the previous fix then I don't think we will find a resolution tbh.
I would advise that you use the new desktop shortcut to run the game.






HalfLifeExpert -> RE: Major launch bug on steam version (11/23/2015 5:39:00 PM)

Thanks anyway, perhaps I will try one last re install, and I will be sure to remove all CMANO/NI files so that reinstalling it will be clean

I have NI, so im not sure why that would be an issue, but ill hope for the best with the reinstall.




HalfLifeExpert -> RE: Major launch bug on steam version (11/23/2015 6:46:26 PM)

UPDATE:

SUCESS!!!!!!!

I did a full reinstall via steam, deleting all files left behind. It didn't take too long thanks to my great internet connection[8D]

Upon firing up, the Splash screen came up same as before, and upon clicking play, I got an actual error message saying it couldn't connect to steam. then it advised me to check the command.exe file to see if it was running different privileges than steam, and apparently the command exe was running as admin, that setting was saved from an earlier attempt to fix the problem. I thought it would have been reverted with the reinstall. I changed that and now it starts up just fine, exactly the same as my laptop, with no annoying UAC popup (UAC setting is at default, I checked)

Thanks for your help, now I just need to re-download the community scenario pack and I will be good to go!




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.03125