Can't connect to opponent in lobby (Full Version)

All Forums >> [New Releases from Matrix Games] >> Close Combat Series >> Close Combat - Gateway to Caen >> Tech Support



Message


Housies -> Can't connect to opponent in lobby (8/4/2015 7:49:51 PM)

Problems:
-We both see each other name in the lobby
-We can't see messages the other player types (we had contact via steam chat)
-We can't connect to each other, when we try, the message establiching connection reamains on the screen till I have to do a Ctrl+Alt+Del
-We could connect to each other couple of days ago.

I experienced more issues with connecting to opponents sinces sunday, something changed with the server?

thanks for the support.




PipFromSlitherine -> RE: Can't connect to opponent in lobby (8/4/2015 9:16:30 PM)

We've had some server issues. Please try now.

Cheers

Pip




Housies -> RE: Can't connect to opponent in lobby (8/5/2015 9:03:16 PM)

Thanks,

This evening we were able to connect... after trying a few times however. Definitly improvement as we were able to play, but I still feel it's not working as it should.
thanks for the continued support.




Steve McClaire -> RE: Can't connect to opponent in lobby (8/6/2015 6:56:41 PM)

When you fail to connect are you seeing the message "Connecting to Opponent..." but your opponent never gets the invitation?

Steve




Housies -> RE: Can't connect to opponent in lobby (8/10/2015 9:25:15 AM)


quote:

ORIGINAL: Steve McClaire

When you fail to connect are you seeing the message "Connecting to Opponent..." but your opponent never gets the invitation?

Steve

Indeed, that was the issue. On my side, the game froze on the "Connecting to Opponent..." so I eventually had to close the game via Ctrl+Alt+Del magic.




Steve McClaire -> RE: Can't connect to opponent in lobby (8/11/2015 7:07:08 PM)

Thanks for the information. We'll continue to try and narrow down the issue.

Are you both you and your opponent able to chat in the game lobby without any errors?

Steve




RD_Knights_X -> RE: Can't connect to opponent in lobby (8/12/2015 2:57:45 AM)

Seve....just an FYI this same condition existed ("Connecting to Opponent..." but your opponent never gets the invitation) the one evening when Hetser and I wee tying to connect (my GRRRRRR post) the other evening.




PipFromSlitherine -> RE: Can't connect to opponent in lobby (8/12/2015 3:21:02 PM)

Have people having issues opened their firewalls for appropriate ports, or are they using the automatic routing?

Cheers

Pip




RD_Knights_X -> RE: Can't connect to opponent in lobby (8/13/2015 5:15:05 AM)

Yes (PipfromSlitherine), we have the appropriate ports on. Ho else would we been able to play prior to the incidents we are commenting on. The problem is in the game system and NOT with the players!




Housies -> RE: Can't connect to opponent in lobby (8/13/2015 8:07:41 AM)


quote:

ORIGINAL: PipFromSlitherine

Have people having issues opened their firewalls for appropriate ports, or are they using the automatic routing?

Cheers

Pip



I haven't done anything with ports (not sure how that works). But as mentioned by Knights; I was able to connect past month without any issue. Since start of august however it often works but it often says: [:-]




PipFromSlitherine -> RE: Can't connect to opponent in lobby (8/13/2015 3:01:58 PM)


quote:

ORIGINAL: RD_Knights_X

Yes (PipfromSlitherine), we have the appropriate ports on. Ho else would we been able to play prior to the incidents we are commenting on. The problem is in the game system and NOT with the players!

The system is specifically designed not to require ports to be opened to play (though you can reduce latency if you do) which is why I asked. That said, the lobby should not require any ports to be open.

The server is running without issue, and we can see other people connected, so will keep working to work out what is causing you guys problems.

Cheers

Pip




crackwise -> RE: Can't connect to opponent in lobby (8/14/2015 5:14:46 PM)

Funny to see that the multiplayer connection issues still plague this game. If you check the GtC forum, you will see that 80% of the problems are related with multiplayer issues and one of the weakest part is the lobby/server system.

We begged you guys to keep direct TCP/IP connection as an option so that people could play the game even if you had server issues or just stopped supporting the servers at some point.

Now I see that we were 100% right! Please keep this in mind at least for the upcoming CC games!




Steve McClaire -> RE: Can't connect to opponent in lobby (8/14/2015 6:05:04 PM)

As Pip said, you do not need port 1944 open to connect to an opponent. And I am investigating this but at the moment unable to reproduce the problem.

For those who have experienced it, are you using the Steam version of the game, or is your opponent?

Steve




Housies -> RE: Can't connect to opponent in lobby (8/17/2015 11:24:28 AM)


quote:

ORIGINAL: Steve McClaire

As Pip said, you do not need port 1944 open to connect to an opponent. And I am investigating this but at the moment unable to reproduce the problem.

For those who have experienced it, are you using the Steam version of the game, or is your opponent?

Steve


We were both using the steam version.




Steve McClaire -> RE: Can't connect to opponent in lobby (8/17/2015 11:05:18 PM)

I've been looking into this for a bit and I don't see any obvious issues. The only way I can see for people to 'miss' the invite is if it fails to get across via the lobby, or if it is being mishandled by the game. I can't reproduce either of these myself but it could be some sort of network timing issue that only some people get.

For those experiencing this, please use lobby chat (or Skype, or some other means) to double check with your opponent that both of your games have completely finished loading the lobby (i.e. the user list AND the match-making forums are both populated) BEFORE you offer a game. Please let me know if that appears to make a difference.

Steve




STIENER -> RE: Can't connect to opponent in lobby (8/23/2015 8:27:02 AM)

having the same issues today aug 22/15 and more issues...see my new thread. I have no ports open just using the lobby like its supposed to work...automatic routing? also see my thread and it could be coincidence...the lobby connection works better, but still screws up with my windows firewall OFF.




Steve McClaire -> RE: Can't connect to opponent in lobby (8/24/2015 7:17:02 PM)

Thanks for the info. Are you using the Steam version STIENER?

Steve




STIENER -> RE: Can't connect to opponent in lobby (8/25/2015 1:37:15 AM)

steve
im NOT using the steam version and I believe my opponents are not also.




Housies -> RE: Can't connect to opponent in lobby (1/20/2016 8:36:19 PM)

Is there any update on this topic?

Tried conneting to a unknown player today but we could not establish connection.




idc -> RE: Can't connect to opponent in lobby (1/20/2016 9:10:04 PM)

Hi Housies,
That was me. Thanks for investigating it. I had already tried connecting to a player who was sat in the same room as me and his computer was also having trouble seeing my connections (i.e. they were timing out). When I tried starting the connecting/hosting I got the message that he had refused my connection even though both of us could see that he hadn't. When he started it (as when you did) it simply timed out. So I think there was something odd going on, perhaps with my machine.

In addition I was getting the error, 'failed to get root' (I think it was), which appeared to be connected with a failure to display the integrated forum messages (which instead showed three dots as though they were continually trying to load and failing).

I guess I need to do a bit more digging, but its late here so will call it a day for now.
Sorry we couldn't play!
Ian




STIENER -> RE: Can't connect to opponent in lobby (1/22/2016 7:19:34 PM)

I had issues with connection on wed nite. e mailed steve about them. he was going to check with the server.....




idc -> RE: Can't connect to opponent in lobby (1/23/2016 8:10:22 PM)

Well, Saturday and getting the same problem. My friend here logs in successfully, but my machine appears not to do so fully. Symptoms as follows:

After clicking 'ok' in the Lobby Login dialog (Name pwd serial already populated correctly), I get 'connecting the Lobby System', then ' Gateway to Caen Multiplayer Lobby', click 'ok', and now I can see members in the lobby users section, but already I get a dialog titled 'Close Combat Error', reading 'Get forum root failed. Unknown error.' and a box 'ok' to click. I click 'ok'.

Now I can receive chat messages, but it is very noticeable that the Matchmaking Forum window is failing to populate. When I click 'join' it says 'connecting to opponent', and then I get 'Close Combat Error' 'Connect to opponent failed. Unknown error'. I click 'OK'.

The dialog titled 'Close Combat Error', reading 'Get forum root failed. Unknown error.' reappears and a box 'ok' to click. I click 'ok'.

When I try hosting or connecting to Barnaby (who is in the same room in the same house with me we get as far as seeing the message saying that he is asking me to join him (or vice versa), but when the other one of us accepts, we both get stuck in a 'connecting to opponent' dialog without it ever connecting.

It seems to me that this may have something to do with the fact that the forum fails to populate. Presumably some part of the connection is getting blocked? Yet I've looked into my router settings and it doesn't appear to be blocking any ports. I can't see why it wouldn't be working.
Any suggestions gratefully received. It is a recent download (since the New Year 2016) direct from Matrix games. So I presume it should be the latest version.

Thanks.
Ian




STIENER -> RE: Can't connect to opponent in lobby (1/23/2016 8:41:48 PM)

LOL....don't ever presume your getting the latest version. there is a patch out. that may be your problem bro. register your game with matrix and get the patch.
steve from matrix usually will eventually read your post and can help if the patch doesn't get you going.
hope this helps.

BTW where are you located?




idc -> RE: Can't connect to opponent in lobby (1/23/2016 8:48:25 PM)

I'm in the UK. I'll look for the patch. Thanks




idc -> RE: Can't connect to opponent in lobby (1/23/2016 8:55:00 PM)

It may be relevant that I'm trying to play the game on a mac through wine. But the odd thing is that it runs fine single player, and equally that my friend Barnaby is also successfully running on a mac and doesn't get the same error messages I'm getting. And the forum loads in the lobby, whereas in mine clearly it is trying to load but failing.




STIENER -> RE: Can't connect to opponent in lobby (1/23/2016 8:59:25 PM)

dump the game ...reload it and load the ver 1.02 patch. and see what happens. make sure ur buddy have the same version too ;-)




idc -> RE: Can't connect to opponent in lobby (1/23/2016 9:06:00 PM)

Right, hotfix downloaded and applied to both computers and we appear to have a connection!
Thank you very much for the advice, Stiener. Amazed that Matrix haven't put the patched version into the standard download a full 18 months after it was issued.
Thanks once again.




STIENER -> RE: Can't connect to opponent in lobby (1/23/2016 9:16:14 PM)

glad I could be of help. Matrix is an amazing out fit alright.
good hunting bro!




idc -> RE: Can't connect to opponent in lobby (1/23/2016 9:42:38 PM)

Successfully played a full game, so looks like that was a success and that running it on wine in Mac is not a problem. Thanks again for your encouragement. I might not have persevered otherwise!
Will see whether we can make an operation work tomorrow.
Very pleased to have CC working again. (Used to play it years ago.)




Housies -> RE: Can't connect to opponent in lobby (1/25/2016 9:54:09 AM)

That's great news idc.

I think you owe Steiner and me a battle online. In which battle you let us win on purpose off course, but in a way it's not too obvious.
It just helps my ego ;)

thanks




Page: [1] 2   next >   >>

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.03125