Weird performance comparisons (Full Version)

All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support



Message


thewood1 -> Weird performance comparisons (3/10/2015 1:30:06 AM)

Loaded Op Bassdrum and Shamal 1991 in 1.07 just to check performance. (Something I do after every major update). I have kept 1.06 also on my machine just as a benchmark.

In 1.06 and 1.07, they both run between 8 and 33 msec with some spikes to 60. Ran both for over 10 minutes. The 1.06 runs each game second at 1 real time second. In 1.07, each game second takes 3 seconds in real time. I tried it accelerated and with/without hi fi settings. All settings are the same. It just seems odd that the cycles are similar, yet the game seems to be struggling to keep up in 1.07.

Did something change in 1.07 that would cause this change in performance?

I have a 3.3MHz 8 core i7 with nVidia graphics and 12Mb RAM. One oddity is it seems like 1.06 is using more CPUs while 1.07 seems focused on 1 core.




thewood1 -> RE: Weird performance comparisons (3/10/2015 1:52:52 AM)

OK, ran some tests...

Just in 1.07. Started with a blank scenario over the Pacific. Created USN side. Started with Hi Fi on. Ran like I would expect...1 sec game = 1 sec real time. Added 5 B-1B bombers at 3000m in the middle of the ocean. Hit start. Immediately started running 1 sec in game time taking 3 sec in real time. Deleted the 5 B-1s. Restarted. Still ran slow. Couldn't do anything to get it running normally.

I haven't put a save up because it is happening in every scenario...included scenarios and simple ones that I scratch build.

I made a couple mistakes above...1.07 does seem to be using all CPUs, but one seems to spike quite often. Also, Hi fi does seem to make a difference. The slow downs only occur when I turn it on.

btw...all pulses were almost 0 msec in the test.




thewood1 -> RE: Weird performance comparisons (3/10/2015 10:49:41 AM)

Update. Even smaller scenarios like Albanian Airstrike with only 170 units is struggling in 1.07 for me. Pulses are 1-5 msec, but time is running 1 sec of game to 3-4 sec of real time.

I went baCK TO MY A10 AMD/ATI laptop and am seeing the same thing. And that laptop benchmarks at half the i7 I have.

Unfortunately I decided to reinstall 1.07 and accidentally installed over my 1.06 install. So I have no older benchmark right now.




jarraya -> RE: Weird performance comparisons (3/10/2015 2:08:15 PM)

Had the same last night but noticed ok performance after a full restart of my machine. Have you tried that?

Sorry, take that back. Now having the same problem. No issue with sounds off though.




thewood1 -> RE: Weird performance comparisons (3/10/2015 3:30:46 PM)

I actually just did a reinstall from scratch...and a reboot just to make sure.

I think it was a sound file corruption when I downloaded 1.07. The options all default to sound back on in 1.07 when installing. When I shut sound off, 1.07 ran fine. In my 1.06 install, sound was always off. So on the reinstall, everything works OK so far with sound on and off.




mikmykWS -> RE: Weird performance comparisons (3/10/2015 11:24:33 PM)

Thanks Wood. Interesting result after removing the aircraft. Added this to our list and will take priority once we're back.
Mike




thewood1 -> RE: Weird performance comparisons (3/11/2015 1:19:53 AM)

Mark is fixed...I think it was a corrupted sound file as stated in my last post. Reinstall fixed it.




mikmykWS -> RE: Weird performance comparisons (3/11/2015 1:49:20 AM)

Ok great.

mike




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
2.148438E-02