HD environment mod (updated to 1.2) (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding



Message


nvek -> HD environment mod (updated to 1.2) (6/4/2014 5:38:00 PM)

Hi all,

There are several mods that include a few HD textures for planets, but none of them were complete and work to combine them seemed to have stalled.
So I started to collect them all, combine them and add some more to make the pack complete.
Then I decided to work on some other other things such as stars, nebula's, supernovae, black holes and a new background.
All of this has been put together not just to add high definition but allso to create more diversity and realism.

Installation:
These images are very heavy and may impact your game performance, so you should definately make a backup of your environment folder first!
Unzip and copy to the correct directory, if you are playing without mods:

game directory/images

If you are playing with a mod that replaces (some) environment graphics and you want to use this mod to supplement them:
game directory/customization/yourmodname/images

Credits:

Martian - Graphics Enhancement Mod (GEM)
Tyrador - Prothean Cycle Mod
Kalthaniell - MASS EFFECT MOD
Igard - New Planet Textures

If I forgot anyone or if you don't want me to include your work please let me know.

Download full mod (version 1.2):
drive.google.com/file/d/0Bw6qxZOIMc_-eGQ5ZjB1NWxmbVU/edit?usp=sharing

Or only the patch if you want to update from version 1.1 to 1.2:
drive.google.com/file/d/0Bw6qxZOIMc_-ZnE1azNUZlkzb0E/edit?usp=sharing

Version 1.2:
- fixed a barren rock appearing as a square
- added bugfix for players that have installed the GEM mod (spheres appearing inside the planets)
- replaced some more barren rock planets





Mesthione -> RE: HD environment mod (6/4/2014 9:10:09 PM)

I really want to download this file but this box.com link won't download. The site is acting really weird....maybe someone else can comment on this.

Would you mind loading it to another host?




FireLion1983 -> RE: HD environment mod (6/4/2014 9:23:28 PM)

Thank you for this; I will check it out next time I play the game.




Mesthione -> RE: HD environment mod (6/4/2014 10:35:40 PM)

Could anyone who has downloaded this upload it anywhere else? I'm pulling out my hair trying to get box.com to work. I've tried three different browsers, disabled antivirus and firewall, etc. Weird.




Locarnus -> RE: HD environment mod (6/4/2014 10:43:51 PM)

Doesnt work for me either.




nvek -> RE: HD environment mod (6/4/2014 11:01:43 PM)

I believe I had clicked a wrong button at the box website, de-sharing it, should be working again.
i am currently allso uploading to a mirrow, will edit the first post when done.




Locarnus -> RE: HD environment mod (6/4/2014 11:10:29 PM)

Second one works (first one still doesnt, I think it s their website)

Thanks for sharing!




TheRevanchist -> RE: HD environment mod (6/5/2014 12:01:17 AM)

thank you! Looking forward to it.




Unforeseen -> RE: HD environment mod (6/5/2014 1:53:47 AM)

What is with the forest planets? Some of them seem out of place with brighter shading and an odd blue highlight around them. Other than that do you have any issues with me uploading this as a part of my orange mod theme?




nvek -> RE: HD environment mod (6/5/2014 1:15:20 PM)

Yeah not all of the forest and barren rock are HD yet, I'm currently uploading a new update (1.1) to adress that.

Will edit the first post when done.

I have no problem with you using this in your orange mod theme.




Buio -> RE: HD environment mod (6/5/2014 1:17:39 PM)

You should put a text file in the root of the mod with author credits too, and preferable links to their separate work.




Unforeseen -> RE: HD environment mod (6/5/2014 1:52:19 PM)

Thanks :D, when i upload the first release i'll be updating the OP of the mod thread with credits and details/links up the individual mods included. There is also a readme in the theme directory that does the same.




nvek -> RE: HD environment mod (6/5/2014 2:53:54 PM)


quote:

ORIGINAL: Buio

You should put a text file in the root of the mod with author credits too, and preferable links to their separate work.


I put one in the environment folder in my latest upload, includes links.
I'll include links here allso once I am actually permitted to do so.




vmxa_slith -> RE: HD environment mod (6/5/2014 3:20:00 PM)

Is there a place where I can see what the mod looks like?




nvek -> RE: HD environment mod (6/5/2014 4:03:58 PM)

I can't post screenshots yet, but if anyone else wants to please feel free.

Alternately you could simply watch some of the images before actually installing.




Buio -> RE: HD environment mod (6/5/2014 9:35:43 PM)

quote:

ORIGINAL: nvek
I put one in the environment folder in my latest upload, includes links.
I'll include links here allso once I am actually permitted to do so.


Good stuff! :)




Unforeseen -> RE: HD environment mod (6/6/2014 11:23:04 AM)

I've recreated this twice now, when i generate a new galaxy the planets are not showing correctly. I'm seeing varying results as shown in the screenshot. Not shown in the screenshot is another issue where instead of a continental planet image being used it used a forest planet image.

[image]local://upfiles/44367/51C5D8975A3C4A88BD9CC2C9E2E4D84D.jpg[/image]




nvek -> RE: HD environment mod (6/6/2014 12:24:01 PM)

That is a problem that may occur when using overlays from a different version or mod (not sure exactly which one).

I don't have the problem myself, so I think overwriting the overlays in your environment folder with these should fix the problem:


drive.google.com/file/d/0Bw6qxZOIMc_-MjdEZ1MyaDdGS2c/edit?usp=sharing




AstroCat -> RE: HD environment mod (6/6/2014 12:40:51 PM)

2 issues... in the current build there is a "problem" that planets and overlays have to be the same size as the vanilla files, it used to not be this way, and I don't think this is working as intended. Also the shadow file you are using is probably from GEM, this was changed along the way, so you now need to use the latest vanilla shadow file. Hope this helps.




nvek -> RE: HD environment mod (6/6/2014 1:33:57 PM)

Forrest planets showing up as continental ingame is normal, there is no category forrest planets ingame.

The image of the moon showing as a square is probably caused by the image being too heavy (I think it's about the heaviest in the pack).
For now you can fix it by overwriting Barren-0021.png with the one from your backup.

I'll have a look into a proper fix somewhere in the coming days.




Unforeseen -> RE: HD environment mod (6/7/2014 12:39:47 AM)

Any idea why the planets seem to have another planet sticking out of them? I have checked and rechecked my folders and there doesn't seem to be anything causing it.




WaflHead -> RE: HD environment mod (6/7/2014 1:00:31 AM)

Yes, I had the same problem with planets inside other planets after installing numerous mods. If I remember correctly I had to delete the shading.png file from customization, then changed theme to DW Original then changed theme back to DW Extended to resolve.




AstroCat -> RE: HD environment mod (6/7/2014 1:45:20 AM)

Its because of what I said above. Before the planet and overlay files could be any size and the game would resize them for you. Now for whatever reason it doesn't and the planets and overlays have to be the save exact size as the vanilla planets.

That's the problem. Over in the GEM thread we talked about it, and I fixed all his planets and overlays. Someone would have to do the same for any that you are using.

I hope they fix this issue as it only seems to effect the planets and overlays, at least what I can tell.




Unforeseen -> RE: HD environment mod (6/7/2014 1:57:36 AM)

quote:

ORIGINAL: AstroCat

Its because of what I said above. Before the planet and overlay files could be any size and the game would resize them for you. Now for whatever reason it doesn't and the planets and overlays have to be the save exact size as the vanilla planets.

That's the problem. Over in the GEM thread we talked about it, and I fixed all his planets and overlays. Someone would have to do the same for any that you are using.

I hope they fix this issue as it only seems to effect the planets and overlays, at least what I can tell.

ahhhh ugh..........thank you for this. Going to have to switch to GEM planets/overlays until a new set of HDs is released. I just really extremely terribly hate that planet set. The coloring is COMPLETELY wrong. Still better than vanilla, still wrong.




nvek -> RE: HD environment mod (6/7/2014 5:36:15 PM)

quote:

ORIGINAL: Unforeseen

quote:

ORIGINAL: AstroCat

Its because of what I said above. Before the planet and overlay files could be any size and the game would resize them for you. Now for whatever reason it doesn't and the planets and overlays have to be the save exact size as the vanilla planets.

That's the problem. Over in the GEM thread we talked about it, and I fixed all his planets and overlays. Someone would have to do the same for any that you are using.

I hope they fix this issue as it only seems to effect the planets and overlays, at least what I can tell.

ahhhh ugh..........thank you for this. Going to have to switch to GEM planets/overlays until a new set of HDs is released. I just really extremely terribly hate that planet set. The coloring is COMPLETELY wrong. Still better than vanilla, still wrong.


I believe you may have misunderstood astrocat.

The main difference between JPG and PNG images is that PNG images usually have a layered structure.
In the case of these planets it has 2; the foreground (the actual planet) and the background, which is empty (not white!) and can be filled in by the game.

In older versions of the game the relation of the size of the foreground image to the background layer didn't matter, the game would auto-correct them, the GEM mod was made for older versions of the game and depended on its engine to correct the image-background relation.

The GEM mod doesnt just contain planet images but allso overlays which are not the correct size for Universe and they are what's causing your problem.

I noticed this problem allso in some of my planets but I fixed most of them before releasing version 1.0 of my mod. ( and fixed the last with patch 1.1)
If you are experiencing this problem it's because you installed the outdated GEM overlays, in particular the shadow overlay image from the GEM mod is too small in relation to its's background and this is what makes you see spheres inside planets.
You need to replace them with the vanilla, which I posted a download link to a few posts above.




AstroCat -> RE: HD environment mod (6/7/2014 8:09:10 PM)

Nvek's correct. If you go to the GEM thread and download my version 3 update you will get all fixed GEM planets, including correct naming and the fixed overlays, which you could use with any mod.




Unforeseen -> RE: HD environment mod (6/7/2014 10:40:17 PM)

Hmm, well i know i was getting the issue with the overlays from here. I'm going to upload the base of my mod with Gem's planets for now and i'll give things a try again later, right now i'm scrambling to get my first upload together and figure out the best way to release a color update to msnevil's beam weapons[it is missing two colors he wasn't able to make]. Thanks for the info!!!




nvek -> RE: HD environment mod (1/1/2020 8:18:46 PM)

Hi, sorry for digging this up, I'm the original auther of this mod, but I have lost it, and obviously the link is no longer working.

I was wondering if anyone still has this mod stored somewhere, and if so could please upload it or send it to me thanks.




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
2.734375E-02