AI troop garrisoning and fleet retrofit problems (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support



Message


drmario89 -> AI troop garrisoning and fleet retrofit problems (6/8/2013 11:27:43 PM)

Under the troop recruitment section of the empire policy screen, there is an option to regulate the amount of troops the ai will garrison at colonies. I usually set this to "none" and garrison troops myself. However, the ai still garrisons troops and even un-garrisons the ones that I manually garrison and resets to its original garrison choices. I can't find any other options regarding troop garrisoning so I assume this isn't the intended ai behavior.

Also, fleets will go and retrofit when I approve the prompt from the advisor, which is normal, but they do it even when there are no new designs to upgrade to. Every ship in the fleet would be the latest design. I should also note that the individual ships when not in a fleet DO NOT go for a retrofit when there are no new designs, as they are set to manual retrofit status. The ships on auto retrofit will queue a retrofit at the advisor prompt, but will cancel it after it finishes whatever its doing if there are no new designs. I only manually upgrade and retrofit military ships, while the other state ships auto retrofit. State bases and private stuff is on full auto and works fine.

Again, it's only when ships are in a fleet do they try and retrofit at the advisor's prompt when there are no new designs for them, and I don't recall this happening before Shadows. This can be very frustrating with multiple fleets, having to cancel each retrofit mission before they run off to a spaceport. This may have something to do with the problem of fleets not properly retrofitting when manually told to do so as a fleet, which was reported here a few days ago by someone else. Hopefully all of that made some sense. I'll try to provide a save file where these things are occurring.




drmario89 -> RE: AI troop garrisoning and fleet retrofit problems (6/9/2013 12:06:19 AM)

I found out that while the fleet status says "retrofit at...", each individual ship in that fleet says it's status is to "refuel at..." This is when I approve the advisor's retrofit prompt and all the ships in the fleet are already the latest designs.

Uploaded a save file under my forum name.




Erik Rutins -> RE: AI troop garrisoning and fleet retrofit problems (6/12/2013 12:36:36 AM)

Thanks, we are investigating.




elliotg -> RE: AI troop garrisoning and fleet retrofit problems (6/14/2013 9:24:33 AM)

quote:

ORIGINAL: drmario89
Under the troop recruitment section of the empire policy screen, there is an option to regulate the amount of troops the ai will garrison at colonies. I usually set this to "none" and garrison troops myself. However, the ai still garrisons troops and even un-garrisons the ones that I manually garrison and resets to its original garrison choices. I can't find any other options regarding troop garrisoning so I assume this isn't the intended ai behavior.

This happens because you have Troop Recruitment set to be automated in the Game Options screen. When Troop Recruitment is automated, all troop management at colonies is handled by the AI. Thus when you manually garrison troops, the AI will then follow your empire policy settings (no garrisoned troops), thus overriding your changes.

To manage colony troop garrisons yourself you must turn Troop Recruitment automation off.

quote:


Also, fleets will go and retrofit when I approve the prompt from the advisor, which is normal, but they do it even when there are no new designs to upgrade to. Every ship in the fleet would be the latest design. I should also note that the individual ships when not in a fleet DO NOT go for a retrofit when there are no new designs, as they are set to manual retrofit status. The ships on auto retrofit will queue a retrofit at the advisor prompt, but will cancel it after it finishes whatever its doing if there are no new designs. I only manually upgrade and retrofit military ships, while the other state ships auto retrofit. State bases and private stuff is on full auto and works fine.

Again, it's only when ships are in a fleet do they try and retrofit at the advisor's prompt when there are no new designs for them, and I don't recall this happening before Shadows. This can be very frustrating with multiple fleets, having to cancel each retrofit mission before they run off to a spaceport. This may have something to do with the problem of fleets not properly retrofitting when manually told to do so as a fleet, which was reported here a few days ago by someone else. Hopefully all of that made some sense. I'll try to provide a save file where these things are occurring.

Thanks for that report. This is fixed in the 1.9.0.6 update, which should be available tomorrow.

Elliot




FFCecil -> RE: AI troop garrisoning and fleet retrofit problems (8/15/2016 11:41:11 AM)


quote:

ORIGINAL: elliotg

quote:

ORIGINAL: drmario89
Under the troop recruitment section of the empire policy screen, there is an option to regulate the amount of troops the ai will garrison at colonies. I usually set this to "none" and garrison troops myself. However, the ai still garrisons troops and even un-garrisons the ones that I manually garrison and resets to its original garrison choices. I can't find any other options regarding troop garrisoning so I assume this isn't the intended ai behavior.

This happens because you have Troop Recruitment set to be automated in the Game Options screen. When Troop Recruitment is automated, all troop management at colonies is handled by the AI. Thus when you manually garrison troops, the AI will then follow your empire policy settings (no garrisoned troops), thus overriding your changes.

To manage colony troop garrisons yourself you must turn Troop Recruitment automation off.

Elliot



I realize this is an old post but I have the same problem even with 1.9.5.12 version. I think what he meant was that the AI will garrison nearly all troops even if it's set to garrison no troops in the Fully Automated troops section.

I have Troop Garrison Level at Colonies set to None and go into Troops section and ungarrison everything from every colony and a few days later all my troops at homeworld that aren't being recruited are back in the garrison.

12 out of 13 troops at my homeworld are garrisoned with the option set to no garrisoned troops. Ideally I wanted it set to low and it keep like 3 garrisoned so my troop transports can get picking up troops. I don't want to manually go to each planet and create troops and garrison which is what I have to end up doing. Can't get it to work right.

Troops are too expensive in the beginning to have so many garrisoned on top of having a fleet of them on transports.

Please look into this. I'm using the latest version of Universe. 1.9.5.12.




Tank Commander_MatrixForum -> RE: AI troop garrisoning and fleet retrofit problems (4/25/2019 8:30:17 AM)

The last post was 2.5 years ago and never answered, the original nearly 6 years ago

at 25th April 2019 this is STILL a major issue. I have the same problems as described above and as originally reported 6 YEARS AGO
1. Changing the green highlighted troops to ungarrison troops will soon after get reset back
2. Set Fully Automated troops to MANUAL, Changing the green highlighted troops to ungarrison troops will soon after get reset back

This is a major issue as I CANNOT load troops and therefore I CANNOT attempt to take over planets via a ground battle. Surely this is a very simple change

Like the the post 2.5 years ago, I am also on the same unchanged version of Universe 1.9.5.12

@Eric Ruttins
@EliotG




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
2.392578E-02