Reporting bugs for 1.7.0.16 (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support



Message


chrisrox -> Reporting bugs for 1.7.0.16 (8/1/2012 6:49:55 PM)


Got a few bugs to report in, starting with the biggest.

1. Ships starting with no weapons
Had a big problem with all military ships for all races as well as pirates receiving no weapons at game start. So i started experimenting a bit with the policy files under Distant Worlds\Policy\. Moving or deleting these solved the problem, as well as using my ingame customised policy file with the starting race name. So i compared the "in game" generated file with the others and the only difference i could find was that all decimal-values used , in the one that worked and . in the others.

Solution to 1
Replaced all . with , in all race policy files and now it works like a charm.

2. Ingame generated policy file doesnt save the following values:
Allow sabotage mission: Destroy base
Allow sabotage mission: Assassinate character
When establish new colony, immediately build this base
Never recruit troops until colony population reaches

3. DesignComponentAreaWeaponsSpaceports is set to N in policyfiles and cant be changed ingame.


Love the game!!!




dejagore -> RE: Reporting bugs for 1.7.0.16 (8/6/2012 12:15:28 AM)


quote:

ORIGINAL: chrisrox
Solution to 1
Replaced all . with , in all race policy files and now it works like a charm.


Like DesignComponentWeaponsBeamMilitaryLevel ;1.0 -> DesignComponentWeaponsBeamMilitaryLevel ;1,0 ?

Hope it would be fixed in the next patch as it's pretty annoying defect. Although good that there is a workaround.




chrisrox -> RE: Reporting bugs for 1.7.0.16 (8/7/2012 6:49:32 PM)

Yep, exactly. Did it work?

Anyone else having this bug with ships receiving no weapons?





Francoy -> RE: Reporting bugs for 1.7.0.16 (8/7/2012 10:44:27 PM)

Yes i have the bug also.

I have a French version of Windows 7, here what i have done to resolve the problem:

In the language settings of windows, set your decimal value to '.' instead of ','




Arcatus -> RE: Reporting bugs for 1.7.0.16 (8/8/2012 7:36:55 PM)


quote:

ORIGINAL: chrisrox

3. DesignComponentAreaWeaponsSpaceports is set to N in policyfiles and cant be changed ingame.



Area weapons on your spaceport will wreck havoc on your transports if a pirate or enemy gets close. It does allot more harm than good...

(So why would you want to change it to yes..?)




Dracus -> RE: Reporting bugs for 1.7.0.16 (8/9/2012 12:21:19 AM)

you don't need to change it, you can manually add them and create your own designs. but area weapons do just as much damage to your stuff as the enemy. I try never to research them.




Niaru -> RE: Reporting bugs for 1.7.0.16 (8/10/2012 3:14:55 PM)

Had an interestig thing last night:

My agent can not go beyond 100% espionage skill. Every time the experience bar hits the full condition, it resets to zero and the agent stays at 100%. Considering that before 1.7.0.16 I had agents with >150% espionage, this is annoying.
Or did I miss something in the Patch notes?




Afalos -> RE: Reporting bugs for 1.7.0.16 (8/30/2012 10:44:07 AM)

Military ships were also missing armor and shields for me. This solved the problem neatly, thank you very much. :)




FlashXAron_slith -> RE: Reporting bugs for 1.7.0.16 (9/7/2012 9:51:07 AM)

... colony screen not showing up, after a long time of play ...
F2 screen

ht
tp:
//
www
.gamefront.
com
/files
/22220769/
The+Federation+2809-01-14.zip


idiotic forum, still not allowed to post links

... so the bug occured once again ...
press F2 and you have it !




Bingeling -> RE: Reporting bugs for 1.7.0.16 (9/7/2012 11:21:07 AM)

You can upload saves related to tech reports to the matrix server. Look at the top sticky of this forum. "Where to upload save files".

Then it is enough to give the file name.

As for your link issues, I am not sure what that is.





PlacidDragon -> RE: Reporting bugs for 1.7.0.16 (9/8/2012 4:03:55 AM)

Also have the same problem with no weapons. I just bought the game (an hour ago), along with the two expansions, downloaded, installed, patched up, and hey presto, no weapons on any of my military ships. There might be other problems as well, but i sort of dont get past the one i found immediately...lol

This is with US English Windows 7 (64 bit ultimate), so there shouldnt be a language issue.

I'll try your fix, hopefully that solves things :)


Edit : Yup, that fixed it just fine [&o]

I guess i'll have to do it for every policy file there is then *sigh*.. ah well..

How could something like this possibly slip past Q&A ? It just... shouldnt happen




Volcano -> RE: Reporting bugs for 1.7.0.16 (9/14/2012 6:05:44 PM)

I also got the problem of all military ships without any weapon or shield components, and when modifying the policy files as chrisrox told it, I noticed that the header line of all these files tells 1.7.0.14 whereas the game is in 1.7.0.16 version. Is that normal ?




Gargoil -> RE: Reporting bugs for 1.7.0.16 (9/14/2012 6:25:00 PM)

Interesting the no weapons bug, as I do not have it.

I wonder why some of us do, and some of us don't?




louisrousseau -> RE: Reporting bugs for 1.7.0.16 (9/23/2012 3:42:30 AM)

I'm also running Windows 7 x64.

Two words: regional settings. For some reason the program uses the regionally set decimal symbol in the "policy" and "races" text files. The originals have a period, as expected on US English computers, whereas a custom policy file saved by me is output with commas instead, as "appropriate" in a French Canadian setting. Of course this setting is mostly meant for UI purposes, in "locale-aware" applications, not backend stuff in a game.

I just modified the files by replacing the periods by commas... (thank goodness for Notepad++) I've resumed my game and I'll wait to see what the AI does once it refreshes my designs next time around, not without ordering a few, err, creations of my own.




Jon Micheelsen -> RE: Reporting bugs for 1.7.0.16 (9/23/2012 10:49:54 PM)

I think there might be a small calculation error, if you have two demoralizing agents on a steal tech mission initiated on the same time, where the target is the same. They level extremely fast, 70-80% maybe on a one year mission. Is it a -*-=++ maybe? I only had it happen on a few missions before the one got caught, but I think there was a noticeable difference on leveling. The one was around 5% no skill the other 45% multi-skill but both gained more very fast.




Bingeling -> RE: Reporting bugs for 1.7.0.16 (12/9/2012 10:44:43 AM)

One confusing thing about the no weapons bug.

I have two computers. My stationary works well. It has "," as the decimal separator in regional settings, and "." as separator in the policy files.

My laptop has the exact same regional settings for both, and bugs.

So two computers, running the same OS with the same regional settings - only one got the problem. Trying to mess with compability settings did nothing useful, the only thing I can think of being different (apart from hardware), is that the stationary has been running various beta versions, while the laptop is new.

And what annoys me most is that I fixed it, wanted to reinstall DW, and backed up the wrong folder... So I have to do the 20 "replace alls" again.




Bingeling -> RE: Reporting bugs for 1.7.0.16 (12/9/2012 9:14:46 PM)

Or not. The stationary was bugged as well. I think this is new in 0.16 or some of the prior steps, as I have played beta patch games in the past with no issues.




Antiscamp -> RE: Reporting bugs for 1.7.0.16 (12/19/2012 6:16:15 AM)

I had this game-breaking bug as well. Luckily, I saw this thread last night before purchasing the Legends expansion and was able to fix it. The game seems to be OK now. Thanks for the thread.




Bingeling -> RE: Reporting bugs for 1.7.0.16 (12/19/2012 8:38:52 AM)

The best fix is the beta patch (...17). Sticky about it is on the main forum.




Antiscamp -> RE: Reporting bugs for 1.7.0.16 (12/19/2012 8:58:01 AM)

Ah. Thanks. I'll get that ASAP then.




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.03125