RE: Public Beta for Legends v1.7.0.15 now Available! (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series



Message


Evrett -> RE: Public Beta for Legends v1.7.0.15 now Available! (6/17/2012 1:14:26 AM)

The next patch needs to put some attention to loading times...this game really take way to long to start up. Thanks




Bebop Cola -> RE: Public Beta for Legends v1.7.0.15 now Available! (6/18/2012 2:01:28 AM)

quote:

ORIGINAL: Andrew Loveridge
  • Fixed crash when using game editor to change development level on highly-developed planet (160+).

  • This appears to still exist, it's just been pushed out. Wekkarus planets with an underwater palace and access to one of the ultra-rare resources can be at 190% development. Attempting to use the editor on such a planet produces the same error.




    Gzu -> RE: Public Beta for Legends v1.7.0.15 now Available! (6/18/2012 10:29:13 PM)

    quote:

    ORIGINAL: Shark7


    quote:

    ORIGINAL: MartialDoctor


    quote:

    ORIGINAL: jlevans

    There was also some debate about whether the AI actually uses the adjusted policy files modified by players, when they are placed in the customization folder. Is it confirmed that this now occurs?


    Actually, I was starting to think this was an issue as well.


    Actually, I think there is little debate, it seems to be more of a fact.



    I made a serval tests. In my games, engine just apply one standard* policy for all the empires. No matter if i use customization folder or edit orginal data files.

    *standard = all set to normal/balanced/etc.




    apd1004 -> RE: Public Beta for Legends v1.7.0.15 now Available! (6/24/2012 12:40:44 PM)

    Normally I stay away from betas because you basically have to re-customize everything from scratch. I decided I would give them a try a couple versions ago.

    One thing I've noticed with the betas is that automated construction ships have a bad habit of building the wrong type of research station at planets that have a bonus to one type of research. For instance, an AI construction ship will build an energy research station at a planet that gives a 13% bonus to weapons research.

    Not sure which beta I started seeing this occur, and I don't remember it being an issue with the non-beta versions although maybe I just never noticed it and assumed automated construction ships would match the research stations to the bonus.

    Cheers




    Master_of_Orion -> RE: Public Beta for Legends v1.7.0.15 now Available! (6/26/2012 8:26:56 PM)

    good new things in this beta!

    But the automation of the passenger ships is not good. Maybe it would be better to manage it manually. I think, perfect would be two options in the population screen of every colony - 1. migrate people from this colony; 2.migrate people to this colony




    Javaslinger -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/10/2012 11:06:07 PM)

    Looks like 1.7.0.15 is no longer available in the members club. And the only official version is way back at 1.7.0.6 which I assume is about 9 generations older than the latest beta...

    Is there something new on the horizon imminently???




    HectorOfTroy -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/11/2012 7:53:35 AM)

    It's still there.




    MartialDoctor -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/12/2012 11:58:03 AM)

    Any ETA on when we can expect an official patch to be out?

    Thanks. [8D]




    Simulation01 -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/14/2012 5:30:45 PM)

    +infinity to MartialDoctor[sm=Christo_pull_hair.gif]




    Bleek -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/18/2012 11:13:59 PM)

    How do these beta patches work, am I ok to stick to the official release or am I missing out and 'game changing' additions by not testing the beta patches?




    WoodMan -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/19/2012 12:13:16 AM)

    Every time I start a new game I get the latest patch be it official or beta. The official patches are basically a culmination of many beta patches. I wouldn't say it is vital to get it right away, wait until you finish your current game then go for it. [;)]




    Haree78 -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/19/2012 2:29:43 AM)

    quote:

    ORIGINAL: Bleek

    How do these beta patches work, am I ok to stick to the official release or am I missing out and 'game changing' additions by not testing the beta patches?


    As Woodman says stick with your current game but if you are thinking of starting a new one the current beta is well worth using. 1.7.0.15 is a lot better than the current official version.




    michaelm75au -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/19/2012 8:53:56 AM)


    quote:

    ORIGINAL: Gzu

    quote:

    ORIGINAL: Shark7


    quote:

    ORIGINAL: MartialDoctor


    quote:

    ORIGINAL: jlevans

    There was also some debate about whether the AI actually uses the adjusted policy files modified by players, when they are placed in the customization folder. Is it confirmed that this now occurs?


    Actually, I was starting to think this was an issue as well.


    Actually, I think there is little debate, it seems to be more of a fact.



    I made a serval tests. In my games, engine just apply one standard* policy for all the empires. No matter if i use customization folder or edit orginal data files.

    *standard = all set to normal/balanced/etc.

    I recall some issue around permissions on these files for customomisation. If not read only, they weren't accessed.[&:]
    Maybe I am mixing this up with some other set of files.




    ASHBERY76 -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/19/2012 9:39:32 PM)

    ETA on next beta?




    oxenshtrudel -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/20/2012 5:39:19 PM)


    quote:

    ORIGINAL: ASHBERY76

    ETA on next beta?

    Soonish. The next update is undergoing closed tests right now. Unless something major is found it will most likely be released soon.




    Erik Rutins -> RE: Public Beta for Legends v1.7.0.16 now Available! (7/20/2012 6:10:34 PM)

    Hi Everyone,

    The new 1.7.0.16 Public Beta Update for Distant Worlds: Legends is now available. We hope this will be the last public beta update before this becomes an official update in a week or two.

    For those that are willing to help us give this a test before it becomes official, it is very much appreciated.

    The updated change list is in the first post in this thread.

    Regards,

    - Erik




    ASHBERY76 -> RE: Public Beta for Legends v1.7.0.16 now Available! (7/20/2012 6:22:24 PM)

    Nice timing.




    Speedy2511 -> RE: Public Beta for Legends v1.7.0.16 now Available! (7/20/2012 10:23:13 PM)

    Hey, thanks for the update :)

    Greetings from Germany
    Nico




    tjhkkr -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/20/2012 10:23:41 PM)

    Thank you!




    Igard -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/20/2012 11:23:10 PM)

    Thanks for the update, an hour played looks good so far!




    MartialDoctor -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/21/2012 8:07:01 AM)

    Nice work. Good to have a new update here [:)]




    chrono280 -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/21/2012 10:52:53 PM)

    Wanted to report a bug (at least I think it is a bug) in 17.0.16:

    If you select a design, then select Manually Upgrade, then, if you do not change anything and just hit CANCEL instead of SAVE, the design is automatically marked as obsolete. I don't know if this happens in earlier beta builds because I haven't done as much playing in those.

    Hope this helps, thanks again for making a terrific space 4x [:)]




    vengen -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/22/2012 1:58:32 AM)

    I've noticed a few things that may be bugs in 1.7.0.16 (but I've played so infrequently in the last two years that they may be things that I've somehow messed up in my settings):

    1 - Started a game as Wekkarus and the default escorts were the size of frigates, the default frigates were the size of destroyers, and the default destroyers were so large that I could not even build them.

    2 - My next door neighbor Hakonish kept removing its trade embargo, then immediately re-imposing it. Both messages appear at the same time - the removal above the re-imposition. This stopped once I built a bunch more warships.

    3 - I can't build them yet, but I have a bunch of non-obselete designs for Cruisers and Battleships in my design screen.

    4 - This has been happening since at least 1.7.0.12, but sometimes I get an exotic resource on two different planets - it's usually Zentenaba Fluid. Is that WAD or a bug?

    I'm not seeing anyone else post bugs, so I'm thinking that this is probably an issue with my machine, a corrupt install, or I've messed up my settings?

    Edit - On second thought - does this belong in the tech support forum?

    2nd edit - Post moved to the Tech Support Forum.




    MartialDoctor -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/22/2012 4:51:16 AM)

    Yeah... you guys need to place those bugs in the tech forum section [:)]




    scotten_usa -> RE: Public Beta for Legends v1.7.0.15 now Available! (7/22/2012 4:49:32 PM)


    quote:

    ORIGINAL: chrono280

    Wanted to report a bug (at least I think it is a bug) in 17.0.16:

    If you select a design, then select Manually Upgrade, then, if you do not change anything and just hit CANCEL instead of SAVE, the design is automatically marked as obsolete. I don't know if this happens in earlier beta builds because I haven't done as much playing in those.

    Hope this helps, thanks again for making a terrific space 4x [:)]


    Old bug, been around forever....




    chrisrox -> RE: Public Beta for Legends v1.7.0.15 now Available! (8/1/2012 5:23:04 PM)

    Got a few bugs to report in, starting with the biggest.

    1. Ships starting with no weapons
    Had a big problem with all military ships for all races as well as pirates receiving no weapons at game start. So i started experimenting a bit with the policy files under Distant Worlds\Policy\. Moving or deleting these solved the problem, as well as using my ingame customised policy file with the starting race name. So i compared the "in game" generated file with the others and the only difference i could find was that all decimal-values used , in the one that worked and . in the others.

    Solution to 1
    Replaced all . with , in all race policy files and now it works like a charm.

    2. Ingame generated policy file doesnt save the following values:
    Allow sabotage mission: Destroy base
    Allow sabotage mission: Assassinate character
    When establish new colony, immediately build this base
    Never recruit troops until colony population reaches

    3. DesignComponentAreaWeaponsSpaceports is set to N in policyfiles and cant be changed ingame.


    Love the game!!!


    !!!!Post moved to the Tech Support Forum!!!!





    ASHBERY76 -> RE: Public Beta for Legends v1.7.0.15 now Available! (8/15/2012 7:44:23 PM)

    ETA on next beta.The autodesign isssue is pretty serious.




    endoric -> RE: Public Beta for Legends v1.7.0.15 now Available! (8/17/2012 6:47:28 PM)


    quote:

    ORIGINAL: ASHBERY76

    ETA on next beta.The autodesign isssue is pretty serious.


    i second this




    WiZz -> RE: Public Beta for Legends v1.7.0.15 now Available! (8/17/2012 6:56:21 PM)

    I think, it was the last patch...




    endoric -> RE: Public Beta for Legends v1.7.0.15 now Available! (8/18/2012 12:01:35 PM)

    wow that would put matrixgames on my 'never buy from game company list' that is sadly full of indy companies.




    Page: <<   < prev  1 [2] 3   next >   >>

    Valid CSS!




    Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
    3.295898E-02