Crash in version 1.03 beta 1 (Full Version)

All Forums >> [Current Games From Matrix.] >> [Ancients] >> Hannibal: Rome and Carthage in the Second Punic War >> Tech Support



Message


Thales99 -> Crash in version 1.03 beta 1 (2/20/2011 12:33:04 PM)

I played several games with the new beta version without problems, however in the course of the last one I experienced three crashes (with identical reports). Unfortunately I have no save game causing a reproducible crash yet, so I only attached one of the crash reports.




nalivayko -> RE: Crash in version 1.03 beta 1 (2/20/2011 2:21:17 PM)

Happened to me once as well. File included.




mercenarius -> RE: Crash in version 1.03 beta 1 (2/21/2011 3:13:52 AM)

Well, I am sorry for this glitch as well as for the delay in posting a response. (I was at a birthday party today). I see that this is the pesky "immortal Roman leader" bug. I had put a test in my development code for this but I couldn't duplicate the problem. Then I forgot to change it to a more benign form in the public beta.

Now that this has happened, I can see exactly what the problem is. This will be corrected in a second public beta that I will get out there as quickly as I can. I need to test it a little more and then I will have to consult with Andrew and Erik. They're the ones who prepare and release the final installer for you. I'll have to see what their schedule is.

Thanks for reporting this, and of course I am sorry for the inconvenience. As a work-around, you can turn off the "Verbose AI" (to avoid boredom) and then refrain from using the Escape Key (or the mouse, etc.) to shorten the AI's movements on the main map. It is only one specific stage that has a problem - when an army is moving by land and is subject to attrition. If that stage is "escaped" and the army didn't lose any units at all then this problem will occur.

Of course this work-around is only temporary. There is nothing wrong with shortening the AI's moves on the game map. Or, at least, there shouldn't be anything wrong with it. [:@]




nalivayko -> RE: Crash in version 1.03 beta 1 (2/21/2011 3:00:50 PM)

It happened only once and I have played at least ten games with the new beta. No worries. Good to hear that you've figured where the bug comes from right away.




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
1.660156E-02