My game is crashing for some reason. (Full Version)

All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support



Message


Sredni -> My game is crashing for some reason. (2/19/2011 9:22:28 PM)

Playing as allies vs AI under the latest non beta patch. The game has been chugging along fine up until now but each time I try to run through this latest turn the game crashes after doing all the turn stuff (it runs the turn and then crashes). I tried going back to the save from a day before and it still crashes on the next days turn completion. Before this incident I havn't had any crash issues during the previous 7 or 8 months of gameplay, but just lately there have been crashes during the turn sometimes when I click on the minimap to change my view location.

Here's the save in case someone would like to see.





hunchback77 -> RE: My game is crashing for some reason. (2/20/2011 8:44:40 PM)

Just ran your turn Sredni and it crashes just after the Aircraft Supply phase. Hopefully Michael M can fix it so you can continue your game. Had a similar crash in one of my AI games caused by a air unit that shouldn't have been there and Michael was able to fix it.




Sredni -> RE: My game is crashing for some reason. (2/20/2011 11:08:17 PM)

I tried going back to the 2nd (it crashes going from the 5th to the 6th) and just running the turns without changing anything and it made it to the 7th without crashing. So I figured something I did during those days was the cause.

So then I went and started over on the 2nd again playing normally and it crashed again after running the 5th. [:(]




michaelm75au -> RE: My game is crashing for some reason. (2/21/2011 8:52:53 AM)

I don't currently have the 1106i code available, but it seems to be showing up when drawing clouds.

Might I suggest you try turning off 'Show clouds' option and so iff that helps.
There seems to be some corruption in the file as it also crashed my most current build.




michaelm75au -> RE: My game is crashing for some reason. (2/21/2011 10:48:13 AM)

I have run a turn from your save and produced this save.

See if this save works.




Sredni -> RE: My game is crashing for some reason. (2/21/2011 2:13:29 PM)

It still crashes [:(]. I tested the save you posted without doing any turn changes and it crashes during turn completion, I tried with changes input (sent troops by rail, conducted an assault, gave movement orders, gave bombing orders, ect ect) and it still crashes. I also tried without clouds and still crashes.

When I tested going back to the 2nd and running through to the 5-6th turn without inputting any changes during the turns it made it all the way to the 7th without crashing. So I figured I just broke something by chance during those turns and restarted on the 2nd and redid them like normal (with a few changes, pilot upkeep, movement orders I'd missed the first time through, some new task forces created), but again it crashed going from 5th-6th.

Would it help to go back further? I've got saves going back 12 days, and while it would suck to redo them lol, it would be better then abandoning this game. The problem is I don't know what I'm doing that causes the crash (or if it was just an anomoly that my 2nd-7th test worked), and if I restart from the previous month I have to play the game and make changes and I don't know which of those changes might be the problem.

I've been wanting to restart lately, this game was just a practice run (which I cheated pretty heavily in [:-] ), but I wanted to run this out to at least the historical wars end and I'm so very close. I want to rescue my stalled invasion of iwo jima, I want to see if my chichi jima invasion fares any better (the amphib TF is just a few days away from the troops on guam), I'm so close to taking fusan and being ready to start bombing tokyo heh. I also wanted to wait for the latest beta patch to reach normal release status and start with it and a fresh game, and I've no clue how long that might be.




michaelm75au -> RE: My game is crashing for some reason. (2/22/2011 8:36:15 AM)

Yea. I think something has trashed or corrupted some location entries pointing to map locations.
It seems to be consistent as to which ones are being corrupted, but can't see why.
I am trying to work backwards to see what is being stored there on the hopes I can clear that out so it wont reuse it.




michaelm75au -> RE: My game is crashing for some reason. (2/22/2011 11:22:28 AM)

I tried to clear out the list first.
Can you try this new save?




Sredni -> RE: My game is crashing for some reason. (2/22/2011 12:43:21 PM)

Still crashing [:(]




michaelm75au -> RE: My game is crashing for some reason. (2/22/2011 1:51:33 PM)

Darn. The data corruption must be too great for 1106i to handle.

Why not down load the latest beta (1108j build 3). It will create a Beta2 directory where the new EXE resides.
And run the save using the Beta 2 shortcut and see if that corrects the problem.
That was the version I was using which seemed to be able to recover from the problem.




Sredni -> RE: My game is crashing for some reason. (2/23/2011 9:38:02 PM)

I ended up going back and replaying the saves I had saved, 12 days back, and it's now up to the 9th with no crashes. No clue what might have caused the crashing in the initial playthrough, I did pretty much the same things this playthrough, though I was a little more on the ball with my sub assignments this time around and I spent more time doing pilot maintenance, and the invasions and attacks I was conducting during those 12 days were all pushed ahead in timetable (I was just more organized and proactive is all). If it happens again I'll do the beta upgrade heh. [8D]




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.0234375