Distant Worlds has stopped working (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support



Message


Deto -> Distant Worlds has stopped working (2/12/2011 9:35:59 PM)

And not started at all. I was able to play distant worlds before quite a few months back, now I reinstalled, patched, got ROTS and so on. When I hit start from launcher or distantworlds exe file, the game crashes. Error is:

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: distantworlds.exe
Problem Signature 02: 1.5.0.0
Problem Signature 03: 4d07cec1
Problem Signature 04: System.Windows.Forms
Problem Signature 05: 2.0.0.0
Problem Signature 06: 4a275ebd
Problem Signature 07: 199c
Problem Signature 08: 2
Problem Signature 09: PSZQOADHX1U5ZAHBHOHGHLDGIY4QIXHX



I'm running Windows 7, 64bit. dotNet is installed along with directX. I have ATI FirePro V4800 if it means anything :)

edit: I have dotNet 4.0

edit2: Made sure I have .Net 3.5 + directx 9c. No difference :<




Data -> RE: Distant Worlds has stopped working (2/13/2011 6:53:32 AM)

I may be wrong here but could this be related to Windows signature mechanism? It can interffere with some programs, if you disable it does it still crash?




Deto -> RE: Distant Worlds has stopped working (2/13/2011 7:49:06 AM)

The driver signature one? If so, I'm not sure I wish to disable that :)

The annoyance that is UAC is disabled




Data -> RE: Distant Worlds has stopped working (2/13/2011 8:11:57 AM)

ya, I was refering to UAC as well....don't think driver signature will affect the game




Deto -> RE: Distant Worlds has stopped working (2/13/2011 3:13:10 PM)

dangit..

Tried without the Rots expansion. Now I'm getting a proper error:

[image]http://dl.dropbox.com/u/238567/dw/poop.jpg[/image]




Bingeling -> RE: Distant Worlds has stopped working (2/13/2011 3:20:34 PM)

I had a bumpy ride to get RotS up and running, instant crashes when I tried to launch the games.

What worked was to uninstall everything in a proper manner, install vanilla Distant Worlds from scratch, and install RotS on top of that. Afterwards I did the 1.504 beta patch. Then it launched with no issues.




Deto -> RE: Distant Worlds has stopped working (2/13/2011 4:09:43 PM)

Uninstalled everything and checked regedit to clean up whatever was left behind (didn't see anything though). Installed vanilla Distant Worlds (the newest version), installed ROTS and beta patch... ...crash :<




Data -> RE: Distant Worlds has stopped working (2/13/2011 5:27:51 PM)

when you unistall also make sure to delete the folder the game creates in the documents and settings folder as well.....that one keeps the saves and some settings for the game




Deto -> RE: Distant Worlds has stopped working (2/13/2011 7:41:04 PM)

Uninstalled and checked, couldn't find anything under users folder. Reinstalled, but same error still continues.. Imo doesn't seem the problem is with the gpu, but I can't remember nor think of anything else that has changed since the last time I played (other than several new version releases to dw)




sbach2o -> RE: Distant Worlds has stopped working (2/14/2011 8:11:15 AM)

Maybe a stupid question (but the "Class not registered" in your exception got me wondering), but have you possibly no Windows Media Player installed?

Unfortunately it doesn't tell which class isn't registered.




Data -> RE: Distant Worlds has stopped working (2/14/2011 9:28:59 AM)

ooo, really hoping is not that classical one...or the other with the IE not installed




Deto -> RE: Distant Worlds has stopped working (2/14/2011 2:13:08 PM)

Kill me now... ...yeah no media player, no ie. Wasted them both when I installed win 7 and forgot all about it ... Thanks for the aid, and don't shoot me! :)




Data -> RE: Distant Worlds has stopped working (2/14/2011 2:21:57 PM)

don't worry Deto, some requests were made not to have the game depend so much on win media player and IE. Atm, it does so we have to make sure we have them.




Bingeling -> RE: Distant Worlds has stopped working (2/14/2011 3:48:29 PM)

If they are required, the game should notice them not present, and spit out a good error window of the friendly kind.




Empleyfire -> RE: Distant Worlds has stopped working (7/16/2011 2:36:08 AM)

i seem to be haveing the same problem...
I got IE 8 and Media player 12 installed whould this have any thing to do whit it?




Kayoz -> RE: Distant Worlds has stopped working (7/16/2011 4:16:35 AM)

Depending on how ambitious you are - you should be able to sort out what's missing by watching RegMon from www.sysinternals.com - that should tell you what it's trying to access, and as such what's going bang.




Empleyfire -> RE: Distant Worlds has stopped working (7/16/2011 8:40:13 PM)

I could not find any app by the name of reg mon. but i downloaded the thing any way...
gona see what its about. got any tips let meg know.




Data -> RE: Distant Worlds has stopped working (7/16/2011 9:16:47 PM)

Process monitor and process explorer from sysinternals are good all around tools, you can even monitor the process call stack up to the point of failure.
As a blind test and if you are willing, you could also try with earlier versions for IE and WMP. I for example have also IE8 but WMP10, maybe 12 is too new for it?




tjhkkr -> RE: Distant Worlds has stopped working (7/18/2011 5:44:23 AM)

Seriously, those saved games are not easy to find... are you sure you nuked them...
I do not have the game in front of me, so I cannot locate the directory structure to point you to.




Data -> RE: Distant Worlds has stopped working (7/18/2011 8:33:46 AM)

You only need to save / load a game to allow the game to open your current location.




Xanvast -> RE: Distant Worlds has stopped working (8/23/2011 12:03:25 AM)

Hi everyone,
I am glad I found this post as I also had crash on launch, I could not make it to the game.
This is the first time I meet a game that requires Internet Explorer and Windows Media Player to run properly.
I am a kind of enthousiast user and I had these two features disabled because I didn't need them.
This is quite annoying but it's ok. I would have never thought that it could be for this reason.
It would be good to specify clearly somewhere that those two softs are required, maybe during installation or to pop up a
warning message if they are not installed.
Anyway thank you !




Data -> RE: Distant Worlds has stopped working (8/23/2011 6:30:15 AM)

You're welcome, Xanvast, and welcome to the forum.
Have fun




Runesil -> RE: Distant Worlds has stopped working (10/27/2011 5:21:39 AM)

Well, this makes more sense. A few months back I was chasing a startup crash that I couldn't resolve.
Turns out I always turn off WMP ... so that's likely the problem. Wish I'd known about this then!

-Rune-




Data -> RE: Distant Worlds has stopped working (10/27/2011 8:00:17 AM)

The many uses of hindsight [:)]




DMan777 -> RE: Distant Worlds has stopped working (11/6/2011 11:36:41 PM)

Ever since installing Win 7, my re-install of DW has been flaky starting.  So much that I've not played it in several months.  So I'm going to try to fix this with a re-install and I want to verify a couple of things.

First, are the patches cumulative?  By that I mean is it only necessary to keep the latest patch for DW and the latest for RotS, or do I need to keep the intermediate patches too?

Second, what is the proper installation order?  When I install DW, do I patch it first and then install RotS, or do I install RotS and then patch?  Or does the latest patch of RotS take care of all the updates.

Here are all of the files I have, what are the necessary files and their installation order.  Thanks for any advice you may be able to provide.

DistantWorlds-SetupRelease-DR-v102.exe
DistantWorlds-Update-v1060.exe
DistantWorlds-ReturnoftheShakturi-SetupRelease-PL-v15.exe
DistantWorlds-ReturnoftheShakturi-Update-v1501.exe
DistantWorlds-ReturnoftheShakturi-Update-v1508.exe




Data -> RE: Distant Worlds has stopped working (11/7/2011 8:01:32 AM)

Yes, the patches are cumulative so you need only the latest one. The same applies for your install order...install DW, ROTS and latest ROTS patch (1.5.0.8)
Fingers crossed [;)]




DMan777 -> RE: Distant Worlds has stopped working (11/8/2011 12:15:59 AM)

Thanks, Data.  I re-installed and everything seems kosher now, save for the irritating security popup.  That's trivial though.




Data -> RE: Distant Worlds has stopped working (11/8/2011 8:20:09 AM)

Glad to hear you're mostly operational, have fun [:)]




Data -> RE: Distant Worlds has stopped working (11/8/2011 8:21:35 AM)

deleted, accidental double post




Titanwarrior89 -> RE: Distant Worlds has stopped working (11/24/2011 5:12:26 PM)

Ive tried everything mentioned in this thread and still can't get it to working. Was working great....I have no Ideal what the problem is....I did a clean uninstall(including the document/setting files)-I have windows media and IE installed. I reinstalled DW-RotS and patch 1508 in that order.[&:]

I want to buy the new add on but afraid that it won't work also. Any answers guys?[&o]
quote:

ORIGINAL: Data

Yes, the patches are cumulative so you need only the latest one. The same applies for your install order...install DW, ROTS and latest ROTS patch (1.5.0.8)
Fingers crossed [;)]





Page: [1] 2   next >   >>

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.0234375