Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[WAD] Event trigger-regular time 6 hours and over not working

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [WAD] Event trigger-regular time 6 hours and over not working Page: [1]
Login
Message << Older Topic   Newer Topic >>
[WAD] Event trigger-regular time 6 hours and over not w... - 7/3/2021 5:07:51 PM   
tiag

 

Posts: 82
Joined: 6/21/2018
Status: offline
More one bug.

As the topic says:

All event triggers with regular time with 6, 12 and 24 hours are not firing. Regular times with 1 hour and below are working.



< Message edited by WSBot -- 7/8/2021 4:07:57 PM >
Post #: 1
RE: Event trigger-regular time 6 hours and over not wor... - 7/3/2021 5:33:04 PM   
thewood1

 

Posts: 6238
Joined: 11/27/2005
Status: online
Is this with the latest version?

_____________________________

You are like puss filled boil on nice of ass of bikini model. You are nasty to everybody but then try to sweeten things up with a nice post somewhere else. That's nice but you're still a boil on a beautiful thing! - BDukes

(in reply to tiag)
Post #: 2
RE: Event trigger-regular time 6 hours and over not wor... - 7/3/2021 5:43:21 PM   
tiag

 

Posts: 82
Joined: 6/21/2018
Status: offline
1.03.114725

(in reply to thewood1)
Post #: 3
RE: Event trigger-regular time 6 hours and over not wor... - 7/4/2021 12:58:38 AM   
michaelm75au


Posts: 13389
Joined: 5/5/2001
From: Melbourne, Australia
Status: offline
Can supply a sample scenario where it is failing again?
I can see the 6,12,24 hour triggers firing.

< Message edited by michaelm75au -- 7/4/2021 1:49:34 AM >


_____________________________

Michael

(in reply to tiag)
Post #: 4
RE: Event trigger-regular time 6 hours and over not wor... - 7/4/2021 12:03:06 PM   
tiag

 

Posts: 82
Joined: 6/21/2018
Status: offline
With 1 hour trigger (firing):
https://drive.google.com/file/d/18VgReEK6v1usbglngFkekDxLyD4NcPVz/view?usp=sharing

With 6 hours trigger (not firing):
https://drive.google.com/file/d/10PrsYF1oCTiC7z_nFRCnr43Wtw7einq1/view?usp=sharing


(in reply to michaelm75au)
Post #: 5
RE: Event trigger-regular time 6 hours and over not wor... - 7/4/2021 5:13:28 PM   
KnightHawk75

 

Posts: 1244
Joined: 11/15/2018
Status: offline
I couldn't repo it either, both samples ran fine for me triggering at the 1 hour and 6hour intervals under build 1147.25 under eng-us local as expected. Additionally the units were removed, the time reset, and the units and group recreated as it appeared desired. What Windows local\culture setting do you play under?

Attached is a version of the 1hr with logging (and other minor enhancements), tiag not only should you see the mygroupX iteration every hour you should see the step by step process in the lua log on load and every hour, or should something error you should see a better idea of where\why.

attachment: Template Scenario 1Hour-logging.zip


Attachment (1)

(in reply to tiag)
Post #: 6
RE: Event trigger-regular time 6 hours and over not wor... - 7/4/2021 5:48:17 PM   
tiag

 

Posts: 82
Joined: 6/21/2018
Status: offline
Behavior observed is correct.
I cant make 6 hours (or longer) work here.

Running german windows pro 10 (21H1), german settings (decimal places, etc.). Do you think it is worth to try change these settings?

(in reply to KnightHawk75)
Post #: 7
RE: Event trigger-regular time 6 hours and over not wor... - 7/4/2021 6:49:39 PM   
tiag

 

Posts: 82
Joined: 6/21/2018
Status: offline
I had logging in my original version, which I removed because I thought I was doing something wrong (spend 3 hours yesterday trying to figure out what was wrong). The sleep() function was also for debugging.

As suggested:
1) Tried to change settings to US, english, reboot windows. Cant trigger 6 hours.
2) Reinstalled CMO, cant trigger 6 hours in your version of the scenario either. Lua output does not give any error in any version, your or mine. It simply does not fire (thus, no logging, no error) the trigger after 6 hours.
3) With one hour trigger, it (yours and mine) works as a charm (with same code etc).

Made an empty scenario, it suprisingly triggers 6 hours!!! (<-should have tried that first).
It is probably scenario related (interesting for you guys to investigate why). But cant understand why for 6 hours does not work and for one hour it does. Any further ideas/tests?
Should I make a video for you?

< Message edited by tiag -- 7/4/2021 6:50:56 PM >

(in reply to tiag)
Post #: 8
RE: Event trigger-regular time 6 hours and over not wor... - 7/4/2021 9:57:05 PM   
KnightHawk75

 

Posts: 1244
Joined: 11/15/2018
Status: offline
Run mine (just change 1hr to 6 ..or use attached) on your system, bet it works.

In your specific 6hr copy, 'start time' is in 2022, and your current time (and reset time) is before that which is why it will not fire. In the editor set "scene start time" to 1-1-2021 00:00:00, leave your reset time untouched at "1-1-2021 00:00:01". Time Triggers will not fire before a scene's start-time.




Attachment (1)

< Message edited by KnightHawk75 -- 7/4/2021 9:58:20 PM >

(in reply to tiag)
Post #: 9
RE: Event trigger-regular time 6 hours and over not wor... - 7/7/2021 7:12:27 PM   
tiag

 

Posts: 82
Joined: 6/21/2018
Status: offline
Good evening:

1) Your version of the scenario did not run on my machine properly. The heading of the created ships were showing a very large value when the group was created....something like 7-8 digits. I guess it has to do with decimal points etc.

2) I run my scenario and corrected the start hour/day accordingly and the 6 hours trigger run as you have antecipated.

FYI: What got me confused was that the one hour trigger fires independently if the scenario started or not.

Anyway, problem solved. Thank you very much.

(in reply to KnightHawk75)
Post #: 10
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [WAD] Event trigger-regular time 6 hours and over not working Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.439