Matrix Games Forums

New Fronts are opening up for Commander: The Great WarCharacters of World War 1Sign of for the Pike and Shot Beta!More Games are Coming to Steam! Deal of the Week: Combat Command Return to the Moon on October 31st! Commander: The Great War iPad Wallpapers Generals of the Great WarDeal of the Week Panzer CorpsNew Strategy Titles Join the Family
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Problems with ATI Catalyst Drivers

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [Discontinued Games] >> I of the Enemy >> I of the Enemy Support >> Problems with ATI Catalyst Drivers Page: [1]
Login
Message << Older Topic   Newer Topic >>
Problems with ATI Catalyst Drivers - 9/3/2005 7:53:04 PM   
mtemple

 

Posts: 34
Joined: 3/22/2005
Status: offline
This is an extension of another thread. It has been determined that as of the 5.7 version, the ATI Catalyst drivers are incompatible with IOE as they will cause artifacting on the screen whenever the mouse moves. I have also noted garbage slowly building up on the screen whenever I use the Netscape Navigator 7.1 web browser.

The Omega drivers, which appear to be based on the Catalyst drivers, exhibit the exact same problems and do not appear to be a viable solution.

At the moment, the only thing that has worked is to revert back to the drivers that came on the CD with the graphics card. These will eliminate all problems I have observed with the game and Netscape.

I am currently getting signed up as a developer with ATI to see if I can get the problems with the Catalyst drivers worked out. I'll keep you posted as to the progress on this front.

In the mean time, please let me know if reverting to the CD drivers has or has not worked for anyone, as this will tell me how much of an emergency it is to get the Catalyst drivers sorted out with ATI.

Sorry for the inconvenience!

_____________________________

Mark Temple
Enemy Technology
"We have found the enemy, and he is us!"
Post #: 1
RE: Problems with ATI Catalyst Drivers - 9/5/2005 11:25:52 AM   
Zap


Posts: 1594
Joined: 12/6/2004
From: LAS VEGAS TAKE A CHANCE
Status: online
Thank you for your search for a problem resolution. I have ATI updated drivers. Will reverting back to older drivers not cause problems with other programs I run that use the updated drivers?

(in reply to mtemple)
Post #: 2
RE: Problems with ATI Catalyst Drivers - 9/5/2005 10:59:50 PM   
mtemple

 

Posts: 34
Joined: 3/22/2005
Status: offline
I have been using the old drivers for quite awhile and only updated to the Catalyst drivers recently. I have not noticed any degradation in performance with the old drivers and have noticed other improvements with them (most notably the clearing up of the artifacting in Netscape).

However, it might seem odd to some of you that, as a game developer, I haven't had much time recently to actually PLAY many games and thus, I may not be a good measure of whether anything is lost by removing the Catalyst drivers. I'm hoping some of you might let me know if you notice anything lost with the Catalyst drivers removed.

Lastly, I noticed an alarming number of issues with the Catalyst drivers when looking through the FAQ for games on the ATI web site. I'm not sure if this is commonplace, or if it reflects a problem with the drivers or with game developers, but right now I feel better to not have the Catalyst drivers loaded.

Again, I would appreciate it if people would let me know if they notice anything negative when reverting back. It will certainly help me with finding a permanent solution to this issue!

_____________________________

Mark Temple
Enemy Technology
"We have found the enemy, and he is us!"

(in reply to mtemple)
Post #: 3
RE: Problems with ATI Catalyst Drivers - 7/24/2006 1:27:19 PM   
lw_enes

 

Posts: 4
Joined: 7/24/2006
Status: offline
I was pretty sure, that the "mouse moving artifact" effect is not an ATI Catalyst related problem, so I started trying yesterday... I checked for latest version of all DLL files. When I had been arrived the Scitech SNAP graphics driver (graphics.bpd) with 2003/11/12 date it became the most suspicious part of the game. So I concentrate to it. ( google )

It is interesting, that the SNAP driver version r14 was worked with IOE (r14 is also buggy), but IOE refused to cooperate with up-to-date official r19 and beta r22 version driver!

However I did not give up, and tried an unknown version, from this site: http://unununium.org/darcs/scitech-snap/drivers/
graphics.vbe = graphics.bpd AND IT WORKS!

With my ATI 9600 card there were no more artifacts after I copied this SNAP driver to game drivers directory. Finally I solved the problem in 2 days without any reverse engineering or programming. :)

Perheps it is time to patch this game?

(in reply to mtemple)
Post #: 4
RE: Problems with ATI Catalyst Drivers - 7/25/2006 3:11:25 AM   
mtemple

 

Posts: 34
Joined: 3/22/2005
Status: offline
Thanks for the report on this! I think it is a great thing to know and I encourage anyone who is still having the problem to try the VBE driver. However, I do not think it a good idea to release the VBE driver as a patch since removing the catalyst drivers solved the problem for us. Because a very small percentage of users have reported this problem, I would be worried about releasing the VBE for fear of causing problems for users of other cards, especially since we have not had time to do extensive testing on this driver.

Actually, my biggest fear at the moment would be to cause a storm of support issues which might take us away from work on IIOE. But I really appreciate the time it took to track this down and I hope it helps other with the same card!

_____________________________

Mark Temple
Enemy Technology
"We have found the enemy, and he is us!"

(in reply to lw_enes)
Post #: 5
RE: Problems with ATI Catalyst Drivers - 7/25/2006 11:53:08 AM   
lw_enes

 

Posts: 4
Joined: 7/24/2006
Status: offline
I am afraid, that downgrading drivers is not the best solution, this is why i started to search another way. ATI is maintaining only Catalyst drivers for a while which is optimised for a bunch of games... anyway i hope that this solution help for others also.

I understand that the new game has priority however a separeted ati-patch compressed file at the download page will be enough.
As you wish...

(in reply to mtemple)
Post #: 6
Page:   [1]
All Forums >> [Current Games From Matrix.] >> [Discontinued Games] >> I of the Enemy >> I of the Enemy Support >> Problems with ATI Catalyst Drivers Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.070