Matrix Games Forums

New screenshots for War in the West!Pike & Shot is now available!Server Maintenance Battle Academy 2 gets updated!Deal of the Week: Advanced Tactics Gold Ask Buzz Aldrin!Pike & Shot gets Release Date and Twitch Session!Deal of the Week Espana 1936War in the West coming in December!Space Program Manager will be launching on Steam
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: SPWaW Technical Issues

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [World War II] >> Steel Panthers World At War & Mega Campaigns >> RE: SPWaW Technical Issues Page: <<   < prev  2 3 4 5 [6]
Login
Message << Older Topic   Newer Topic >>
RE: SPWaW Technical Issues - 12/20/2009 8:07:49 PM   
farn

 

Posts: 1
Joined: 12/20/2009
Status: offline
Hello,

I just bought the generals edition, because I loved the original Steel Panthers. Now I´m totally pissed off. I´m trying to run the game on a laptop with ATI 1100 Xpress and 2 GB Mem. I think I´ve managed to solve the problem with the crashing graphics (wierd colours etc.) by forcing the games into XP mode etc. What makes the game totally unplayable is the fact, that the program only seems to register every 10-50 mouseclicks in the artillery window. No artillery = no chance of winning any battles, so thats a great investment of €40,-. Grrrr... Does anyone know how I can resolve this problem ? Thanks

(in reply to planner 3)
Post #: 151
RE: SPWaW Technical Issues - 12/20/2009 10:42:12 PM   
wesy


Posts: 170
Joined: 2/10/2002
From: Oakland (The Town)
Status: offline
I'm not sure if this will solve your problem, but this fixed the issue of weird colors etc. on my Lenovo T61 laptop with 4gb of ram running W7 x64.

I'm running the mech.exe with the following settings








Attachment (1)

(in reply to farn)
Post #: 152
RE: SPWaW Technical Issues - 12/20/2009 10:50:39 PM   
planner 3

 

Posts: 618
Joined: 3/7/2008
Status: offline
Have you tried shutting down excess background running apps ? I'm not familiar with your set up but this is one possibility. Next go to Save file, in game folder, and deleted the steel.exe file. Don't worry game generates new one on start up. This old girl (SPwaw) is veritable memory hog, she looks for and takes all she can find, I don't know how big a battle your trying to do but there are limits to the numbers of troops, units etc. you can deploy.
Also you might have to locate a feature that can slow down your CPU. This game is close or older than 10 years and you know how children can be ???? hehehe  Good Luck and don't get discouraged, post problems and someone will try to help. Also you may try for info at "SPwaw.com/php/BB2/Index.php?" There is a large community of SPwaw fans there and you can get loads of assistance. Tell them the "Chief" sent you.

_____________________________

"As Pogo said, 'We have met the enemy and he is us' "

(in reply to farn)
Post #: 153
RE: SPWaW Technical Issues - 12/20/2009 11:15:46 PM   
junk2drive


Posts: 12901
Joined: 6/27/2002
From: Arizona West Coast
Status: offline
Sorry chief, the file is Steel.prf

(in reply to planner 3)
Post #: 154
RE: SPWaW Technical Issues - 12/21/2009 4:52:49 AM   
planner 3

 

Posts: 618
Joined: 3/7/2008
Status: offline
J2D: ey at my age what u expect, we sometimes get forge................oh hell where was i ?

_____________________________

"As Pogo said, 'We have met the enemy and he is us' "

(in reply to junk2drive)
Post #: 155
RE: SPWaW Technical Issues - 3/6/2010 2:39:14 PM   
aliso

 

Posts: 1
Joined: 3/6/2010
Status: offline
Hi guys,
I've recently solved that artillery-multiple-click problem which annoyed me for a long time.

By me the problem lie in a CPU allocation. I run it on a machine with a dual-core processor and the game uses by default only the first core, thus fighting directly for the CPU usage with my well-beloved Win XP and who knows what else as well.

So I run the game, then alt-tab back to desktop, run my process explorer ( I guess that basic Task manager should work as well), right-click on the "mech.exe" process, select "set affinity", uncheck the "CPU 0" and check the "CPU 1" option, then alt-tab back to the game and the artillery runs smoothly and without delays (hurray !!!).

Hope this helps, now I can be only angry with myself, that I didn't realize this before, since it is a common problem with a lot of games :-)

(in reply to planner 3)
Post #: 156
RE: SPWaW Technical Issues - 4/29/2010 2:10:11 PM   
NCrawler

 

Posts: 30
Joined: 6/4/2003
From: Sherwood, AR
Status: offline
So, is the game source still being modified? I ask because I have found the authors website of the graphics library used in the SP series and he has released the library as open source/freeware. If someone were still working on the source and originally had trouble compiling the WinVFX graphics library (like the Camo Group did years ago) then the archive on the authors site should be a great help. It would be nice to have SPWAW running at higher resolutions on todays hardware...



NC

(in reply to KG Erwin)
Post #: 157
RE: SPWaW Technical Issues - 4/29/2010 11:57:25 PM   
JEB Davis


Posts: 316
Joined: 12/27/2005
From: Michigan, U.T.B.
Status: offline

quote:

ORIGINAL: NCrawler
So, is the game source still being modified?

In a word... "No".
But there are several cool mods being developed at http://enhanced.freeforums.org

_____________________________

Reduce unrealistic SP:WaW slaughter, "Low Carnage" (v8.403 or Enhanced):
Settings: 90S,80H,100RR,XXXTQ,110TT,150IT,180AvS,130AvA,150SOF / Command & Ctrl ON / AutoRally OFF
Visit the Enhanced forum at http://enhanced.freeforums.org

(in reply to NCrawler)
Post #: 158
RE: SPWaW Technical Issues - 4/30/2010 6:16:49 PM   
lparkh


Posts: 325
Joined: 7/25/2004
Status: offline
I had the same artillery mouse click issue. The worksaround that I was advised to do and worked for me was to **slow down** my cpu. A good app for this is CPUKiller3

(in reply to JEB Davis)
Post #: 159
RE: SPWaW Technical Issues - 4/30/2010 6:19:53 PM   
lparkh


Posts: 325
Joined: 7/25/2004
Status: offline
I know this places me amongst the great unwashed.. but I would encourage further development to be increasing resolution rather then gameplay. While this may be irrelevant to current grognards playing the game it might broaden the audience again so that your efforts would be more appreciated.
I've played wargames for 30+ years now and I confess I also get turned away a bit by the current pixelation on a modern machine. The shrapnel version on the other hand at higher res is stupidly appealing. It seems like more effort on gameplay has been expended on SPWAW so my ideal world (and perhaps other new players) would be SPWAW with higher resolution (which makes the graphics automatically seem sharper too).
But then I am now amongst the great unwashed so I will assume I should be discounted ;-)

(in reply to lparkh)
Post #: 160
RE: SPWaW Technical Issues - 4/30/2010 11:08:53 PM   
JEB Davis


Posts: 316
Joined: 12/27/2005
From: Michigan, U.T.B.
Status: offline
We would all love a higher resolution upgrade for SPWAW, of course.
It's just that after you've been around a few years you will realize
that there will never be any further game code releases.
Matrix flat out doesn't want or can't do it.

Go buy a cheap used CRT monitor and you won't have the pixellation
problems you get with a "modern, improved technology" LCD screen.
(Why do we have to put up with new technology that is inferior?)

_____________________________

Reduce unrealistic SP:WaW slaughter, "Low Carnage" (v8.403 or Enhanced):
Settings: 90S,80H,100RR,XXXTQ,110TT,150IT,180AvS,130AvA,150SOF / Command & Ctrl ON / AutoRally OFF
Visit the Enhanced forum at http://enhanced.freeforums.org

(in reply to lparkh)
Post #: 161
RE: SPWaW Technical Issues - 1/7/2011 8:05:46 PM   
kriegspieler7

 

Posts: 2
Joined: 1/7/2011
Status: offline
Greetings!

I've jjust downloaded the latest versions of SPWaW (8.2-8.403) and when I try to play the game, the image is off to the lower right on the screen and I can only see the upper left corner of the menu.

Is that a common problem or what? Do I just have to update my drivers or something else? Is there a forum site I can go to?

I really didn't want to have to ask for help this way, but I didn't know how else to do it.

Talk about , "leaning on the kindness of strangers. Sheeeeeesh!"

Thanks for anybody who's able to help.

(in reply to KG Erwin)
Post #: 162
RE: SPWaW Technical Issues - 1/7/2011 11:45:09 PM   
JEB Davis


Posts: 316
Joined: 12/27/2005
From: Michigan, U.T.B.
Status: offline
You'll find a good group of helpful folks at http://www.spwaw.com/phpBB2/
and more at the link in my sig.

_____________________________

Reduce unrealistic SP:WaW slaughter, "Low Carnage" (v8.403 or Enhanced):
Settings: 90S,80H,100RR,XXXTQ,110TT,150IT,180AvS,130AvA,150SOF / Command & Ctrl ON / AutoRally OFF
Visit the Enhanced forum at http://enhanced.freeforums.org

(in reply to kriegspieler7)
Post #: 163
RE: SPWaW Technical Issues - 1/8/2011 4:01:50 AM   
kriegspieler7

 

Posts: 2
Joined: 1/7/2011
Status: offline
Thanks for the input. I've sent an inquiry to that site.

kriegspieler7

(in reply to JEB Davis)
Post #: 164
RE: SPWaW Technical Issues - 1/10/2011 1:47:02 AM   
heinrich55

 

Posts: 353
Joined: 5/31/2004
Status: offline
Guys,
My XP computer crashed, and I now have a Win 7 computer. I did the file download noted above and that cured my colors and operation. I was able to get back into the menu for the game. Thanks a bunch for that!
Is there any way to slow down the mouse? My mouse now scrolls at top speed, making play very frustrating. Any suggestions are welcome.

Heinrich55

(in reply to kriegspieler7)
Post #: 165
RE: SPWaW Technical Issues - 1/10/2011 1:57:10 AM   
junk2drive


Posts: 12901
Joined: 6/27/2002
From: Arizona West Coast
Status: offline
Did you look in the preference screen?

_____________________________

Conflict of Heroes "Most games are like checkers or chess and some have dice and cards involved too. This game plays like checkers but you think like chess and the dice and cards can change everything in real time."

(in reply to heinrich55)
Post #: 166
RE: SPWaW Technical Issues - 1/10/2011 2:06:34 AM   
heinrich55

 

Posts: 353
Joined: 5/31/2004
Status: offline
J2D,
I did look there, but didn't see anything that seemed to adjust the mouse speed. Perhaps I didn't notice something there.

Heinrich55

(in reply to junk2drive)
Post #: 167
RE: SPWaW Technical Issues - 1/10/2011 2:09:53 AM   
heinrich55

 

Posts: 353
Joined: 5/31/2004
Status: offline
Just went back and checked, but didn't see anything that appeared to adjust the mouse speed.


Heinrich55

(in reply to heinrich55)
Post #: 168
RE: SPWaW Technical Issues - 1/10/2011 2:10:52 AM   
junk2drive


Posts: 12901
Joined: 6/27/2002
From: Arizona West Coast
Status: offline
There should be one for scroll speed. Try that.

_____________________________

Conflict of Heroes "Most games are like checkers or chess and some have dice and cards involved too. This game plays like checkers but you think like chess and the dice and cards can change everything in real time."

(in reply to heinrich55)
Post #: 169
RE: SPWaW Technical Issues - 1/10/2011 2:16:16 AM   
heinrich55

 

Posts: 353
Joined: 5/31/2004
Status: offline
J2D,
Yep, I must be losing it with old age. I saw another post under a different thread, so I went back. There is an adjustment for scrolling speed, just like you said. Thanks for being patient with me,

I'm good now. Scroll speed 3 seems to be okay.

Heinrich55

(in reply to junk2drive)
Post #: 170
RE: SPWaW Technical Issues - 3/2/2011 10:08:50 PM   
Shawmut


Posts: 83
Joined: 2/29/2004
From: Boston, MA USA
Status: offline
I have just tried to install my SPWWIIGE on my PC (W/Windows 7).  It is all colored as though in "neon" shades and nearly illegible.
This had occurred previously when I tried to install it with "Vista" and just gave up on there being any resolution to the problem.
It had functioned fine on "XP".
Please advise.
Thank you.

(in reply to Tyrson)
Post #: 171
RE: SPWaW Technical Issues - 3/2/2011 10:12:58 PM   
Shawmut


Posts: 83
Joined: 2/29/2004
From: Boston, MA USA
Status: offline
Just today I tried to download my SPWWIIGE and came across the same issue - "neon" type colors. It had worked on XP when I had that, but gor the same issue as today when I went to "VISTA". Colors so blurred that the game was unusable.

(in reply to farn)
Post #: 172
RE: SPWaW Technical Issues - 3/3/2011 6:37:29 PM   
Alby


Posts: 4790
Joined: 4/29/2000
From: Whiteland, Indiana
Status: offline

quote:

ORIGINAL: Shawmut

Just today I tried to download my SPWWIIGE and came across the same issue - "neon" type colors. It had worked on XP when I had that, but gor the same issue as today when I went to "VISTA". Colors so blurred that the game was unusable.


http://enhanced.freeforums.org/windows-7-direcx-11-display-erratic-colors-t579.html

_____________________________




(in reply to Shawmut)
Post #: 173
RE: SPWaW Technical Issues - 1/16/2012 8:12:24 PM   
Speedy

 

Posts: 14372
Joined: 9/11/2001
From: Reading, England
Status: offline
Grrr. Fired up this great game again (SPwaWGE) on my laptop which is Windows 7 and I get these funny colours making the game unplayable. Tried some of the things here like right clicking on mech.exe and changing it to 256 colours etc but no joy. Any advice?

Thanks




Attachment (1)

< Message edited by Speedy -- 1/16/2012 8:26:57 PM >


_____________________________

WitE Tester
BTR/BoB Tester

(in reply to Alby)
Post #: 174
RE: SPWaW Technical Issues - 1/16/2012 9:35:21 PM   
Rosollia

 

Posts: 19
Joined: 1/12/2012
Status: offline
To fix the colors on Windows7 currently you have 4 options:

1. Use NCrawlers fix.
http://enhanced.freeforums.org/download/file.php?id=1037
(It needs to be unzipped to your game folder and started from win7spwaw.cmd)

2. Use D3DWindower.
http://www.matrixgames.com/forums/tm.asp?m=2162408

3. Use direct draw compatibility tool.
http://www.matrixgames.com/forums/tm.asp?m=2452605

4. Wait for NCraweler to release his new dll fix. Or PM him about it.


You may also notice your artillery screen being unresponsive. For that there are 2 options:

1. Try pressing the shift key everytime before clicking on your mouse in the artillery screen.

2. If you have a multicore cpu the affinity fix may help.


(in reply to Speedy)
Post #: 175
RE: SPWaW Technical Issues - 1/16/2012 9:59:12 PM   
Rosollia

 

Posts: 19
Joined: 1/12/2012
Status: offline
Just to add the color fix options 1-3 that I posted above all have their shortcomings.

option 1 has the problem that while it fixes the color immediately it works by closing windows explorer. This means you can not multitask and may not be able to adjust sound volume. Explorer may not start again and you have to reboot your PC.
option 2 makes the game run in a window and if your computer is not fast enough there may be slowdowns. The window may also be too small.
option 3 is the method I am currently using, but the colors are not right until you click on solitaire play and go to the editor screen.

You just need to find out which method works best for your computer.

(in reply to Rosollia)
Post #: 176
RE: SPWaW Technical Issues - 1/17/2012 7:02:29 AM   
Speedy

 

Posts: 14372
Joined: 9/11/2001
From: Reading, England
Status: offline
Thanks a lot. Employed method 3 and all good

_____________________________

WitE Tester
BTR/BoB Tester

(in reply to Rosollia)
Post #: 177
RE: SPWaW Technical Issues - 1/3/2013 2:42:54 PM   
soeren01

 

Posts: 296
Joined: 6/25/2004
From: Bayern
Status: offline
There is another possibility.
Get VMware or Virtualbox and install an virtual XP system on which you run SPWAW.
The only drawback I have is you need to set the hosts screen resolution to 800x600 to be able to use the whole screen.

< Message edited by soeren01 -- 1/3/2013 2:43:01 PM >


_____________________________

soeren01, formerly known as Soeren
CoG FoF
PacWar WIR BoB BTR UV WITP WITE

(in reply to Speedy)
Post #: 178
RE: SPWaW Technical Issues - 1/3/2013 4:52:02 PM   
planner 3

 

Posts: 618
Joined: 3/7/2008
Status: offline
I must be leading a charmed life, I have 2 machines, 1 XP home edit., 1 Win7 Pro edition, carrying 4 versions of Spwaw on both machines and no problems playing scenarios or camps. No fancy video boards either.

PS: for Gunny (KW), it worked good in Falling Waters, WV also.

I ran across a possible help on another game and I'm trying it out. Go to shortcut for game, right click; on  properties, on target line, after .exe, add space/nocache, (space is really space bar, don't spell it.) This is supposed to keep from limiting the cache file or (IT Nerds may add here !). Hey FWIW, like I said they're both working fine. 

Der Chief

_____________________________

"As Pogo said, 'We have met the enemy and he is us' "

(in reply to Tyrson)
Post #: 179
RE: SPWaW Technical Issues - 1/26/2014 8:24:38 PM   
dlazov66


Posts: 2513
Joined: 2/23/2009
From: United States
Status: offline
SP:WaW does not work on Windows 7, any fix?

It actually starts up, but the graphics are fried (you get the magenta crap painting to the screen).

Looks like the old compatibility stuff does not work when you try to set it with W7 either.



_____________________________


War in the East/War in the West - Alpha Test Team

(in reply to planner 3)
Post #: 180
Page:   <<   < prev  2 3 4 5 [6]
All Forums >> [Current Games From Matrix.] >> [World War II] >> Steel Panthers World At War & Mega Campaigns >> RE: SPWaW Technical Issues Page: <<   < prev  2 3 4 5 [6]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.114