Matrix Games Forums

Space Program Manager Launch Contest Announced!Battle Academy 2 is out now on iPad!A closer look at rockets in Space Program ManagerDeal of the Week - Pride of NationsA new update for Piercing Fortress EuropaNew screenshots for War in the West!Pike & Shot is now available!Server Maintenance Battle Academy 2 gets updated!Deal of the Week: Advanced Tactics Gold
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Inconsistent combat replay

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [World War II] >> Uncommon Valor - Campaign for the South Pacific >> Tech Support >> Inconsistent combat replay Page: [1]
Login
Message << Older Topic   Newer Topic >>
Inconsistent combat replay - 2/12/2005 4:22:13 AM   
CatLord


Posts: 312
Joined: 10/21/2002
From: Lausanne, Switzerland
Status: offline
The same combat replay (001) file send to me by my PBEM opponent gives me different Combat Replay & Report.

I have posted my problem several time in the WitP forum, because:
1 - The same problem exist in WitP
2 - Nobody ever read here anymore...

Cat

_____________________________

Member of the Revolution Under Siege development team.
Post #: 1
RE: Inconsistent combat replay - 2/12/2005 5:13:33 AM   
spence

 

Posts: 3932
Joined: 4/20/2003
From: vermont
Status: offline
I've noticed the same thing - combat report and combat replay differing. The combat report is the more accurate (I think). I've had a replay tell me I recaptured Luganville when in fact I had not. I've also had a replay tell me I did not capture a base, then discovered that I had captured it when it was time to make my move. My opponent did send the combat report in the former case and that indicated that I had not captured the base as indicated by the combat replay. In the latter case my opponent did not send the combat report. Both instances were in the same game.
In a different game, a large multi-turn carrier battle the combat replays showed my SBDs bombing the beejeezum out of the Kaga and not even attacking the Akagi (which was in the TF). The combat report showed hits on both Kaga and Akagi in that TF. Since both sank due to damage caused by 1000 lb bombs obviously the combat report is more close to reality. I think FOW is present in both the combat replay and the combat report but that the latter is less subject to it.

(in reply to CatLord)
Post #: 2
RE: Inconsistent combat replay - 2/12/2005 2:58:27 PM   
toraq


Posts: 405
Joined: 10/24/2004
Status: offline
I think it is a bug. Sometimes, specially in carrier battles or big air raids against ships, combat replay is quite different from the combat report.
If you are japanese this should not happen (both will be more or less the same) but if you play the allies, this can happen from time to time .
Long time ago it was a bug that was fixed but it still happens anyway...
That´s why I always ask for the combat report when I play the allies

(in reply to spence)
Post #: 3
RE: Inconsistent combat replay - 2/12/2005 2:58:57 PM   
CatLord


Posts: 312
Joined: 10/21/2002
From: Lausanne, Switzerland
Status: offline
It's not a FOW problem, it's a bloody bug !

The report and the replay are the same up to a certain point, and then they diverge from what my opponents did see.

Air Attacks on TF which I can see and have generate a report for never occurs for him, same with submarine attack, same with LCU attack, etc...

Cat

_____________________________

Member of the Revolution Under Siege development team.

(in reply to spence)
Post #: 4
RE: Inconsistent combat replay - 2/12/2005 4:45:56 PM   
CatLord


Posts: 312
Joined: 10/21/2002
From: Lausanne, Switzerland
Status: offline
It seems it's the animations which are screwing up the Replay...

Cat

_____________________________

Member of the Revolution Under Siege development team.

(in reply to CatLord)
Post #: 5
RE: Inconsistent combat replay - 2/16/2005 8:49:59 PM   
AmiralLaurent

 

Posts: 3351
Joined: 3/11/2003
From: Near Paris, France
Status: offline
Hi,

I'm an UV veteran that came back here (from WITP world) just to see if there was some activity.

I had this problem also in PBEM. My own experience show two things :

_ replay discrepencies happen during turns with much air vs naval action, but also on quieter turns when planes (P-39s usually) strafe enemy ships. There is something in strafing that is sending the replay out of its usual path. Check the turns where you saw discrepencies and you will notice that 95% of the times first discrepency is during a strafing attack that would show different results. Problem is that then all results may be different (raids launched or not, sub attacks or not and so on).

_ discrepencies are reduced when the AI difficulty setting is the same for both PBEM players. I know it has nothing to do with PBEM but it has some influence on the replay. Change the AI setting between two readings of the replay and it will show different results most of the time.

If this setting is the same for both players all the time, discrepencies will be reduced to 1-3 times a game month (in active times) even with strafing actions. At least that was the rate during my final times in UV last summer. And all my games were well in 1943 with P-39 strafing barges almost every day.

(in reply to CatLord)
Post #: 6
RE: Inconsistent combat replay - 2/18/2005 6:13:54 AM   
CatLord


Posts: 312
Joined: 10/21/2002
From: Lausanne, Switzerland
Status: offline
Ha, thanks.

I actually have some B-25D which I want to skip bomb on the target and are straffing instead...

Cat

_____________________________

Member of the Revolution Under Siege development team.

(in reply to AmiralLaurent)
Post #: 7
RE: Inconsistent combat replay - 2/21/2005 2:39:30 AM   
CatLord


Posts: 312
Joined: 10/21/2002
From: Lausanne, Switzerland
Status: offline
quote:

ORIGINAL: AmiralLaurent

Hi,

I'm an UV veteran that came back here (from WITP world) just to see if there was some activity.

I had this problem also in PBEM. My own experience show two things :

_ replay discrepencies happen during turns with much air vs naval action, but also on quieter turns when planes (P-39s usually) strafe enemy ships. There is something in strafing that is sending the replay out of its usual path. Check the turns where you saw discrepencies and you will notice that 95% of the times first discrepency is during a strafing attack that would show different results. Problem is that then all results may be different (raids launched or not, sub attacks or not and so on).
This seems to be the cause of my problem and is fairly reproducable. Thank you very much.

Cat

_____________________________

Member of the Revolution Under Siege development team.

(in reply to AmiralLaurent)
Post #: 8
RE: Inconsistent combat replay - 2/21/2005 11:30:29 PM   
Mr.Frag


Posts: 13409
Joined: 12/18/2002
From: Purgatory
Status: offline
The random number pool is not protected in UV ... Japan's results are accurate, ensure you start UV and run the replay with the same options as Japan set.

(in reply to CatLord)
Post #: 9
RE: Inconsistent combat replay - 2/22/2005 3:53:29 AM   
CatLord


Posts: 312
Joined: 10/21/2002
From: Lausanne, Switzerland
Status: offline
Can't that be fixed if it's already done in WitP ?

I mean, the patch has to be redone anyway...

Cat

PS: And sorry, are you sure "protecting the random pool" will solve the problem , as it is still around in WitP ?

_____________________________

Member of the Revolution Under Siege development team.

(in reply to Mr.Frag)
Post #: 10
Page:   [1]
All Forums >> [Current Games From Matrix.] >> [World War II] >> Uncommon Valor - Campaign for the South Pacific >> Tech Support >> Inconsistent combat replay Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.094