Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Combat Animations Not Populated

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Combat Animations Not Populated Page: [1]
Login
Message << Older Topic   Newer Topic >>
Combat Animations Not Populated - 2/25/2019 9:00:31 PM   
Trotsky21

 

Posts: 17
Joined: 2/24/2019
Status: offline
Process: Installed based game file WarinthePacificAdmiralsEdition-SetupRelease-v10079DR. Launched game from launcher. Default to base game full screen resolution. Loaded December 8 scenario as US, immediately ended orders to view combat animations. Air-to-Air combat animations are not populated with aircraft.

Requesting tech support.




Attachment (1)
Post #: 1
RE: Combat Animations Not Populated - 2/25/2019 10:11:51 PM   
BillBrown


Posts: 1726
Joined: 6/15/2002
Status: offline
First, the base game did not support wide screen options, so you have to update to get a better resolution.
As far as the no animations, I have no idea what to tell you. I take it that you are using a stock scenario?
It is almost like there are no files present for the pictures. What directory are you installing the game in?
Do yo have an Anti-Virus program running?

(in reply to Trotsky21)
Post #: 2
RE: Combat Animations Not Populated - 2/26/2019 1:29:36 AM   
Trotsky21

 

Posts: 17
Joined: 2/24/2019
Status: offline
This is the base game without 1124. The game was launched from the launcher immediately after install, so the resolution is whatever the default is; the December 8 scenario selected; no orders entered just proceed to execution.

The install base here is just the base game without the update. Yes I have virus software, and I haven't yet cleanlisted WITP. The install folder is custom, because of the way my computer data is structured I can't use default directories. I should say that at some point during a previous install process, I did have a functioning 1124 which had combat animations, they disappeared when I patched to 1126a.

UPDATE:

Combat animations still not appearing. Install process: 1) installed base version from existing downloaded base file. 2) Installed 1126a version from existing download file. Note: 1124 was not applied, per instructions. Virus software added WITP executable to clean list. 3) Directory E:\WITP_game

Version in splash screen was correct at 1126a and the correct date. Game loads and runs. Combat animations still missing craft images.

Note: As I recall the only install process which resulted in combat animations appearing correctly was installing the base game, and then updating with the "Check For Updates" feature of the launcher, which updates the game version to 1124 (not 1126).

UPDATE #2:

I looked through the file structure. In the /ART folder, all the ship images and icons are there, but none of the folders or the root had any aircraft images. Can anyone verify for me where the art for aircraft are located?

< Message edited by Trotsky21 -- 2/26/2019 2:16:08 AM >

(in reply to BillBrown)
Post #: 3
RE: Combat Animations Not Populated - 2/26/2019 2:28:35 AM   
BillBrown


Posts: 1726
Joined: 6/15/2002
Status: offline
The files are:
Japan: J_PlaneSide.bmp Jptop.bmp jptop_alpha.bmp

Allies: A_PlaneSide.bmp Aptop.bmp Aptop_alpha.bmp

(in reply to Trotsky21)
Post #: 4
RE: Combat Animations Not Populated - 2/26/2019 2:43:53 AM   
Trotsky21

 

Posts: 17
Joined: 2/24/2019
Status: offline
I'm giving up after the 5th attempted installation with the same result. No air combat animations.

(in reply to BillBrown)
Post #: 5
RE: Combat Animations Not Populated - 2/27/2019 3:36:18 AM   
Trotsky21

 

Posts: 17
Joined: 2/24/2019
Status: offline
UPDATE:

Combat animations now appear in the fully installed 1126a version of the game. The issue was the dd_sw switch in the command line, which was not in my command line originally. The dd_sw switch, therefore, is not simply a matter of video or graphics processing speed - without the switch some animations will not appear. This fact should be in the documentation.

(in reply to Trotsky21)
Post #: 6
RE: Combat Animations Not Populated - 2/27/2019 4:00:05 AM   
BillBrown


Posts: 1726
Joined: 6/15/2002
Status: offline
quote:

ORIGINAL: Trotsky21

UPDATE:

Combat animations now appear in the fully installed 1126a version of the game. The issue was the dd_sw switch in the command line, which was not in my command line originally. The dd_sw switch, therefore, is not simply a matter of video or graphics processing speed - without the switch some animations will not appear. This fact should be in the documentation.


That is the first time I have heard of that.
And, since the -dd_sw switch basically bypasses much of the video driver code, I would venture to guess that the underlying
problem is bad/obsolete/corrupted video drivers.

< Message edited by BillBrown -- 2/27/2019 4:02:03 AM >

(in reply to Trotsky21)
Post #: 7
RE: Combat Animations Not Populated - 2/27/2019 8:20:33 PM   
Lokasenna


Posts: 8675
Joined: 3/3/2012
From: Iowan in MD/DC
Status: offline

quote:

ORIGINAL: BillBrown

quote:

ORIGINAL: Trotsky21

UPDATE:

Combat animations now appear in the fully installed 1126a version of the game. The issue was the dd_sw switch in the command line, which was not in my command line originally. The dd_sw switch, therefore, is not simply a matter of video or graphics processing speed - without the switch some animations will not appear. This fact should be in the documentation.


That is the first time I have heard of that.
And, since the -dd_sw switch basically bypasses much of the video driver code, I would venture to guess that the underlying
problem is bad/obsolete/corrupted video drivers.


Alternatively, and I think this is far more likely: running an older game (2009... or 2005?) on newer hardware that has no reason to have good backwards compatibility.

Backwards compatibility is an age-old PC gaming issue that has never gone away.

(in reply to BillBrown)
Post #: 8
RE: Combat Animations Not Populated - 2/28/2019 3:46:02 PM   
Lowpe


Posts: 16836
Joined: 2/25/2013
Status: offline
My graphics will disappear like this when I alt-tab out of the program and have numerous other programs running, or ran many turns back to back...I suspect I am starving the game for memory.

Anyhow, I doubt it was strictly the dd_sw.


(in reply to Lokasenna)
Post #: 9
RE: Combat Animations Not Populated - 2/28/2019 10:46:47 PM   
larryfulkerson

 

Posts: 37508
Joined: 4/17/2005
From: Tucson, AZ
Status: offline
I've got 16 Gig's of RAM and a terrabyte of hard disk and I suffer the same loss
of graphics. I doubt that it's a memory problem gentlemen.

_____________________________

When you get right down to it, almost every explanation Man came up with for anything until about 1926 was stupid.
- Dave Barry

(in reply to Lowpe)
Post #: 10
RE: Combat Animations Not Populated - 3/1/2019 4:19:29 PM   
Lowpe


Posts: 16836
Joined: 2/25/2013
Status: offline

quote:

ORIGINAL: larryfulkerson

I've got 16 Gig's of RAM and a terrabyte of hard disk and I suffer the same loss
of graphics. I doubt that it's a memory problem gentlemen.


Not the kind of memory I was talking about it.

(in reply to larryfulkerson)
Post #: 11
RE: Combat Animations Not Populated - 3/1/2019 7:50:12 PM   
larryfulkerson

 

Posts: 37508
Joined: 4/17/2005
From: Tucson, AZ
Status: offline
quote:

Not the kind of memory I was talking about it


What other kind of memory is there? I heard of an MIT student storing
a 'bit' by using an electromagnetic standing wave between between the earth and the moon.
He discovered that he couldn't use it after all because of the 1.02 second delay in the
sending of the wave and the 1.02 second delay in it's return was at least 2 seconds too slow
for the mainframe he was using and reading it's value changed it's value so you could use
it only once in a program. He decided to use a vacuum tube instead of the earth and moon and
it worked like a charm once you factor in that the value you get for that bit is actually the
opposite of what it holds.




< Message edited by larryfulkerson -- 3/1/2019 7:52:03 PM >


_____________________________

When you get right down to it, almost every explanation Man came up with for anything until about 1926 was stupid.
- Dave Barry

(in reply to Lowpe)
Post #: 12
RE: Combat Animations Not Populated - 3/2/2019 5:32:53 AM   
Technopiper

 

Posts: 64
Joined: 2/11/2019
Status: offline
He could be talking about video memory, just guessing. -dd_sw switch force software graphics.

I was able to replicate the missing plane bug by repeatedly loading progress. Had this bug while trying to figure out about airstrike settings. I must have reloaded for at least 6 or 7 times. First I got the "no plane" animation then CTD. It happened to me everytime I repeatedly reload. This does look like a memory problem.

By the way I had 16MB RAM, 2 GB video RAM. I did use -dd_sw switch. Graphic setting: 1366x768, fullscreen on a 1080 display. I did so to make the picture larger.

Hope that helps.

(in reply to larryfulkerson)
Post #: 13
RE: Combat Animations Not Populated - 3/2/2019 9:55:46 AM   
Yaab


Posts: 3509
Joined: 11/8/2011
From: Poland
Status: offline
I always play WITP:AE on low-end laptops with average RAM memory. I have used the Coral Sea scenario many times to ran several different tests - turn after turn of repeated air vs air , air vs ships combat etc. Never had this problem. Once, I added the -colorBlind switch and the messages' lettering on the animation screen switched from black to white, which blended with backgrounds, so I had to erase the switch.

(in reply to Technopiper)
Post #: 14
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Combat Animations Not Populated Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.131