Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Possible bug: Reinforcement AFV with no MP

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Tigers on the Hunt >> Tech Support >> Possible bug: Reinforcement AFV with no MP Page: [1]
Login
Message << Older Topic   Newer Topic >>
Possible bug: Reinforcement AFV with no MP - 8/28/2018 1:48:52 PM   
UP844


Posts: 1282
Joined: 3/3/2016
From: Genoa, Republic of Genoa (occupied by Italy)
Status: online
Primosole bridge again, this time playing with the Germans.

As soon as I set up a Pz IV F2 in the Reinforcement Segment, it became darkened (like it had spent all its MP)

Later, when I attempted to move it, the game warned me the AFV had no MP (this was not a big surprise).

The PzIV remained darkened in the later turns and was never able to move. It is not marked "IMMOBILISED".

This is an old bug: it does not happen often but - like the one I reported yesterday - could mean disaster in a scenario where reinforcements enter from a single hex.




Attachment (1)

< Message edited by UP844 -- 8/28/2018 1:49:42 PM >


_____________________________

Chasing Germans in the moonlight is no mean sport

Siegfried Sassoon

Long Range Fire (A7.22)........1/2 FP
Post #: 1
RE: Possible bug: Reinforcement AFV with no MP - 8/28/2018 1:50:40 PM   
UP844


Posts: 1282
Joined: 3/3/2016
From: Genoa, Republic of Genoa (occupied by Italy)
Status: online
Here is the saved game ;)


Attachment (1)

_____________________________

Chasing Germans in the moonlight is no mean sport

Siegfried Sassoon

Long Range Fire (A7.22)........1/2 FP

(in reply to UP844)
Post #: 2
RE: Possible bug: Reinforcement AFV with no MP - 8/28/2018 1:58:27 PM   
rico21

 

Posts: 2415
Joined: 3/11/2016
Status: offline
This is not a bug, the Panzer is in place to cover the victory point.

(in reply to UP844)
Post #: 3
RE: Possible bug: Reinforcement AFV with no MP - 8/31/2018 11:48:05 PM   
UP844


Posts: 1282
Joined: 3/3/2016
From: Genoa, Republic of Genoa (occupied by Italy)
Status: online
This IS a bug. The Panzer IV entered just like the Panzer III, but as soon as I was placed it (I was playing with the Germans) became darkened and the warning appeared.

Besides that, I have seen this happen (even though it is a quite rare occurrence) in other scenarios.

_____________________________

Chasing Germans in the moonlight is no mean sport

Siegfried Sassoon

Long Range Fire (A7.22)........1/2 FP

(in reply to rico21)
Post #: 4
RE: Possible bug: Reinforcement AFV with no MP - 9/1/2018 4:53:33 PM   
DoubleDeuce


Posts: 1160
Joined: 6/23/2000
From: Crossville, TN
Status: offline
I saw something similar when working on my 'Taking Ptaki' scenario, with a StuG. I deleted the vehicle, repurchased it and redeployed it using the same parameters and it worked from then on. I was not able to reproduce it.

Here is were someone reported it > http://www.matrixgames.com/forums/fb.asp?m=4269494

< Message edited by DoubleDeuce -- 9/1/2018 6:17:03 PM >


_____________________________


(in reply to UP844)
Post #: 5
RE: Possible bug: Reinforcement AFV with no MP - 9/1/2018 10:32:31 PM   
Peter Fisla


Posts: 2423
Joined: 10/5/2001
From: Canada
Status: offline
UP844, can you please post the scenario file instead of the saved game file. When I load the saved game file, it's already the German Movement segment and I don't see anything wrong with the Pz IV or the Pz III vehicles...

thanks

(in reply to DoubleDeuce)
Post #: 6
RE: Possible bug: Reinforcement AFV with no MP - 9/1/2018 11:15:09 PM   
UP844


Posts: 1282
Joined: 3/3/2016
From: Genoa, Republic of Genoa (occupied by Italy)
Status: online

quote:

ORIGINAL: Peter Fisla

UP844, can you please post the scenario file instead of the saved game file.


The scenario file is Rico's Primosole Bridge, and it is there:

http://www.matrixgames.com/forums/tm.asp?m=4036275&mpage=23&#

In my experience with this bug, however, there is no assurance it will occur again.

quote:

ORIGINAL: Peter Fisla

When I load the saved game file, it's already the German Movement segment and I don't see anything wrong with the Pz IV or the Pz III vehicles...


The Pz IV is darkened as if it had already expended all of its MPs. If you go on with the game until the next German Turn, you will notice the Pz IV never becomes "undarkened". It's like its MP allotment becomes zero .


_____________________________

Chasing Germans in the moonlight is no mean sport

Siegfried Sassoon

Long Range Fire (A7.22)........1/2 FP

(in reply to Peter Fisla)
Post #: 7
RE: Possible bug: Reinforcement AFV with no MP - 9/1/2018 11:25:48 PM   
Peter Fisla


Posts: 2423
Joined: 10/5/2001
From: Canada
Status: offline
OK, I got the scenario; I will take a look...

(in reply to UP844)
Post #: 8
RE: Possible bug: Reinforcement AFV with no MP - 9/2/2018 1:22:06 PM   
UP844


Posts: 1282
Joined: 3/3/2016
From: Genoa, Republic of Genoa (occupied by Italy)
Status: online
I have purposely moved a Marder up to the last MP: the AFV counter became darker, but it reverter to its normal shade of colour in the immediately following American Defensive Fire Segment.

This does not happen when the bug occurs: the AFV remains dark for the rest of the game.




Attachment (1)

_____________________________

Chasing Germans in the moonlight is no mean sport

Siegfried Sassoon

Long Range Fire (A7.22)........1/2 FP

(in reply to Peter Fisla)
Post #: 9
RE: Possible bug: Reinforcement AFV with no MP - 9/3/2018 12:48:31 PM   
UP844


Posts: 1282
Joined: 3/3/2016
From: Genoa, Republic of Genoa (occupied by Italy)
Status: online
I observed another occurrence of "darkening": when an AFV is Shocked, its counter darkens at the very start of its Movement Segment and than reverts to its normal shade at the start of the opponent Defensive Fire.

_____________________________

Chasing Germans in the moonlight is no mean sport

Siegfried Sassoon

Long Range Fire (A7.22)........1/2 FP

(in reply to UP844)
Post #: 10
RE: Possible bug: Reinforcement AFV with no MP - 12/11/2018 9:02:17 PM   
Peter Fisla


Posts: 2423
Joined: 10/5/2001
From: Canada
Status: offline
I finally had some time to look at this issue. It turns out that this is a scenario data issue not game bug, fro some reason the Pz IV F2 [ID:6] has movement value of 0 in the scenario file. So what I have done, I have loaded the affected scenario into the scenario editor deleted this Pz IV F2 and then re-created the unit and saved the scenario. I'm attaching the updated scenario with the corrected Pz IV F2 entering map on turn 7. I was then able to play the scenario and when Turn 7 came and the Pz IV F2 came on board, I was able to move the tank just fine. I have checked all other Pz IV F2s in the scenario and they are just fine. Also, I have checked the game editor code and everything is correct, so I'm not sure what happened here. Perhaps it is an old scenario, who knows...

In Any case, if you see this kind of situation in other scenarios, you will need to modify the scenario...remove the affected AFV and then re-create it again.

Cheers!

Peter

Attachment (1)

< Message edited by Peter Fisla -- 12/11/2018 9:15:29 PM >

(in reply to UP844)
Post #: 11
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Tigers on the Hunt >> Tech Support >> Possible bug: Reinforcement AFV with no MP Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.152