Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Weird Constructor Behavior

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Weird Constructor Behavior Page: [1]
Login
Message << Older Topic   Newer Topic >>
Weird Constructor Behavior - 7/26/2017 7:57:43 PM   
LizardSF

 

Posts: 5
Joined: 6/12/2013
Status: offline
I have a common pattern with DWU. I start playing, I get to mid-game-ish where I have several colonies, a positive cashflow, a few wonders, and then, something happens and I just give up until I try again a few months later.

This time, it's my constructor.

I found one of the "death star" ships... the "World Destroyer". It had some other races working on it, which would not do. After some effort to build ships with the range to reach it, I set out a constructor and a fleet to escort it. I scared off the other constructors and order mine to repair the ship.

It instantly turned and fled to the nearest colony, several sectors away. My guardian fleet followed it.

I maneuvered other constructors into the area and kept a few military ships to fight off other races' constructors, earning nasty messages from them. I could order any of the constructors to repair any of the other ruined ships in the region, but as soon as I gave them the order to repair the "world destroyer", they ran.

This is annoying, to say the least.

The target ship is listed as having only a single damaged component, so the next race to succesfully repair it will have a powerful advantage. Bad enough some "legendary pirates" just spawned and wiped out one of my colony's defensive based like it was a sublight escort.

Advice, please?

I'm using the latest DWU, with Starfall 1.12 Fixed.
Post #: 1
RE: Weird Constructor Behavior - 7/26/2017 8:22:15 PM   
stuart3

 

Posts: 113
Joined: 9/4/2014
Status: offline
Whenever you order a construction ship to construct or complete the construction of a ship or base the first thing it will do is to visit a suitably developed colony in order to top up it's supplies of resources. Only then will it set off to do the construction.

If you order a construction ship that is already close to such a colony to complete the World Destroyer then it will only have to make a single trip there and not a return journey. This is the best you can do.

Note that this does not apply when the construction ship is ordered to repair something. In that case it will simply head straight to the damaged ship or base and carry out the repair.

(in reply to LizardSF)
Post #: 2
RE: Weird Constructor Behavior - 7/26/2017 8:42:27 PM   
LizardSF

 

Posts: 5
Joined: 6/12/2013
Status: offline
OK, that makes a kind of sense. I had simply "moved" the constructor to the target system because I didn't have a ship there to let me "see" the world destroyer at the time. So they're running back to reload. I guess I can keep my fleet in the region and keep blasting other ships that get near my precioussss....

(in reply to stuart3)
Post #: 3
RE: Weird Constructor Behavior - 7/26/2017 10:52:58 PM   
Retreat1970


Posts: 564
Joined: 11/6/2013
From: Wisconsin
Status: online
Change the constructor stance to something other than flee when enemy sighted. Could be there's a slug around. Also any enemy ship comes in and they'll bolt.

(in reply to LizardSF)
Post #: 4
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Weird Constructor Behavior Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.139