Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Game running painfully slow...

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Game running painfully slow... Page: [1]
Login
Message << Older Topic   Newer Topic >>
Game running painfully slow... - 3/30/2017 1:14:23 PM   
GBS

 

Posts: 903
Joined: 7/3/2002
From: Southeastern USA
Status: offline
Is there anything I can do to speed things up? I have a much more advanced computer than I had when I played Admirals Edition years ago. Giving orders and trying to move from screen to screen now can take 5 to 10 seconds for them to open or close. Hope someone can advise because it is close to unplayable. Thanks.
Post #: 1
RE: Game running painfully slow... - 3/30/2017 1:22:26 PM   
ReadyR

 

Posts: 28
Joined: 5/17/2015
From: Ottawa, Canada
Status: offline
I am new to this game, so hesitate to offer help...However, I had the same problem when I started on a Windows 10 machine. Take a look at the ReadMe files. In one of them is a walkthrough of various settings to try. After some fiddling around, I found the setting that makes the game run as it should, even on Windows 10.

(in reply to GBS)
Post #: 2
RE: Game running painfully slow... - 3/30/2017 1:28:05 PM   
MakeeLearn

 

Posts: 1915
Joined: 9/11/2016
Status: online
You have to use command line switches. It's detailed in the "whatsnew" pdf in the game folder.

And more info in various threads in tech support.

example:
"C:\Matrix Games\War in the Pacific Admiral's Edition.exe" -SingleCpuOrders -deepColor -dd_sw -altFont'


Make sure target is "War in the Pacific Admiral's Edition.exe" and NOT "War in the Pacific Admiral's Edition\autorun.exe'\"


There are several command line switches some needed some based on individual computers and taste.

-deepColor -dd_sw are most common and important .




Attachment (1)

< Message edited by MakeeLearn -- 3/30/2017 4:27:19 PM >

(in reply to GBS)
Post #: 3
RE: Game running painfully slow... - 3/30/2017 1:31:02 PM   
Macclan5


Posts: 582
Joined: 3/24/2016
From: Toronto Canada
Status: offline

quote:

ORIGINAL: MakeeLearn

You have to use command line switches. It's detailed in the "whatsnew" pdf in the game folder.

And more info in various threads in tech support.


"C:\Matrix Games\War in the Pacific Admiral's Edition\autorun.exe" -SingleCpuOrders -deepColor -dd_sw -altFont





+1

Here is the specific thread.

http://www.matrixgames.com/forums/tm.asp?m=3905995


My personal opinion is to make sure you set the "switches" to single CPU.

I am rather convinced that the game engine works best on a single CPU as it was developed long before duo-cores, quad cores, etc.

Disclaimer: I am a diesel Volkswagen on the information super highway.


_____________________________

A People that values its privileges above it's principles will soon loose both. Dwight D Eisenhower.

(in reply to MakeeLearn)
Post #: 4
RE: Game running painfully slow... - 3/30/2017 2:11:56 PM   
Ol_Dog


Posts: 318
Joined: 2/23/2003
From: Southern Illinois
Status: online
But I believe you get good mileage for a diesel

_____________________________

Common Sense is an uncommon virtue.
If you think you have everything under control, you don't fully understand the situation.

(in reply to Macclan5)
Post #: 5
RE: Game running painfully slow... - 3/31/2017 11:25:33 AM   
GBS

 

Posts: 903
Joined: 7/3/2002
From: Southeastern USA
Status: offline
Thanks for the help. I can get to the properties page but cant find the command line switches you talk about.

(in reply to Ol_Dog)
Post #: 6
RE: Game running painfully slow... - 3/31/2017 11:37:35 AM   
Bullwinkle58


Posts: 11011
Joined: 2/24/2009
Status: offline
quote:

ORIGINAL: GBS

Thanks for the help. I can get to the properties page but cant find the command line switches you talk about.


In your game folder, top level, open either readme.rtf or WhatsNew.pdf. Switches are fully covered.

_____________________________

The Moose

(in reply to GBS)
Post #: 7
RE: Game running painfully slow... - 3/31/2017 7:15:39 PM   
jmalter

 

Posts: 1652
Joined: 10/12/2010
Status: offline
You might be able to improve your game's performance w/ its command-line switches. It's also worth investigating your computer for other programs, running as background services, that use significant CPU & RAM resources. For example, in my Windows Vista Business OS, the Windows Updater service was hogging the CPU, I disabled that program. Also, I run WitP continuously - after 5 or 6 2-day turns, my box gets tired. Save, exit, shut down, reboot, & restart.

(in reply to Bullwinkle58)
Post #: 8
RE: Game running painfully slow... - 3/31/2017 9:09:33 PM   
Sardaukar


Posts: 6654
Joined: 11/28/2001
From: Finland/Israel/Romania
Status: offline
It all depends on your computer.

I have got good performance with specific switches...that did not work for others so well.

So, bit of experiment might be needed.

Mine is (without actual path):

War in the Pacific Admiral Edition.exe" -altFont -px1366 -py768 -multiaudio -dd_sw -skipVideo -deepColor -SingleCpuOrders -cpu2

_____________________________

"To meaningless French Idealism, Liberty, Fraternity and Equality...we answer with German Realism, Infantry, Cavalry and Artillery" -Prince von Bülov, 1870-


(in reply to jmalter)
Post #: 9
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Game running painfully slow... Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.141