Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Did I miss something..? [Resolved]

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Did I miss something..? [Resolved] Page: [1]
Login
Message << Older Topic   Newer Topic >>
Did I miss something..? [Resolved] - 1/12/2017 1:34:00 AM   
Unforeseen


Posts: 588
Joined: 3/26/2013
From: New Earth
Status: offline
So I'm playing my game, trying to get to year 2200 before starting my AAR and while looking around for an ice planet to stick a naxx colony ship i found on I notice an uninhabited Utopia. I thought, huh...that's awful strange... go into the editor and sure enough they (ancient guardians) aren't even in the game.

Now..It's been quite some time since I hand picked all the empires in the customization screen. I know the guardians were one of the choices.. But I assumed they would just..you know automatically be in the game like they used to. Have things changed or am I experiencing a strange bug?




Attachment (1)

< Message edited by Unforeseen -- 1/14/2017 1:13:30 AM >


_____________________________

Signature not required.
Post #: 1
RE: Did I miss something..? - 1/12/2017 3:50:40 AM   
Aeson

 

Posts: 704
Joined: 8/30/2013
Status: offline
The Ancient Guardians are only spawned if you have the Return of the Shakturi storyline enabled in game setup, at least in the unmodded game.

(in reply to Unforeseen)
Post #: 2
RE: Did I miss something..? - 1/12/2017 1:51:48 PM   
Unforeseen


Posts: 588
Joined: 3/26/2013
From: New Earth
Status: offline
Hmm well the story events were all on. Is there anything else that would cause this? I did change the name from Mechanoid to Guardian. Could that cause this?

_____________________________

Signature not required.

(in reply to Aeson)
Post #: 3
RE: Did I miss something..? - 1/12/2017 6:22:58 PM   
Aeson

 

Posts: 704
Joined: 8/30/2013
Status: offline
Possibly, if the game is looking for the name rather than a reference index when it tries to spawn a colony on Utopia. There's a post somewhere around here indicating that you can stop sand slugs from spawning on Korrabia by changing the name of the monster, so it wouldn't be terribly surprising to me if the game is looking for a specific name when it tries to spawn the Ancient Guardians.

It might also be vaguely possible that the colony spawned properly but was wiped out by bombardment weapons, though in that case you should probably find either abandoned ships and stations or Ancient Guardians-style stations owned by one of the local empires or pirate factions in the region around the planet. I would however regard it as very unlikely for this to happen, especially if none of the empires in the game were given a particularly advanced start.

(in reply to Unforeseen)
Post #: 4
RE: Did I miss something..? - 1/14/2017 12:41:57 AM   
Unforeseen


Posts: 588
Joined: 3/26/2013
From: New Earth
Status: offline
I guess it's a bug, probably going to have to try a fresh install. Even after changing the name back, no guardians. Started a game on vanilla, no guardians.

Edit: Did some digging, apparently this was brought up a while back and it turned out that on pre-warp games the Guardians don't spawn on Utopia until you go to their system and meet them. That's probably what was wrong in the first game, as I never actually went to the system with a ship I simply had obtained a map of the area. Feel kinda stupid for not knowing about this lol.

< Message edited by Unforeseen -- 1/14/2017 1:16:29 AM >


_____________________________

Signature not required.

(in reply to Aeson)
Post #: 5
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Did I miss something..? [Resolved] Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.115