Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Seeking Help to get WITPAE running in Windows 8

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Seeking Help to get WITPAE running in Windows 8 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Seeking Help to get WITPAE running in Windows 8 - 5/19/2015 1:49:03 PM   
anthonykevinluke

 

Posts: 251
Joined: 8/31/2001
Status: offline
Evening/morning all,

I have read the read me and also the tech threads on how to fix the horrible lag issues with WITPAE and Windows 8, however still no joy in fixing the problem; for example it takes me 10-15 seconds to open up a city like Saigon when I click on it! I have a desktop system (general specs - Intel(R) 7 series chipset, NVIDIA Geforce GTX 670, quad core, 16 Gb of ram, Intel (R) core (TM) i5-3570k cpu@3.40Gh -more detail if someone knowledgeable wants it).
I have tried several combinations from the threads and as said still no luck, currently my shortcut target line is -"E:\Matrix Games\War in the Pacific Admiral's Edition\autorun.exe" –deepColor -cpu2 -multiaudio -dd_sw -px2560 py1440. Can someone confirm that this is supposed to go into the shortcut target line; and any ideas on what I am doing wrong? Any assistance would be greatly appreciated as this is killing me ... happy to provide more info on system if anyone can assist. Not having any problems with screen width - just the lag. In hope of help!

regards,

AKL
Post #: 1
RE: Seeking Help to get WITPAE running in Windows 8 - 5/19/2015 2:49:43 PM   
tomed63

 

Posts: 35
Joined: 11/27/2012
Status: offline
Tony Luke
Hi! I use windows 8 and don't have any problems with the game.
the first thing I noticed is that you are addressing the autorun.exe.
You should be addressing the witpae.exe.
This is what I use: C:\War in the pacific Admirals edition.exe -wd -deepcolor -singlecpustart-px1360 -py768
-multiaudio -dd_ssw -skip video -archieve -altfont.
I'm pretty sure this will fix your problem.

Thomas

Back again, are you using a wide screen? is the game filling the screen?
when I use the px py that I indicated, the game fills a wide screen.
when I tried the px py that you indicated, I got a normal windows screen which did not fill the screen.


< Message edited by tomed63 -- 5/19/2015 4:00:53 PM >

(in reply to anthonykevinluke)
Post #: 2
RE: Seeking Help to get WITPAE running in Windows 8 - 5/19/2015 4:09:00 PM   
Leandros


Posts: 1063
Joined: 3/5/2015
Status: offline

Hi, Tomed - I have the same problem and have tried to insert the various suggestions as lined up by you in the start-up line. Nothing happens. I also have the
problem that when I "take down" the game picture, the frame texts are garbled when I bring it up again. Rather annoying when one wants to take a break and look in
at something else. In practice I have to close the game each time. Correct scaling is only achieved when I run it through an external 4:3 screen. My laptop
screen is widescreen.

What I'm wondering is if I'm correcting the CORRECT line. Exactly where is the command line found where the corrections shall be inserted?

Fred

_____________________________

River Wide, Ocean Deep - a book on Operation Sea Lion - www.fredleander.com
Saving MacArthur - a book series on how The Philippines were saved - in 1942! http://www.amazon.com/gp/product/B018F2QMEW?*Version*=1&*entries*=0

(in reply to tomed63)
Post #: 3
RE: Seeking Help to get WITPAE running in Windows 8 - 5/19/2015 4:58:27 PM   
pmelheck1

 

Posts: 596
Joined: 4/3/2003
From: Alabama
Status: offline
I fixed it with the -deepColor switch. watch the capital C I had a lower case c and it didn't work. Must be a capital C in the switch.

_____________________________


(in reply to Leandros)
Post #: 4
RE: Seeking Help to get WITPAE running in Windows 8 - 5/19/2015 8:28:51 PM   
rustysi


Posts: 4053
Joined: 2/21/2012
From: LI, NY
Status: offline
Not 100% sure but IIRC I've heard there're issues sometimes with multiple core systems. Game engine's pretty old and doesn't always play nice with multi-cores.

_____________________________

It is seldom that liberty of any kind is lost all at once. Hume

In every party there is one member who by his all-too-devout pronouncement of the party principles provokes the others to apostasy. Nietzsche

Cave ab homine unius libri. Ltn Prvb

(in reply to pmelheck1)
Post #: 5
RE: Seeking Help to get WITPAE running in Windows 8 - 5/20/2015 1:52:11 AM   
anthonykevinluke

 

Posts: 251
Joined: 8/31/2001
Status: offline
Hi Tomed and others,

The line I use above is the line in the desktop shortcut, the 'target' line. Is this the correct line I should be changing? If not where is the line found that I need to change? Should my shortcut line read .exe rather than autorun.exe? Am I changing the right line in the right place??? and yes I have got it working full screen (a bit stretched looking but looks OK) and no slow down during animations, firing etc. just scrolling and trying to open things up on the screen.

Also tried the directions in the read me file in the main folder and it talked about changing the - “Quick Start” shortcut to the game (located in your Start Menu folder for War in the Pacific: Admiral’s Edition ....." I do not have one of these in my main game folder?

Appreciate the feedback and hope for answers to my above. Still hoping to get this working. Many thanks.

Regards,

AKL

(in reply to rustysi)
Post #: 6
RE: Seeking Help to get WITPAE running in Windows 8 - 5/20/2015 2:14:16 AM   
rustysi


Posts: 4053
Joined: 2/21/2012
From: LI, NY
Status: offline
Nope got it wrong. I'll try again.

< Message edited by rustysi -- 5/20/2015 3:14:57 AM >


_____________________________

It is seldom that liberty of any kind is lost all at once. Hume

In every party there is one member who by his all-too-devout pronouncement of the party principles provokes the others to apostasy. Nietzsche

Cave ab homine unius libri. Ltn Prvb

(in reply to anthonykevinluke)
Post #: 7
RE: Seeking Help to get WITPAE running in Windows 8 - 5/20/2015 2:19:20 AM   
rustysi


Posts: 4053
Joined: 2/21/2012
From: LI, NY
Status: offline
http://www.matrixgames.com/forums/tm.asp?m=3508445&mpage=1&key=win&#

OK let's see if I got it right this time. This may help.

OK, got it right. This is a link to another thread on the subject. Hope it helps.

< Message edited by rustysi -- 5/20/2015 3:20:26 AM >


_____________________________

It is seldom that liberty of any kind is lost all at once. Hume

In every party there is one member who by his all-too-devout pronouncement of the party principles provokes the others to apostasy. Nietzsche

Cave ab homine unius libri. Ltn Prvb

(in reply to rustysi)
Post #: 8
RE: Seeking Help to get WITPAE running in Windows 8 - 5/20/2015 2:23:49 AM   
anthonykevinluke

 

Posts: 251
Joined: 8/31/2001
Status: offline
Ah ha ... some success, thanks so far. I created a new shortcut in the main game file and used the command line by Tomed and it did indeed fix the lag issue! However (as nothing should ever be easy when dealing with tech) I only had a small windowed screen instead of full screen. So I changed the PX and xy size to 1920/1080 and got a full windowed screen but had all the bottom info covered by my task bar. So, I took out the -wd (windows command) and it gave me full screen but re-introduced the lag! Any thoughts? Why no lag in Windows mode but massive lag without it ...?

Still working and open to suggestions,

regards,

AKL

Edit - If I go to windowed full screen mode I lose the bottom of the screen - i.e. where the industry line sits, cuts of at ground troops ....

< Message edited by tony luke -- 5/20/2015 3:50:56 AM >

(in reply to rustysi)
Post #: 9
RE: Seeking Help to get WITPAE running in Windows 8 - 5/20/2015 3:32:33 AM   
wdolson

 

Posts: 10345
Joined: 6/28/2006
From: Near Portland, OR
Status: offline
You could go back to the -wd and reduce the y size from 1080 to something like 950 or so.

Bill

_____________________________

WitP AE - Test team lead, programmer

(in reply to anthonykevinluke)
Post #: 10
RE: Seeking Help to get WITPAE running in Windows 8 - 5/20/2015 6:42:53 AM   
anthonykevinluke

 

Posts: 251
Joined: 8/31/2001
Status: offline
Thanks I'll give it a go ........

Regards,

AKL

(in reply to wdolson)
Post #: 11
RE: Seeking Help to get WITPAE running in Windows 8 - 5/20/2015 3:06:27 PM   
Admiral DadMan


Posts: 3420
Joined: 2/22/2002
From: A Lion uses all its might to catch a Rabbit
Status: offline
if you want to use the 1080 setting you can "Auto hide" your taskbar.

_____________________________

Scenario 127: "Scraps of Paper"
(\../)
(O.o)
(> <)

CVB Langley:

(in reply to anthonykevinluke)
Post #: 12
RE: Seeking Help to get WITPAE running in Windows 8 - 5/20/2015 6:37:07 PM   
lb4269


Posts: 182
Joined: 9/14/2004
Status: offline
Windows 8 drove me bonkers when I got my new computer. I was at the end of my rope until I stumbled into a fix on my own computer.

If you right click the shortcut and go under properties, there should be a compatibility tab. Under that was an option to set various things and I put mine under Windows Service Pack 2.

It fixed everything for me and I have not had a single problem since.






Attachment (1)

_____________________________

MikeS

(in reply to Admiral DadMan)
Post #: 13
RE: Seeking Help to get WITPAE running in Windows 8 - 5/20/2015 11:45:54 PM   
anthonykevinluke

 

Posts: 251
Joined: 8/31/2001
Status: offline
Thanks all; still need to do some experimenting ...

I did hide the task bar and use 1080 but it still cut off the industry line, reducing to 950 made the full window turn into a small window stuck in the top left, I am sure you know the effect I am describing. Maybe there is a number in between that will enable me to see it all as well as get full screen. Still puzzled why not using windowed mode re-introduced the lag ...? Haven't tried the compatibility fix via properties; I looked at it and thought that surely everyone had already tried that! Perhaps I was wrong, therefore I will give it a go as well.

Thanks all, still working to get it right.

regards,

AKL

(in reply to lb4269)
Post #: 14
RE: Seeking Help to get WITPAE running in Windows 8 - 5/21/2015 8:05:19 AM   
Reg


Posts: 2716
Joined: 5/26/2000
From: Victoria, Australia
Status: offline
At the risk of seeming flippant, get a second monitor. (They're cheap these days...)

Win8 will allow you to selectively set your bigger screen as the primary display and you can run WITP in full screen on that. Use the other screen to access the task bar and read the manual etc....



< Message edited by Reg -- 5/21/2015 9:05:50 AM >


_____________________________

Cheers,
Reg.

(One day I will learn to spell - or check before posting....)
Uh oh, Firefox has a spell checker!! What excuse can I use now!!!

(in reply to anthonykevinluke)
Post #: 15
RE: Seeking Help to get WITPAE running in Windows 8 - 5/21/2015 8:21:02 AM   
Leandros


Posts: 1063
Joined: 3/5/2015
Status: offline
quote:

ORIGINAL: Reg

At the risk of seeming flippant, get a second monitor. (They're cheap these days...)

Win8 will allow you to selectively set your bigger screen as the primary display and you can run WITP in full screen on that. Use the other screen to access the task bar and read the manual etc....



Or use an older (4:3) one as supplementary. I did that and it works, particularly if you have a dedicated grahics card. But I still have the lag and garbled text
when I "take down, put up" the game picture.

Fred

P.S.: What is just as "irritating" is that when I "put up" the (garbled text) picture again, the lag is gone!


< Message edited by Leandros -- 5/21/2015 9:32:45 AM >


_____________________________

River Wide, Ocean Deep - a book on Operation Sea Lion - www.fredleander.com
Saving MacArthur - a book series on how The Philippines were saved - in 1942! http://www.amazon.com/gp/product/B018F2QMEW?*Version*=1&*entries*=0

(in reply to Reg)
Post #: 16
RE: Seeking Help to get WITPAE running in Windows 8 - 5/21/2015 11:53:47 AM   
anthonykevinluke

 

Posts: 251
Joined: 8/31/2001
Status: offline
Hmmm ... interesting - been trying lots of different combinations but have noticed that with all of them that after 2 to 3 turns the game gets slower and slower, and animations become much slower and action and sound go out of synch? Do you experience this? If so what is the solution ...??? I have found this with both windowed and full screen options.

regards,

AKL

(in reply to Leandros)
Post #: 17
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Seeking Help to get WITPAE running in Windows 8 Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.121