Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Engine thrusters alignment

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> Engine thrusters alignment Page: [1]
Login
Message << Older Topic   Newer Topic >>
Engine thrusters alignment - 6/9/2014 12:18:25 AM   
AstroCat


Posts: 440
Joined: 7/31/2003
Status: offline
How come the engine exhaust graphic often appears not aligned to where it is assigned on the ship .png? Is there a trick to getting this to work. Even the vanilla ones are often misaligned to the ships. thanks!

< Message edited by AstroCat -- 6/9/2014 3:11:19 AM >
Post #: 1
RE: Engine thrusters alignment - 6/9/2014 3:36:16 AM   
RICO7878


Posts: 46
Joined: 8/24/2012
Status: offline
The engine "alignment" changes as the ship's speed changes. When a ship is at full sub-light speed then the full extent or alignment of the engines will match the pure blue lines on the ship image file. If the ship is cruising or going slow then the exhaust will shrink and some engines might even appear to go out completely while only one exhaust is on. Took me a while to notice this too and I was always checking my image files. I think this is what you are referring to but try to post a screenshot if you can if you think this is something else.

(in reply to AstroCat)
Post #: 2
RE: Engine thrusters alignment - 6/9/2014 12:16:29 PM   
AstroCat


Posts: 440
Joined: 7/31/2003
Status: offline
I mean the engine exhaust does not line up with where it should in-game. Check the screen shot and you'll see the thrusters are not centered correctly on the ships, event though they have the proper "blue lines" in the .png file.

So basically the engine exhaust is not appearing in-game where the "blue line" says it should. Thanks for then help!

Normal version:
http://i1351.photobucket.com/albums/p788/astrocat2/2014-06-09_071346_zpsf59da8b1.jpg~original

Zoomed in version to really see it:


< Message edited by AstroCat -- 6/9/2014 1:28:41 PM >

(in reply to RICO7878)
Post #: 3
RE: Engine thrusters alignment - 6/9/2014 2:28:13 PM   
Locarnus


Posts: 275
Joined: 5/30/2010
From: Earth, Sol
Status: offline
Does it affect all shipsets?

If not, can you upload an affected shipset?

_____________________________

DW:U BalanceMod v0.9 (extended TechTree)
compatible with DW:U Extended, StarTrek and XPanded

http://www.matrixgames.com/forums/tm.asp?m=3624576

(in reply to AstroCat)
Post #: 4
RE: Engine thrusters alignment - 6/9/2014 5:40:30 PM   
AstroCat


Posts: 440
Joined: 7/31/2003
Status: offline
It effects lots of the shipsets including the vanilla (human) family6. It also doesn't matter whether I use vanilla or modded engine exhaust files. The problem remains the same.



< Message edited by AstroCat -- 6/9/2014 6:41:55 PM >

(in reply to Locarnus)
Post #: 5
RE: Engine thrusters alignment - 6/11/2014 11:45:49 AM   
AstroCat


Posts: 440
Joined: 7/31/2003
Status: offline
Ok, I went and looked at a bunch of screenshots from other people's games and sure enough same problem. So, it's not just me but a total game bug. Any ideas how to fix it?

(in reply to AstroCat)
Post #: 6
RE: Engine thrusters alignment - 6/11/2014 12:16:02 PM   
AstroCat


Posts: 440
Joined: 7/31/2003
Status: offline
More info, yeah something is seriously wrong with this in the game. If I take then "blue" bar in the .png and move them around way off where I want them to be I can actually get them to show up correctly in-game! Like way off to the side, ends up correct in-game!

(in reply to AstroCat)
Post #: 7
RE: Engine thrusters alignment - 6/11/2014 12:32:25 PM   
Mansen


Posts: 352
Joined: 5/3/2013
Status: offline
You're not compressing the png files by any chance are you? I imagine that could eff up the RGB values.

_____________________________

Currently Working On:
X-Universe Conversion (Hiatus)

(in reply to AstroCat)
Post #: 8
RE: Engine thrusters alignment - 6/11/2014 1:48:07 PM   
Dd_01


Posts: 63
Joined: 12/19/2012
From: Russia
Status: offline
As I see, problem appears with the modded thrusters. Maybe they cause the issue?

(in reply to Mansen)
Post #: 9
RE: Engine thrusters alignment - 6/11/2014 6:47:00 PM   
AstroCat


Posts: 440
Joined: 7/31/2003
Status: offline
Yeah, this is a tough one to really figure out. At this point I'm starting to think this has to do with the image resize issue we now have with planets and overlays. I am gonna keep messing with it and see what I can come up with. The behavior of the engine thrusts really don't just "follow the blue line" like it says.

(in reply to Dd_01)
Post #: 10
RE: Engine thrusters alignment - 6/11/2014 7:09:17 PM   
Darkspire


Posts: 1989
Joined: 6/12/2003
From: My Own Private Hell
Status: offline

quote:

ORIGINAL: AstroCat

Yeah, this is a tough one to really figure out. At this point I'm starting to think this has to do with the image resize issue we now have with planets and overlays. I am gonna keep messing with it and see what I can come up with. The behavior of the engine thrusts really don't just "follow the blue line" like it says.


There does seem to be something amiss, the shot below is from 1.9.5.0, the engine plumes are in the right position there, custom shipset, I have 1.9.5.1 in at present but have not really taken any shots as I have not played for a few days due to trying to get Darkverse up to date, I will fire it up tonight and see if there is any difference with the same race as 1.9.5.1 is where the scaling was changed.

These were very early Ion engines I think, start of a PreWarp game, do different engines all have the same offset GFX effect? I shall try that out as well methinks, shouldn't make any difference but the tester in me says check it out

Darkspire



_____________________________


(in reply to AstroCat)
Post #: 11
RE: Engine thrusters alignment - 6/12/2014 12:01:03 AM   
AstroCat


Posts: 440
Joined: 7/31/2003
Status: offline
Yeah I've tried everything and I can't quite figure out the deal. Maybe someone else can help out, and tell me why this keeps happening in so many different configurations.

One thing I know for sure, it does NOT work as intended or stated.

< Message edited by AstroCat -- 6/12/2014 1:21:13 AM >

(in reply to Darkspire)
Post #: 12
RE: Engine thrusters alignment - 6/12/2014 12:16:27 AM   
Aeo762

 

Posts: 2
Joined: 6/8/2014
Status: offline
I noticed this as well the other night..
It does indeed seem to be a resizing issue. I did a few quick tests, resizing both the thruster graphics and the graphic for the biggest offender in my current shipset.
Resizing the thrusters had no noticeable effect, but resizing the ship from 300x300 to 500x500 did show a small improvement in thruster position in-game, though it was still not 100% correct. My guess is the way the game automatically resizes images is flawed, leading to these issues.

Darkspire, quick question. Where can I find that shipset seen in your screenshot? It looks great.

(in reply to Darkspire)
Post #: 13
RE: Engine thrusters alignment - 6/12/2014 12:21:57 AM   
AstroCat


Posts: 440
Joined: 7/31/2003
Status: offline
Yeah I looked a bunch of user screenshots and found the bug all over the place, so I know it's real and not just me. I think (don't know for sure of course) it's related to the planet and overlay issue.

(in reply to Aeo762)
Post #: 14
RE: Engine thrusters alignment - 6/12/2014 12:20:07 PM   
AstroCat


Posts: 440
Joined: 7/31/2003
Status: offline
Ok, the best I can do to "fix" this issue is this, similar to how I "fixed" the GEM planets and overlays.

Start with all the default thruster images.
Then open you "modded" ones.
Resize to 53x53
Transform to scale, I found 130% worked good for what I was using.
Paste as a new layer onto the default image.
Make sure it lines up close.
Delete the original layer 0.
Save as an uncompressed .png.

That's the best I can do, it's not perfect but it matches up closer than before.

I attached my enginethrusters.zip so anyone can check it out.

Attachment (1)

< Message edited by AstroCat -- 6/12/2014 1:22:34 PM >

(in reply to AstroCat)
Post #: 15
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> Engine thrusters alignment Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.156