Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[Fixed] Fix It

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> [Fixed] Fix It Page: [1]
Login
Message << Older Topic   Newer Topic >>
[Fixed] Fix It - 5/29/2014 5:39:15 AM   
addchild314

 

Posts: 3
Joined: 5/29/2014
Status: offline
Two things.

First: Consider hiring a quality assurance team. They can help discover bugs before release, causing people to actually enjoy your game.

Second: Is this what I should expect it to do? Because I expected more stars, ships, and explosions.

Distant Worlds - Crash Dump - 1.9.5.1

1:19:03 AM Thursday, May 29, 2014


System.Runtime.InteropServices.COMException (0x80040154): Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
at System.Windows.Forms.UnsafeNativeMethods.CoCreateInstance(Guid& clsid, Object punkOuter, Int32 context, Guid& iid)
at System.Windows.Forms.AxHost.CreateWithLicense(String license, Guid clsid)
at System.Windows.Forms.AxHost.CreateInstanceCore(Guid clsid)
at System.Windows.Forms.AxHost.CreateInstance()
at System.Windows.Forms.AxHost.GetOcxCreate()
at System.Windows.Forms.AxHost.TransitionUpTo(Int32 state)
at System.Windows.Forms.AxHost.CreateHandle()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.AxHost.EndInit()
at DistantWorlds.Start.XkCYaRIG4UKiNVl6ZUy(Object )
at DistantWorlds.Start.PDqJ52o3mV()
at DistantWorlds.Start..ctor()
at sUMn0fc5CEqtPeT10H.I3qOOMQIxxForGALDE.oBUhiDVFYIM()


--- COMPLETE ---

and this older ****

Distant Worlds - Crash Dump - 1.9.5.0

1:08:16 AM Thursday, May 29, 2014


System.Runtime.InteropServices.COMException (0x80040154): Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
at System.Windows.Forms.UnsafeNativeMethods.CoCreateInstance(Guid& clsid, Object punkOuter, Int32 context, Guid& iid)
at System.Windows.Forms.AxHost.CreateWithLicense(String license, Guid clsid)
at System.Windows.Forms.AxHost.CreateInstanceCore(Guid clsid)
at System.Windows.Forms.AxHost.CreateInstance()
at System.Windows.Forms.AxHost.GetOcxCreate()
at System.Windows.Forms.AxHost.TransitionUpTo(Int32 state)
at System.Windows.Forms.AxHost.CreateHandle()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.AxHost.EndInit()
at DistantWorlds.Start.BMFev7d9yEhCkIpXJBV(Object )
at DistantWorlds.Start.ammvpy3cwB()
at DistantWorlds.Start..ctor()
at Tb9dooikR4oF2la5ZE.k5iURiDyr2g1taxEYo.OoIqyfobPqH()


Win7 x64 SP1 Ult.
AMD FX8350
32GB DDR3-1333
Radeon HD 7870 OC


--- COMPLETE ---

P.S.: No, the Beta does not address this issue, in case you missed it in the version numbers above.
P.P.S.: Compatibility mode makes no difference in Windows 7, Windows Vista, Win XP SP3, WinXP Sp2, Win2000, Win98, Win95 modes with and without 'run as administrator' enabled. Forcing 640x480 resolution was the only thing that made a difference - I got a warning about low resolution before it crashed.


< Message edited by addchild314 -- 5/30/2014 11:37:03 PM >
Post #: 1
RE: Fix It - 5/29/2014 6:08:53 AM   
zakblood


Posts: 19337
Joined: 10/4/2012
Status: offline
How to get a DxDiag File

http://www.matrixgames.com/forums/tm.asp?m=2413997

then upload it, so developer, site staff can check for errors in full log.

quote"Forcing 640x480 resolution was the only thing that made a difference - I got a warning about low resolution before it crashed." end quote means nothing to me but may ring bells for them with more info from above file etc....

matter of interest, what size are you using? resolution, color depth etc, the more info you give them the better and more accurate they will give as an answer, as above maybe isn't enough.

what they may ask, what anti virus are you running etc, which driver version for your card, single or dual card, one or 2 screens etc etc

searching the error code myself only gives this answer,

this error means nothing more than that the ActiveX control isn't installed or working on that machine, so reinstalling or repairing the program will or should fix this.

ActiveX controls are small programs, sometimes also called "add-ons,” that are used on the Internet. They can enhance your browsing experience by allowing animation or they can help with tasks such as installing security updates at Microsoft Update.
Some Web sites require you to install ActiveX controls to see the site or perform certain tasks on it. When you visit such a site, Internet Explorer asks if you want to install the ActiveX control.
You should only install ActiveX controls if you have information about the Web site that offers the control and the publisher that created the control
Active X Installer service on the computer should be started, then on Internet Explorer you will get a pop-up that will allow to install this add-on. Follow the steps to start the service.
1. Click Start.
2. Type Services in Start Search.
3. Right click on Active X installer.
4. Click Properties.
5. Set the Startup type to Manual.
6. Click on Start, click OK.
With Windows 7, the ActiveX Installer Service is also used when a user is logged in as a member of the Administrators group. This helps ensure that all users are aware of requests to install ActiveX controls when they visit a Web site that is not part of the Trusted sites zone.

so this to me, at first glance may mean you don't have IE fully installed or working correctly, but maybe wrong, it won't be the first time tbh

< Message edited by zakblood -- 5/29/2014 7:18:27 AM >

(in reply to addchild314)
Post #: 2
RE: Fix It - 5/29/2014 6:18:00 AM   
Spidey


Posts: 399
Joined: 12/8/2013
Status: offline
To me this looks less like a game problem and more like a C# problem. What I'd do in your situation is to check out your redist library inside the game folder and try running DXSETUP.exe, dotNetFx40_Full_x86_x64.exe, and xnafx40_redist.msi. I won't promise that it helps but I'm pretty sure that should install the additional libraries that the game relies upon to run.

(in reply to addchild314)
Post #: 3
RE: Fix It - 5/29/2014 6:20:18 AM   
zakblood


Posts: 19337
Joined: 10/4/2012
Status: offline
must agree with Spidey also on info given, with more info, a better or different one may be right also, but it's not alot to go on either tbh, so is just an informed guess atm

line in question is the first one,

System.Runtime.InteropServices.COMException (0x80040154): Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))

google it, and check answers, it doesn't seem to be game related, more of a system error, a general one with either missing or disabled parts, as the game needs some of these to work correctly, if you don't have them, it throws a random error when asked for it....

but still think the answer given by Spidey above will help more than mine, just going by info given..

< Message edited by zakblood -- 5/29/2014 7:27:25 AM >

(in reply to Spidey)
Post #: 4
RE: Fix It - 5/29/2014 8:33:15 AM   
elliotg


Posts: 3231
Joined: 9/10/2007
Status: offline
Hi addchild314

You are missing either Windows Media Player or Internet Explorer. Both of these must be installed and enabled.

You can check this at Control Panel > Programs and Features > Turn Windows features on or off

Thanks
Elliot

(in reply to addchild314)
Post #: 5
RE: Fix It - 5/29/2014 1:35:49 PM   
Rahal


Posts: 34
Joined: 5/25/2014
Status: offline
Your computer is messed up.

(in reply to elliotg)
Post #: 6
RE: Fix It - 5/29/2014 1:39:56 PM   
Greedo37

 

Posts: 5
Joined: 5/25/2014
Status: offline
Just curious, why would wmp or IE be required to play distant worlds? Or why would you make it a requirement as a developer ?

(in reply to Rahal)
Post #: 7
RE: Fix It - 5/29/2014 1:52:13 PM   
zakblood


Posts: 19337
Joined: 10/4/2012
Status: offline
as it use part of these in design, same as many games, instead of redesigning the wheel yourself use what already out there, saves time and money and makes business sense tbh

(in reply to Greedo37)
Post #: 8
RE: Fix It - 5/29/2014 1:58:59 PM   
Spidey


Posts: 399
Joined: 12/8/2013
Status: offline
It's an XNA Game Studios 4 thing, I believe. Would it really surprise you if MS hijacked capabilities for its game tools thing from other Windows components?

(in reply to Greedo37)
Post #: 9
RE: Fix It - 5/30/2014 3:11:52 AM   
addchild314

 

Posts: 3
Joined: 5/29/2014
Status: offline
Not sure how it could be broken; I installed this copy of Win7 on Saturday because Tropico 5 wouldn't run on Win8. I've installed, uninstalled, reinstalled, and repaired every redist that ships with the game. Let me look into WMP/IE... I probably did remove them; I usually do, as I consider them more of a liability than anything...

I really don't like that the framework relies on IE and WMP. That seems... wrong, somehow. Very wrong.

(in reply to Spidey)
Post #: 10
RE: Fix It - 5/30/2014 4:20:57 AM   
zakblood


Posts: 19337
Joined: 10/4/2012
Status: offline
then a very high percentage of modern games wouldn't work on your machine without it then, as more use it than don't, thats why it's in almost every downloaded and boxed version of a game, cd /dvd / download, they all seem to come with it now days, thats just life in windows now days, you could always try linux or mac, but even going down those paths will lead you back to the same thing, if they emulate it, they will still need the other stuff as well for games to work.

(in reply to addchild314)
Post #: 11
RE: Fix It - 5/30/2014 5:22:47 AM   
OzoneGrif

 

Posts: 132
Joined: 12/2/2010
Status: offline
Quite a few software won't work correctly without WMP or IE installed sadly.

DW is one of them.

(in reply to zakblood)
Post #: 12
RE: Fix It - 5/30/2014 9:05:55 PM   
addchild314

 

Posts: 3
Joined: 5/29/2014
Status: offline
I actually haven't had issue with any other games/software, though admittedly I haven't tested very many on the new installation. But when I checked, IE and WMP were both installed & working. On a whim I removed them both, deleted DW, restarted, reinstalled, restarted, reinstalled DW... and like magic, it worked. IDK, maybe one of the 300 windows updates I just installed went pear shaped and screwed something up.

Whatever the reason, it works now.

Thanks for the help, and I apologize for blaming the devs. This certainly wasn't a QA problem.

(in reply to addchild314)
Post #: 13
RE: Fix It - 10/17/2017 4:06:56 PM   
davidofga

 

Posts: 20
Joined: 4/20/2013
Status: offline
Hard to tell in Windows 10 if media player 12 is actually installed. Something called direct play is installed. and IE !! seems to be installed. DWU worked fine until the latest updates from MS. If I delete direct play, how do I reinstall it?

(in reply to addchild314)
Post #: 14
RE: Fix It - 10/17/2017 4:15:50 PM   
davidofga

 

Posts: 20
Joined: 4/20/2013
Status: offline
Is direct play the new version of media player?

(in reply to Rahal)
Post #: 15
RE: Fix It - 10/17/2017 4:27:54 PM   
zakblood


Posts: 19337
Joined: 10/4/2012
Status: offline
no,, it's the part of (i'll link you)

DirectPlay is a deprecated API that was part of Microsoft's DirectX API. DirectPlay is a network communication library intended for computer game development, although its general nature allows it to be used for other purposes.

https://en.wikipedia.org/wiki/DirectPlay


grove music is the windows 10 default player

but also does come with windows 12 media player

but i use the 5K player as my default, and upto yet i've not had any compatibility issue, as all the others are still installed, so anything that needs lets say windows media player, still works, as it's there, even if it's not my default media player





Attachment (1)

< Message edited by zakblood -- 10/17/2017 4:32:46 PM >

(in reply to davidofga)
Post #: 16
RE: Fix It - 10/17/2017 4:34:00 PM   
zakblood


Posts: 19337
Joined: 10/4/2012
Status: offline

quote:

ORIGINAL: davidofga

Hard to tell in Windows 10 if media player 12 is actually installed. Something called direct play is installed. and IE !! seems to be installed. DWU worked fine until the latest updates from MS. If I delete direct play, how do I reinstall it?


uninstall is one thing, installing it back is simple






Attachment (1)

(in reply to davidofga)
Post #: 17
RE: Fix It - 10/17/2017 5:55:04 PM   
davidofga

 

Posts: 20
Joined: 4/20/2013
Status: offline
javascript:void(powin('post.asp?do=reply&messageID=4361958&toStyle=tm'))

My version of defaults apps under Music has:
Groove Music
RealPlayer
VLC Media Player
I-Tunes

Nothing else

(in reply to zakblood)
Post #: 18
RE: Fix It - 10/17/2017 6:21:34 PM   
davidofga

 

Posts: 20
Joined: 4/20/2013
Status: offline
Once I figured out how to reinstall Windows Media Player all is well. Problem solved. Somehow in the flurry of updates of late WMP got deleted. Thanks for your help!

(in reply to davidofga)
Post #: 19
RE: Fix It - 10/17/2017 6:22:05 PM   
zakblood


Posts: 19337
Joined: 10/4/2012
Status: offline
glad your sorted, enjoy the game

(in reply to davidofga)
Post #: 20
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> [Fixed] Fix It Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.133