Matrix Games Forums

Battle Academy Mega Pack releases on SteamDeal of the Week Da Vinci's Art of WarCivil War II Patch 1.4 public BetaHappy Easter!Battle Academy is now available on SteamPlayers compare Ageods Civil War to Civil War IIDeal of the week - An updated War in the East goes half Price!Sign up for the Qvadriga beta for iPad and Android!Come and say hi at Pax and SaluteLegends of War goes on sale!
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Always ctd after setup

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Conflict of Heroes Series >> Tech Support >> Always ctd after setup Page: [1]
Login
Message << Older Topic   Newer Topic >>
Always ctd after setup - 11/13/2013 5:57:57 PM   
hafer


Posts: 253
Joined: 8/28/2010
Status: offline
I tried it several times, but i always get this error. I bought the game at release and had no probs. But i canceled playing it after the latest patch. what a pity!

Win7, latest drivers..


Post #: 1
RE: Always ctd after setup - 11/14/2013 1:28:14 AM   
rosseau

 

Posts: 968
Joined: 9/13/2009
Status: offline
Go to the bottom of this thread for a hotfix:

http://www.matrixgames.com/forums/tm.asp?m=3275689




< Message edited by rosseau -- 11/14/2013 2:32:57 AM >

(in reply to hafer)
Post #: 2
RE: Always ctd after setup - 11/14/2013 3:33:20 PM   
hafer


Posts: 253
Joined: 8/28/2010
Status: offline
I applied the fix at the day it was released. It has nothing to do with that. But thanx.

It's a shame that i cant get it running!

(in reply to rosseau)
Post #: 3
RE: Always ctd after setup - 11/16/2013 11:10:14 AM   
happyloaf

 

Posts: 24
Joined: 11/14/2013
Status: offline
Can you switch your PC to english and post the error message? I think it is similar to the same problem I am having. I cannot get Matrix to issue a refund. It has been a week and we have tried everything to get it working. Does your explorer.exe crash as well?

(in reply to hafer)
Post #: 4
RE: Always ctd after setup - 11/16/2013 4:59:20 PM   
Panman


Posts: 106
Joined: 8/1/2008
Status: offline
@hafer,

What scenario are you playing when you get this message?

(in reply to happyloaf)
Post #: 5
RE: Always ctd after setup - 11/16/2013 9:43:00 PM   
happyloaf

 

Posts: 24
Joined: 11/14/2013
Status: offline
I had a similar message on scenario 3 (general something) when playing as the Russians. The scenario will not load. As the germans, the scenarios works perfectly?

(in reply to Panman)
Post #: 6
RE: Always ctd after setup - 11/16/2013 11:32:01 PM   
Panman


Posts: 106
Joined: 8/1/2008
Status: offline
Hmmm ... just tried it and had no issues with either side. Did you install the hotfix? What system options do you have selected for your video settings?

I'm running Windows 7 and since installing the hotfix everything seems to be running just fine.

(in reply to happyloaf)
Post #: 7
RE: Always ctd after setup - 11/17/2013 1:05:09 AM   
hafer


Posts: 253
Joined: 8/28/2010
Status: offline

quote:

ORIGINAL: Panman

@hafer,

What scenario are you playing when you get this message?


"Nutcracker" was the last one where it happened..

(in reply to Panman)
Post #: 8
RE: Always ctd after setup - 11/17/2013 1:14:35 AM   
hafer


Posts: 253
Joined: 8/28/2010
Status: offline

quote:

ORIGINAL: happyloaf

Can you switch your PC to english and post the error message? I think it is similar to the same problem I am having. I cannot get Matrix to issue a refund. It has been a week and we have tried everything to get it working. Does your explorer.exe crash as well?


Well, most of the message is in english. Only in the first line it said "there is not enough memory to continue program."

(in reply to happyloaf)
Post #: 9
RE: Always ctd after setup - 11/17/2013 1:21:56 AM   
Panman


Posts: 106
Joined: 8/1/2008
Status: offline
Hmmm ... just tried both sides and no issues starting the scenario. What system options do you have selected for your video settings?

(in reply to hafer)
Post #: 10
RE: Always ctd after setup - 11/17/2013 1:41:15 AM   
happyloaf

 

Posts: 24
Joined: 11/14/2013
Status: offline
I was at 1080p w/ the board game map. Highest settings. My video card is an HD7970 on an I3-2120 w/ 8 gig ram. So hopefully it isn't a video card problem. I found the game to buggy to be playable since I could hardly load it/run it/go 1 turn w/o it crashing.

(in reply to Panman)
Post #: 11
RE: Always ctd after setup - 11/17/2013 2:03:32 AM   
Panman


Posts: 106
Joined: 8/1/2008
Status: offline
Have you checked your video drivers and have you applied the hot fix? I'm running with virtually the same specs and settings and after applying the hotfix haven't had an issue with the crashing.

Where do you have the game installed? Have you tried running it with administrator privileges?

(in reply to happyloaf)
Post #: 12
RE: Always ctd after setup - 11/17/2013 8:23:28 AM   
hafer


Posts: 253
Joined: 8/28/2010
Status: offline
1920x1200, GTX580, newest drivers. 16gb RAM, 2600k - everything up2date

I never had probs with conflict of heroes, only since the latest update...

< Message edited by hafer -- 11/17/2013 9:24:05 AM >

(in reply to Panman)
Post #: 13
RE: Always ctd after setup - 11/17/2013 3:12:31 PM   
Panman


Posts: 106
Joined: 8/1/2008
Status: offline
Odd ... we all have similar specs and I'm able to run it fine. I hate issues like these ... so hard to track down.

Only other thing I can think of is to take all video settings back to basic and keep adding detail settings until you hit the breaking point ... and that only applies if you are running out of the video memory. Unless the installs/patches corrupted in some way.

Maybe try an XNA repair?


(in reply to hafer)
Post #: 14
RE: Always ctd after setup - 11/17/2013 11:33:33 PM   
happyloaf

 

Posts: 24
Joined: 11/14/2013
Status: offline
For me it is even a loading the game thing. I have tried repairing XNA and that sometimes gets the game to run when I install it but not always. Sometimes when I install it will load and some scenarios crash other times it won't load at all.

I have the latest beta AMD video drivers as well. I applied the hotfix and still have the issue.

I did notice that the Ghost Panzer expansion when I click on it takes 1-2 min to respond. Even if I redownload it it still takes the install 1-2 min to load it also makes hexgame.exe not respond when right clicking (like trying to get it to run in admin mode).

(in reply to Panman)
Post #: 15
RE: Always ctd after setup - 11/18/2013 12:54:36 PM   
ericbabe


Posts: 10471
Joined: 3/23/2005
Status: offline
That looks like an out-of-memory error and probably one that pertains to allocating on your video card. I would recommend trying to run the program with lower settings -- such as with low-resolution models, or by turning down some of the settings in the Preferences menu. Make sure there are no other applications running when you start the game, especially anything that could be allocating video memory. If you have dual monitors, trying turning this off before you play. Finally, try running the game at a lower resolution by lowering your desktop resolution.

_____________________________


(in reply to happyloaf)
Post #: 16
RE: Always ctd after setup - 11/22/2013 7:21:37 AM   
hafer


Posts: 253
Joined: 8/28/2010
Status: offline

quote:

ORIGINAL: ericbabe

That looks like an out-of-memory error and probably one that pertains to allocating on your video card. I would recommend trying to run the program with lower settings -- such as with low-resolution models, or by turning down some of the settings in the Preferences menu. Make sure there are no other applications running when you start the game, especially anything that could be allocating video memory. If you have dual monitors, trying turning this off before you play. Finally, try running the game at a lower resolution by lowering your desktop resolution.


Thanx Eric, but i'm running a GTX580 with 3 gigs - its not a hardware problem. And before the last patch it works with highest settings in every scenario.. strange?!

(in reply to ericbabe)
Post #: 17
RE: Always ctd after setup - 11/22/2013 2:54:57 PM   
Gerry Edwards


Posts: 103
Joined: 2/22/2013
Status: offline
Hi Hafer,

It could still be a kinda of hardware problem. You may be experiencing a video memory leak. It is not uncommon and can go unnoticed for a very long time. I would recommend turning your video setting down and seeing if it still crashes at the same point. If it does the chances of a memory leak are significantly lower. I understand your belief that it isn't the hardware as i have been in your situation with a Geforce GTX 770 2gb card. Let us know how that goes so we can further assist you.

Cheers,
Gerry

_____________________________

Those who came before pave the path of tomorrow.

(in reply to hafer)
Post #: 18
RE: Always ctd after setup - 11/22/2013 3:19:14 PM   
ericbabe


Posts: 10471
Joined: 3/23/2005
Status: offline
The only thing that really changed from the original release to the patched version / SOS version is that we added new map features and more units which may might cause the game to make more use of video memory. Your GTX580 should be enough to run the game even with these changes, but if you've got some other application running that allocates video memory, or if you're running in dual-monitor mode, then there might be some problem with video memory.

_____________________________


(in reply to Gerry Edwards)
Post #: 19
RE: Always ctd after setup - 11/22/2013 10:55:35 PM   
hafer


Posts: 253
Joined: 8/28/2010
Status: offline
I did a reinstall and got the same crash.

I completely lowered the graphic settings (which is a joke - gtx580) and got the same crash.


It only happend with only a few scenarios....

(in reply to ericbabe)
Post #: 20
RE: Always ctd after setup - 11/25/2013 3:27:53 PM   
ericbabe


Posts: 10471
Joined: 3/23/2005
Status: offline
Do you happen to know whether it the same error each time -- in PiecePrototype.MakePiece?

I have a GTX video card with 2GB, and when I'm running in dual monitor mode with high resolution units I also get the same out of memory error you are seeing when I run certain scenarios. So it's possible to run out of video memory even with a high-end GTX card, especially if you're running in a configuration (such as with more than one monitor or with other applications in the background) that are allocating chunks of video memory.

Your first post says you always get this error, but your last post mentioned that it only happens with a few scenarios. Do you have a list of the scenarios that are causing this problem?

_____________________________


(in reply to hafer)
Post #: 21
RE: Always ctd after setup - 12/5/2013 2:29:11 PM   
hafer


Posts: 253
Joined: 8/28/2010
Status: offline

quote:

ORIGINAL: ericbabe

Do you happen to know whether it the same error each time -- in PiecePrototype.MakePiece?

I have a GTX video card with 2GB, and when I'm running in dual monitor mode with high resolution units I also get the same out of memory error you are seeing when I run certain scenarios. So it's possible to run out of video memory even with a high-end GTX card, especially if you're running in a configuration (such as with more than one monitor or with other applications in the background) that are allocating chunks of video memory.

Your first post says you always get this error, but your last post mentioned that it only happens with a few scenarios. Do you have a list of the scenarios that are causing this problem?


I' ve just one monitor and didn't activate any of those graphic-card settings.
I've 3 gig of video memory so i cant (at best will) believe that it has something to do with that hardware (i can play high end shooter-games..)
Sorry, i always get the error when playing nutcracker, most of the other scenarios run fine...

(in reply to ericbabe)
Post #: 22
RE: Always ctd after setup - 12/12/2013 5:05:37 PM   
ericbabe


Posts: 10471
Joined: 3/23/2005
Status: offline
It is somewhat of a common misconception that 3D objects must take up more memory than 2D objects, so players who run big shooter games assume that those shooter games must make large demands on their video cards because they have many 3D objects. However, 3D objects can make a relatively compact use of memory compared to 2D objects -- for instance, it may be surprising but one of our 3,000 polygon tanks at the low texture settings actually takes up less memory on the video card than the corresponding 2D chit. So it is quite possible in general to have out-of-memory issues even when the video card is not tracking millions of polygons.

It's also possible to get out-of-memory errors when there is still memory left to be allocated on a device. An out-of-memory error occurs after a time-out interval if the device fails to return the requested memory fast enough. This may be happening in your situation, and it may be related to the refresh on the billboard graphics -- the stalks of wheat or similar -- as they go in-and-out of fog-of-war. The refresh of these items on the video card may be happening faster than the card can fulfill the refresh requests. Perhaps try playing "Nutcracker" with the scenery density turned down in the Preferences screen and see whether that helps. If this does help -- if my suspicions are correct -- I'll check the XNA blogs to see whether there is anything I can have the code do to handle this error-situation more gracefully.

_____________________________


(in reply to hafer)
Post #: 23
RE: Always ctd after setup - 1/23/2014 1:07:18 AM   
jack54


Posts: 534
Joined: 7/18/2007
From: East Tennessee
Status: offline
quote:

ORIGINAL: hafer

I' ve just one monitor and didn't activate any of those graphic-card settings.
I've 3 gig of video memory so i cant (at best will) believe that it has something to do with that hardware (i can play high end shooter-games..)
Sorry, i always get the error when playing nutcracker, most of the other scenarios run fine...


Eric just thought I'd let you know I also get the same error when starting 'Nutcracker'...
GeForce 650 1gig...16GB ram... Windows 8.1





Attachment (1)

< Message edited by jack54 -- 1/23/2014 2:54:06 AM >


_____________________________

mostly playing
Flashpoint Campaigns:Red Storm, Piercing Fortress Europa, RUS, Qvadriga, Drums of War


Avatar counter from 'Flashpoint Campaigns: Red Storm'

(in reply to hafer)
Post #: 24
RE: Always ctd after setup - 2/12/2014 3:46:33 PM   
ericbabe


Posts: 10471
Joined: 3/23/2005
Status: offline
Thanks for the post of the popup. That looks like a straight-up out-of-video-memory error. I can load Nutcracker on our machine with a 1GB video card, so there must be some difference in the way that Windows is grabbing some of this memory for itself on our different machines. Have you been able to solve this by reducing some of the graphics settings?

_____________________________


(in reply to jack54)
Post #: 25
RE: Always ctd after setup - 2/13/2014 2:06:31 AM   
jack54


Posts: 534
Joined: 7/18/2007
From: East Tennessee
Status: offline
sorry but no difference... The thing is it crashes with same pop-up at the same time. Immediately after setup before turn 1.

Western Approach plays but crashes before final score display... this is an inability to write to folder error yet all other scenarios display the score fine
I'm running as Administrator in 8.1.


Thanks for any help Eric... I really like the game and would LOVE to add SOS to the mix but I'm concerned about more crashing.

Thanks and all the BEST!

Jack

< Message edited by jack54 -- 2/13/2014 3:48:20 AM >


_____________________________

mostly playing
Flashpoint Campaigns:Red Storm, Piercing Fortress Europa, RUS, Qvadriga, Drums of War


Avatar counter from 'Flashpoint Campaigns: Red Storm'

(in reply to ericbabe)
Post #: 26
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Conflict of Heroes Series >> Tech Support >> Always ctd after setup Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.102