Matrix Games Forums

Civil War II Patch 1.4 public BetaHappy Easter!Battle Academy is now available on SteamPlayers compare Ageods Civil War to Civil War IIDeal of the week - An updated War in the East goes half Price!Sign up for the Qvadriga beta for iPad and Android!Come and say hi at Pax and SaluteLegends of War goes on sale!Piercing Fortress Europa Gets UpdatedBattle Academy Mega Pack is now available
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Ground battle bugs + a few other things

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Ground battle bugs + a few other things Page: [1]
Login
Message << Older Topic   Newer Topic >>
Ground battle bugs + a few other things - 9/20/2013 4:35:14 PM   
Strat_84

 

Posts: 72
Joined: 12/8/2011
Status: offline
1°) I was about to invade a planet held by the Shakturi, my transports reached the planet and started dropping my troops. But meanwhile the Guardians had started to bombard the planet.
The last civilians died during the drop operation, half of my troops went "undead" on that planet: can't see them on the planet, but still listed in the troop summary with a "red cross" icon + an error message when clicking on one of them (see screenshot).
Colonizing the planet again made the error message disapear, but no way to get back my troops (which are supposed to be dead I guess anyway).


Attachment (1)

< Message edited by Strat_84 -- 9/20/2013 4:38:35 PM >
Post #: 1
RE: Ground battle bugs + a few other things - 9/20/2013 4:36:52 PM   
Strat_84

 

Posts: 72
Joined: 12/8/2011
Status: offline

2°) Defending a planet against the shakturi. I send a transport fleet with my surviving troops to help. I didn't follow exactly what happened but I think they started dropping troops just when the battle was being lost. Result: my infantry was still in the transports, my special forces had JOINED THE SHAKTURI.
They were still listed as mine in the troop summary, I was still paying maintenance for them, but when I tried to take back the planet they remained on the enemy side (see screenshot)

When I finally recaptured the planet, these special forces were still in my troop summary, but nowhere on the planet.

Attachment (1)

(in reply to Strat_84)
Post #: 2
RE: Ground battle bugs + a few other things - 9/20/2013 4:47:46 PM   
Strat_84

 

Posts: 72
Joined: 12/8/2011
Status: offline
3°) Hyperdeny components seem to be broken on space stations. I had GW1000 components on all my defence stations but I have never seen one functioning.

4°) I noticed the Nuclear Exterminator cannot attack ships in Shadows, while it did in Legends. I don't know if this is a bug or a deliberate choice but that removes nearly all the interest in researching that weapon, the first bombard weapon you can have does the same job while being much smaller and less power hungry.

(in reply to Strat_84)
Post #: 3
RE: Ground battle bugs + a few other things - 9/21/2013 5:23:14 AM   
mSterian

 

Posts: 154
Joined: 7/25/2013
Status: offline
Yup. As I previously stated, Shadows is bugged as hell.
At least they're still rolling out patchs. x.12 should be coming early October I think.

(in reply to Strat_84)
Post #: 4
RE: Ground battle bugs + a few other things - 12/1/2013 9:07:58 PM   
elliotg


Posts: 3033
Joined: 9/10/2007
Status: offline
quote:

ORIGINAL: Strat_84
1°) I was about to invade a planet held by the Shakturi, my transports reached the planet and started dropping my troops. But meanwhile the Guardians had started to bombard the planet.
The last civilians died during the drop operation, half of my troops went "undead" on that planet: can't see them on the planet, but still listed in the troop summary with a "red cross" icon + an error message when clicking on one of them (see screenshot).
Colonizing the planet again made the error message disapear, but no way to get back my troops (which are supposed to be dead I guess anyway).

Thanks for the report. This is fixed in the next update.

Elliot

(in reply to Strat_84)
Post #: 5
RE: Ground battle bugs + a few other things - 12/1/2013 9:08:19 PM   
elliotg


Posts: 3033
Joined: 9/10/2007
Status: offline
quote:

ORIGINAL: Strat_84
2°) Defending a planet against the shakturi. I send a transport fleet with my surviving troops to help. I didn't follow exactly what happened but I think they started dropping troops just when the battle was being lost. Result: my infantry was still in the transports, my special forces had JOINED THE SHAKTURI.
They were still listed as mine in the troop summary, I was still paying maintenance for them, but when I tried to take back the planet they remained on the enemy side (see screenshot)

When I finally recaptured the planet, these special forces were still in my troop summary, but nowhere on the planet.

This is fixed in the next update

Elliot

(in reply to Strat_84)
Post #: 6
RE: Ground battle bugs + a few other things - 12/1/2013 9:08:57 PM   
elliotg


Posts: 3033
Joined: 9/10/2007
Status: offline
quote:

ORIGINAL: Strat_84
3°) Hyperdeny components seem to be broken on space stations. I had GW1000 components on all my defence stations but I have never seen one functioning.

This is fixed in the next update.

quote:


4°) I noticed the Nuclear Exterminator cannot attack ships in Shadows, while it did in Legends. I don't know if this is a bug or a deliberate choice but that removes nearly all the interest in researching that weapon, the first bombard weapon you can have does the same job while being much smaller and less power hungry.

This change in Shadows is by design.

Thanks
Elliot

(in reply to Strat_84)
Post #: 7
RE: Ground battle bugs + a few other things - 12/4/2013 2:54:44 PM   
Strat_84

 

Posts: 72
Joined: 12/8/2011
Status: offline
quote:

ORIGINAL: elliotg
quote:


4°) I noticed the Nuclear Exterminator cannot attack ships in Shadows, while it did in Legends. I don't know if this is a bug or a deliberate choice but that removes nearly all the interest in researching that weapon, the first bombard weapon you can have does the same job while being much smaller and less power hungry.

This change in Shadows is by design.

Thanks
Elliot


Thanks for the answers.

About that particular subject, I think you may consider modifying the design then.

When two weapons are meant for the same use, on the same research branch, one being higher tech than the other one, that one necessarily needs an improvement compared to the first one (that "bonus" used to be the ability to be used against ships at close range).
Otherwise, it's not worth researching it.

(in reply to elliotg)
Post #: 8
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Ground battle bugs + a few other things Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.068