Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: Windows 8 running really slow

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> RE: Windows 8 running really slow Page: <<   < prev  1 [2]
Login
Message << Older Topic   Newer Topic >>
RE: Windows 8 running really slow - 4/9/2015 12:16:20 AM   
witpqs


Posts: 16528
Joined: 10/4/2004
From: Argleton
Status: online

quote:

ORIGINAL: rizzle2830

I also tried every possible combination with "-cpu#" etc. I tried windowed mode and that made it run normal, but regardless of what resolution you use, windowed mode really sucks. Desperate, I tried some of the other commands on the list and found an unlikely solution: -dd_sw -deepColor -px1600 -py800

The resolution change isn't what did it, but as soon as I added "-deepColor" the game went to normal speeds. I didn't think it would have such an impact, but for some reason simply setting the game to 32 colors made it run faster, even though my PC specs FAR exceed the system requirements. It seems like WITP just isn't windows 8 friendly. There are still points where it chugs, but 90% of the time it runs like normal.

Did you try -SingleCpuOrders when you had it in windowed mode?

_____________________________


(in reply to rizzle2830)
Post #: 31
RE: Windows 8 running really slow - 4/11/2015 5:41:22 PM   
geofflambert


Posts: 6632
Joined: 12/23/2010
From: St. Louis
Status: offline

quote:

ORIGINAL: zuluhour


-dd_swf (try putting the f in.)


-dd_swf: Looking for double dudes for a single white female? Or is it Two dudes looking for single white female?

(in reply to zuluhour)
Post #: 32
RE: Windows 8 running really slow - 4/11/2015 5:48:19 PM   
geofflambert


Posts: 6632
Joined: 12/23/2010
From: St. Louis
Status: offline

quote:

ORIGINAL: geofflambert


quote:

ORIGINAL: zuluhour


-dd_swf (try putting the f in.)





Do or do not. There is no try.




Attachment (1)

(in reply to geofflambert)
Post #: 33
RE: Windows 8 running really slow - 6/29/2015 6:21:07 PM   
Willderyes

 

Posts: 7
Joined: 6/15/2015
Status: offline
I would like to make you I know what ya'll are talking about. Seems like a lot of the problems being discussed are display delays. What is slow for me is when I click for "next fleet" or "next port" I have to wait a painful 5 to 10 seconds for the computer to catch up. Sometimes I hit the next button again thinking I missed it the first time, then there is even more delay.

< Message edited by Willderyes -- 6/29/2015 7:22:06 PM >

(in reply to witpqs)
Post #: 34
RE: Windows 8 running really slow - 6/29/2015 6:56:30 PM   
witpqs


Posts: 16528
Joined: 10/4/2004
From: Argleton
Status: online
Here are two of the switches I use on Windows 8/8.1; these might make a difference during the orders phase.

quote:


-deepColor -SingleCpuOrders


_____________________________


(in reply to Willderyes)
Post #: 35
RE: Windows 8 running really slow - 6/30/2015 2:08:00 AM   
wdolson

 

Posts: 9221
Joined: 6/28/2006
From: Near Portland, OR
Status: offline
It's a multiple processor core problem with DirectX. There are many command line switches that help this because each computer is a bit different. The switches are not supported by the version of the game that comes with the basic install. You need to upgrade to the first patch at minimum. I recommend upgrading to the most recent patch, if you haven't upgraded yet.

Bill

_____________________________

WitP AE - Test team lead, programmer

(in reply to witpqs)
Post #: 36
RE: Windows 8 running really slow - 7/19/2015 1:03:08 AM   
mullk

 

Posts: 549
Joined: 4/3/2003
From: Ohio
Status: offline
All my issues with Windows 8.1 were fixed by the -deepColor switch. It must be entered exactly as shown with the small "d" and capital "C". That fixed my speed issue as well as several graphic glitches that occurred plus horrible key lag. I didn't see anyone saying to try this and it was the only thing that worked for me

_____________________________


(in reply to wdolson)
Post #: 37
Page:   <<   < prev  1 [2]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> RE: Windows 8 running really slow Page: <<   < prev  1 [2]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.066