Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: Cant start Shadows

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> RE: Cant start Shadows Page: <<   < prev  1 2 3 [4] 5   next >   >>
Login
Message << Older Topic   Newer Topic >>
RE: Cant start Shadows - 5/24/2013 11:17:55 PM   
gwgardner

 

Posts: 4685
Joined: 4/7/2006
Status: offline
quote:

ORIGINAL: Erik Rutins

Hi GwGardner,

Have you already tried the rest of the Tech Support FAQ? When exactly do you get this crash? Is this with a clean installation?

Regards,

- Erik


Tried the support faq but not a clean install. Have run all the others for years. I'll have to find the box for the original install.

I get the crash after 'forming nebulae clouds' appears.

(in reply to Erik Rutins)
Post #: 91
RE: Cant start Shadows - 5/25/2013 1:57:41 AM   
Deomrve

 

Posts: 105
Joined: 9/4/2006
Status: offline
Got home applied the hotfix and now my game crashes 22 seconds into loading, give or take a couple of seconds.

Edit: Did a shadows reinstall and it still doesn't work. I'm really getting tired of doing complete Distant Worlds reinstalls. Hope this gets fixed soon.

< Message edited by Deomrve -- 5/25/2013 3:10:04 AM >

(in reply to gwgardner)
Post #: 92
RE: Cant start Shadows - 5/25/2013 5:21:51 AM   
elliotg


Posts: 3231
Joined: 9/10/2007
Status: offline
quote:

ORIGINAL: gwgardner
Yes, installed XNA from the game installer.

Here's my startup error log:

Distant Worlds - Crash Dump - 1.9.0.0

10:48:00 AM Friday, May 24, 2013


System.NullReferenceException: Object reference not set to an instance of an object.
at DistantWorlds.Types.GraphicsHelper.ScaleLimitImage(Bitmap image, Int32 maxWidth, Int32 maxHeight, Single alpha)
at DistantWorlds.Types.HabitatImageCache.LoadImagesSmall()
at DistantWorlds.Types.HabitatImageCache.Initialize(String applicationStartupPath)
at DistantWorlds.Main.xZLVOJRCpU()
at DistantWorlds.Main.LHMV4MLiKd(Int32 , Int32 , Boolean )
at DistantWorlds.Main..ctor(Int32 width, Int32 height, Boolean windowedMode, Splash splashForm)
at DistantWorlds.Start.wqAsGLaYJv(Object , EventArgs )
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.SetVisibleCore(Boolean value)
at System.Windows.Forms.Control.set_Visible(Boolean value)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at EmhsmAfGsqawTHUV7P.UtyI96UUspX0ueL2Cg.nBHfNLSqHwyxpjahWUl(Object )
at EmhsmAfGsqawTHUV7P.UtyI96UUspX0ueL2Cg.JsVS1aLxjZr()


--- COMPLETE ---

Hi there

Looks like you have an incomplete installation of Distant Worlds.

You are seeing this error because the game cannot find at least some of the images for the planets. These should be in the "images\environment\planets\" folders.

This problem probably occurred with the installation of Distant Worlds original (i.e. the base game), because that's where the planet images come from.

You'll need to reinstall DW original properly, and the subsequent expansions.

Thanks
Elliot

(in reply to gwgardner)
Post #: 93
RE: Cant start Shadows - 5/25/2013 6:28:14 PM   
Deomrve

 

Posts: 105
Joined: 9/4/2006
Status: offline
Got Shadows to work, copied a working version from my laptop to my desktop and it now works. Since this method works I might try the hot fix again since I completely wiped and then reinstalled .net4 and xna from Microsoft's site before the I copied DW.

(in reply to elliotg)
Post #: 94
RE: Cant start Shadows - 5/26/2013 4:02:31 PM   
gwgardner

 

Posts: 4685
Joined: 4/7/2006
Status: offline

quote:

ORIGINAL: elliotg


Hi there

Looks like you have an incomplete installation of Distant Worlds.

You are seeing this error because the game cannot find at least some of the images for the planets. These should be in the "images\environment\planets\" folders.

This problem probably occurred with the installation of Distant Worlds original (i.e. the base game), because that's where the planet images come from.

You'll need to reinstall DW original properly, and the subsequent expansions.

Thanks
Elliot



Thank you. That fixed it.

(in reply to elliotg)
Post #: 95
RE: Cant start Shadows - 5/27/2013 3:09:48 AM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
I am having same problem as the others here.game won't start at all no crash dumps.it does'nt get that far.I reinstalled the game net 4.5 and xna.Still nothing helps.
Any help would be appreciated.Thanks

(in reply to gwgardner)
Post #: 96
RE: Cant start Shadows - 5/27/2013 9:05:12 AM   
Bingeling

 

Posts: 4691
Joined: 8/12/2010
Status: offline
Windows Media Player is activated and working?

(in reply to martgord)
Post #: 97
RE: Cant start Shadows - 5/27/2013 1:56:55 PM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
Yes it is active and working.it looks like the same issue as Athenian reported above

(in reply to Bingeling)
Post #: 98
RE: Cant start Shadows - 5/27/2013 2:24:48 PM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
Sorry for the extra post,but i just installed Shadows on my work computer which is xp sp3 32 bit and it works just fine.My home computer is a win7 64 bit.I thought this info would be helpful.

(in reply to martgord)
Post #: 99
RE: Cant start Shadows - 5/27/2013 2:28:11 PM   
Raap

 

Posts: 403
Joined: 1/12/2011
Status: offline
Yeah, I think generally most startup problems with the game have been related to Win7. That seems to be where the dependency issues occur.

(in reply to martgord)
Post #: 100
RE: Cant start Shadows - 5/27/2013 7:27:54 PM   
rjord

 

Posts: 78
Joined: 5/13/2013
Status: offline
Have people with Windows 7 who are having issues tried running the game in Vista compatibility mode?

Roy

(in reply to Raap)
Post #: 101
RE: Cant start Shadows - 5/28/2013 12:49:45 PM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
Erik,
As imentioned in an earlier post iam having the exact same problem as Athenian.Did you speak to Elliot yet?I would really like to play the game that I payed for last week.
I had no problems playing Legends.Please help

(in reply to Raap)
Post #: 102
RE: Cant start Shadows - 5/28/2013 10:00:19 PM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
I am having same exact problem as you.Did anyone get back to you with a solution,since i have'nt seen a post from you in a few days.Any help[ would be appreciated,as i also can't get the game to start.

(in reply to Athenian)
Post #: 103
RE: Cant start Shadows - 5/28/2013 11:10:40 PM   
Erik Rutins

 

Posts: 33958
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Hi Martgord,

Please go through the Tech Support FAQ first. If that does not help, please upload a DxDiag file and a crash log for us (if there is a crash log).

Please make sure DirectX from the /redist sub-folder of your installation folder is also installed. Please make sure you are logged in as Administrator. Please try running the game as Administrator to see if that makes any difference.

Please confirm which files you used to install the game (file names) so we can make sure you have the right installers.

Regards,

- Erik

_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to martgord)
Post #: 104
RE: Cant start Shadows - 5/28/2013 11:34:17 PM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
I went thru the faq already.I uploaded my dxdiag.I also followed already all the other steps Directx run as administrator etc.My previous Legends install was working fine,but I reinstalled anyway.I used the 1049 setup for distant worlds then the Pl-v15 next and then the v1700.exe for legends.I tested it then and it was working.Finally I used the v1901 for Shadows.Did not work.updated to v1902 still no luck.Hope you can help
Thanks

Attachment (1)

(in reply to Erik Rutins)
Post #: 105
RE: Cant start Shadows - 5/28/2013 11:37:38 PM   
Erik Rutins

 

Posts: 33958
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Thank you Martgord. Did you already check for a crash log? If there is no crash log, can you describe exactly what happens when you try to play Distant Worlds: Shadows? At what point, exactly, does it fail to work for you?

Regarding the files you used, did each of those have "SetupRelease" in the file name?

Regards,

- Erik

_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to martgord)
Post #: 106
RE: Cant start Shadows - 5/28/2013 11:39:05 PM   
Bingeling

 

Posts: 4691
Joined: 8/12/2010
Status: offline
If you installed

...
...
v-1700 Legends
Then
v-1901 Shadows.

You are failing because you have not installed shadows. You need to run the proper, big, shadows installer, not just the patch.

(in reply to martgord)
Post #: 107
RE: Cant start Shadows - 5/29/2013 12:07:55 AM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
There is no crash log and no folder 1901 or 1902 there at all.I only have a folder 1700.I click on the file directly DistantWorlds.EXE and it has a spinning circle for 1-2 seconds then that is it.

Each of the files I installed did have setupRelease in their name.Forgot to specify that,sorry.

Thanks,
Martgord

(in reply to Erik Rutins)
Post #: 108
RE: Cant start Shadows - 5/29/2013 12:51:36 AM   
elliotg


Posts: 3231
Joined: 9/10/2007
Status: offline
Hi martgod

Can you please also check your Windows event log for any messages relating to Distant Worlds? There may be some messages in there indicating missing dependencies that are preventing DW from starting.

Control Panel > Administrative Tools > Event Viewer

The other obvious things to check:
- do you have .Net 4.0 or 4.5 installed
- do you have XNA 4.0 installed
- do you have the 32-bit version of Internet Explorer installed and enabled
- do you have Windows Media Player installed and enabled

Thanks
Elliot

(in reply to martgord)
Post #: 109
RE: Cant start Shadows - 5/29/2013 2:25:17 AM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
Hi Elliot,

Nothing in the event viewer about Distant Worlds.

After runing net cleanup tool I reinstalled both framework 4 and xna 4 from the redist directory of Shadows.I also tried to repair them both a couple
of times.No luck getting shadows to run.

I have both iexplorer 32 bit and Media layer installed and active

Thanks,
Martgord

(in reply to elliotg)
Post #: 110
RE: Cant start Shadows - 5/29/2013 6:00:09 AM   
Athenian

 

Posts: 15
Joined: 5/24/2013
Status: offline
To fix my issue, I resorted to somewhat drastic measures. I did a in place upgrade/repair install of my Windows 7 Pro.

Took a couple of hours, but I retained all my programs, profile data, etc (did not have to reinstall anything). I did have to reactivate Windows.

I can't exactly recommend what I did, but if you have access to the Win 7 install media (or you can download it legit from Microsoft's Digital River service for free) and have a good Win 7 key, its worth a shot. Just a word of warning, you do need the install media that matches with your service pack level (ie Win 7 or Win 7 SP1).

Just run the setup.exe from within Windows, choose upgrade and it will tell you what may not transfer to the new OS install. It was pretty slick actually.

Hope that helps.

(in reply to martgord)
Post #: 111
RE: Cant start Shadows - 5/29/2013 12:03:45 PM   
GGLurch

 

Posts: 3
Joined: 5/29/2013
Status: offline
Hi Everybody,

had the same thing yesterday.

Have Win7 Prof. 64bit freshly installed. Had to install Distant World completely, got Shadows and the game would not start. When starting, I got the little window loading the nebula's and stuff. But the window just popped up for a second. Then nothing. Tried the NET clean-up tool and other stuff mentioned earlier here. Nothing worked.
So I uninstalled the game completely. Checked under CONTROL PANEL - PROGRAMS AND FEATURES that NET and XNA are installed (XNA was installed at the first Shadows installation). After running the NET clean-up tool, Win7 updated my NET installation with the latest patches. I restarted my machine after that and started to install Distant World again - step by step.

1. Original Game - started it - works - update via update button on start window - started it - still works
2. Shakturi - started it - works - update via update button on start window - started it - still works
3. Legends - started it - works - update via update button on start window - started it - still works
4. Shadows - under installation I unchecked NET and XNA installation since i confirmed earlier that it is installed on my machine - Started it - works - update - works! (fantastic add-on btw!)

Under my first installation of Shadows i was asked to "repair" or "reinstall" NET, what i found strange because I'm pretty sure I already had NET installed with the latest updates. Since i was not sure what to do, i chose "repair" and probably messed up my NET installation, because my Win7 update just went berserk with tons of NET patches to install. Maybe that was the problem in my case.

Hope that helps!
Nico

(in reply to Athenian)
Post #: 112
RE: Cant start Shadows - 5/29/2013 3:16:33 PM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
Athenian,

After the install of Win7 how did you install Shadows?When it asked you about installing net4 and xna4 did you do it or did you install them seperately?

Thanks

(in reply to Athenian)
Post #: 113
RE: Cant start Shadows - 5/29/2013 7:08:26 PM   
Athenian

 

Posts: 15
Joined: 5/24/2013
Status: offline
I already had Shadows Installed when I did the Upgrade/Repair install of Win7.

The first thing I did after about 50-60 windows updates was launch Shadows, and it ran just fine.

I didn't have to reinstall anything, for Distant Worlds or anything else for that matter.

Oh, and I did not have to reinstall XNA 4 or .net 4. I already had them installed, but it was the Windows 7 upgrade/repair that fixed the issue I suspect.

(in reply to martgord)
Post #: 114
RE: Cant start Shadows - 5/30/2013 4:28:57 PM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
Erik,
Still trying to get Shadows to run.What I tried now is I reinstalled net framework 4 and xna4 and let windows update anything to do
with net framework 4 both critical and optional updates.I then rebooted and uninstalled Distant Worlds totally.

I reinstalled each part of DW from the setup-release exe and started the program to see if it works.Everything thru Legends worked.I even updated Legends to 1.720 which required net framework 4.When it asked me to install net 4 I unticked the option
because I had it installed already.It worked without any problem

Then I Installed shadows from Setup Release V1901.I also unticked net4 and xna 4 since they are both installed already.Same problem little blue circle spins for a second or two and then nothing.

One thought i had was that when i ran the file I had a popup asking to let it run publisher not known.That did not happen by the
other setup files,they ran straight away,although I did use same file on my work computer xp sp3 and there it runs fine.

Any ideas or do i just give up and get a refund? I have steam and plenty of games installed and never had a problem with any other game.

Thanks,
Martgord

(in reply to Erik Rutins)
Post #: 115
RE: Cant start Shadows - 5/30/2013 5:02:51 PM   
Erik Rutins

 

Posts: 33958
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Hi Martgord,

Frankly, I'm pretty much out of ideas. The issue is clearly system specific and I'm 99% sure that somehow one of the dependencies on your system is messed up. If that were fixed, I'm sure the game itself would work. You've tried everything we could recommend to fix the issue, short of reinstalling Windows. Troubleshooting a problem that deep in Windows is something we're unable to do. Perhaps Microsoft could, but it's beyond us at this point. Since we can't get Shadows working on your system we would be fine with issuing a refund. The only other next step at this point would be to reinstall/repair Windows.

Regards,

- Erik

_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to martgord)
Post #: 116
RE: Cant start Shadows - 5/30/2013 5:56:51 PM   
martgord

 

Posts: 15
Joined: 11/29/2011
Status: offline
Erik,

Thanks for quick reply.I don't feel like reinstaling windows since everything else works.I'll just play Legends I guess.

I would like to get a refund please.How to I go about that?

Thanks,
Martgord

(in reply to Erik Rutins)
Post #: 117
RE: Cant start Shadows - 5/30/2013 7:03:38 PM   
Erik Rutins

 

Posts: 33958
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Hi Martgord,

Please contact our Help Desk. You can point them to my message here where I confirmed that we could not get it working for you and they'll issue a refund.

Regards,

- Erik

_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to martgord)
Post #: 118
RE: Cant start Shadows - 6/21/2013 5:44:47 PM   
Golgri

 

Posts: 7
Joined: 6/15/2013
Status: offline
I reinstalled Windows 8 and tried to install shadow ... legend works bur shadow nothing .... a short time a window apearss.... willlll this be fixed anytime?

(in reply to Erik Rutins)
Post #: 119
RE: Cant start Shadows - 6/24/2013 8:02:24 PM   
GA01

 

Posts: 8
Joined: 6/17/2013
Status: offline
I've had the same problem as the others; I start the game, messages appear such as "creating galaxy", etc... and then -- nothing. It won't start. I went through all the faqs and did the solutions but none worked. I posted my last dump log on the forum about a week ago but had not gotten a reply. I'll do so again here. I bought this expansion when it first came out and it has never worked. At first I did not worry because I have such a back log of games I thought I play other games, wait until a patch fixed things and then play the expansion. Now a month and numerous patches later it still won't start; to be honest I wish I just had saved my money and not purchased it.

Anyway here is my crash dump:

System.Runtime.InteropServices.COMException (0xC00D0FEB): Exception from HRESULT: 0xC00D0FEB
at WMPLib.IWMPPlayer4.set_uiMode(String pbstrMode)
at AxWMPLib.AxWindowsMediaPlayer.set_uiMode(String value)
at DistantWorlds.Start.FfUJ3oFN8ej7hwUT53e(Object , Object )
at DistantWorlds.Start.mcPyNVTBC5(String[] )
at DistantWorlds.Start.tBCA251kDe(Object , EventArgs )
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.SetVisibleCore(Boolean value)
at System.Windows.Forms.Control.set_Visible(Boolean value)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at W4tyRa7AfEsLyEUpBq.yOo6YVkBLSPx8OiQ4D.sIHXregjg44mFZw0cqK(Object )
at W4tyRa7AfEsLyEUpBq.yOo6YVkBLSPx8OiQ4D.FJ8bFfEbIKk()


--- COMPLETE ---

(in reply to Golgri)
Post #: 120
Page:   <<   < prev  1 2 3 [4] 5   next >   >>
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> RE: Cant start Shadows Page: <<   < prev  1 2 3 [4] 5   next >   >>
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.156