Matrix Games Forums

Command gets Wargame of the Year EditionDeal of the Week: Pandora SeriesPandora: Eclipse of Nashira is now availableDistant Worlds Gets another updateHell is Approaching Deal of the Week Battle Academy Battle Academy 2 Out now!Legions of Steel ready for betaBattle Academy 2 gets trailers and Steam page!Deal of the Week Germany at War
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

What do I need to play latest version

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command Ops Series >> What do I need to play latest version Page: [1]
Login
Message << Older Topic   Newer Topic >>
What do I need to play latest version - 3/25/2013 4:17:20 PM   
PokerWolf


Posts: 17
Joined: 3/25/2013
From: Canada
Status: offline
Hi been searching for a rts operational warfare game and happened upon this site. Tried the demo and Im in love.

Cant believe these forums are not humming with activity ands that there are not a hundred fan pages. Anyways I wanted to just get the main game for now but was wondering can I use the beta patches and with those will I get access to all the changes made to the game that would effect scenarios in this version of the game or do I have to get the expansion for whatever enhancements it brings to the game as a whole? Basically I don't want to buy the core game learn the nuances of the system to then get the expansion and have to adjust to whatever changes it makes to the system. Any advice would be great. I just want to play the botb scenarious with all the enhancements and fixes made to the engine.

I would love to see this brought to the ipad. To be hones though 80 is a bit steep for ios customers. I would pay it but many think now that games should be 1- 5 dollars on ios devices; they forget that yes most of the games for ios are cheap but are simple games and that real games with substance cost a great deal of money to make. I have no problem paying premium prices for a complex wargame. As battle Academy showed people are willing to pay 20. Anways would love to see this brought to an ipad.

Throw on some flashy icons to lure new players who may be more forgiving of the complexity if they can see their armies move and look good. Maybe some miniature army (show some tank units and soldiers moving together etc) can be animated to represent each unit with info bars underneath. Im happy with the icons but the looks of the game can scare off some people. More multiplayer options needed. Can you imagine 5 on 5 player games coordinating attacks with your teammates. Nightmare or Heaven depending on who you ask I guess. Keep up the good work. I don't care for the high price but I recognize the work that has gone into this game and by the looks of the beta patches it seems to still see support so Im happy to give my money to developers and publishers who work on war games and who respect their fans.it is a niche market and needs our support.


< Message edited by PokerWolf -- 3/25/2013 4:41:04 PM >
Post #: 1
RE: What do I need to play latest version - 3/25/2013 4:47:10 PM   
phoenix

 

Posts: 1926
Joined: 9/28/2010
Status: offline
Hey Pokerwolf. As far as I'm aware, the most recent basic game is Command Ops; Battles from the Bulge. There exists, at the moment, one add-on pack you can buy to add to CO:BFTB (which is needed as the base game) - the 'Highway To The Reich' module (covering Operation Market-Garden), which adds about 10 scenarios from the old, orginal HTTR to the new Command Ops engine. In the next couple of months there will likely be an new add-on to buy, adding all the old Conquest of the Aegean scenarios to the new engine. Though if you buy the HTTR add-on you can play the Market-Garden games on the new patch (current is patch 4.4.258, which is a public beta), some maps are slow to load because they haven't been 'converted' yet by Panther games (will happen for final of patch 4). It's easy enough to convert them yourself though.

So, to play the basic game patched to 4.4.258 you would need Command Ops:Battles from the Bulge and the 'public' beta 4.4.258, which is available from the members section of Matrix (you can register to get access for free).

I think that covers it.

I agree it's a superb game, and you can get so seriously hooked that you will never look at another strategy game again, because they none of them have the AI this game has (friendly and enemy). It's unique. That's what has happened to me, anyway. :) Multi-player works superbly and is fantastic to play, and even more addictive.

I think it's worth every penny. I would happily have paid more, because, as I said, there's nothing else out there that has AI like this. I would happily pay a subscription actually if that was what was needed to keep it going. The development of the game is an open-ended process, I think, which we - the players - have recently had a small part in, through the new public beta system. The response of the developers at Panther is excellent, and again, I think, almost unique.

There are a variety of different development projects underway - from a smaller scale (platoon level, I think) tactical rendering of part of the blitzkrieg (Legends of the Blitzkrieg) through to a big eastern front game, covering the battles around Chir (or 'the' Chir - not sure since EF things aren't my strong point...). I guess the time frame on these might be 'sometime in the next three years', realistically. It's a small team doing it all.

Should add - the game was brilliant even before this new engine, and you don't need to play it on the patch of this engine to get the idea. The patch has some issues in it as well, (which the pre-patch version didn't) - it's a beta patch, after all (none of the issues are game killers, I think - I'm presently playing a very long MP scenario on 4.4.258, without problems). The issues look likely to be ironed out over the next few weeks and I guess the patch will be final in that time frame too (just going off what the developers have said in here).

< Message edited by phoenix -- 3/25/2013 5:03:05 PM >

(in reply to PokerWolf)
Post #: 2
RE: What do I need to play latest version - 4/3/2013 1:11:06 PM   
redwolf

 

Posts: 151
Joined: 9/19/2002
Status: offline
quote:

There exists, at the moment, one add-on pack you can buy to add to CO:BFTB (which is needed as the base game) - the 'Highway To The Reich' module (covering Operation Market-Garden), which adds about 10 scenarios from the old, orginal HTTR to the new Command Ops engine.


Hold on, are those all scenarios that were in HTTR/RdoA?

(in reply to phoenix)
Post #: 3
RE: What do I need to play latest version - 4/3/2013 1:54:35 PM   
wodin


Posts: 7981
Joined: 4/20/2003
From: England
Status: offline
Yes redwolf..

_____________________________

My Tactical wargame facebook page.

https://www.facebook.com/Tacticalwargame


(in reply to redwolf)
Post #: 4
RE: What do I need to play latest version - 4/3/2013 2:34:46 PM   
phoenix

 

Posts: 1926
Joined: 9/28/2010
Status: offline
Yes. There were more in the old game. Only about 10 of them converted.

(in reply to wodin)
Post #: 5
RE: What do I need to play latest version - 4/3/2013 10:09:02 PM   
redwolf

 

Posts: 151
Joined: 9/19/2002
Status: offline
Oh that means even if I spend the $85 dollars to "upgrade my HTTR" I don't get to have the full game?

That's kind of a letdown.

(in reply to phoenix)
Post #: 6
RE: What do I need to play latest version - 4/3/2013 11:07:42 PM   
wodin


Posts: 7981
Joined: 4/20/2003
From: England
Status: offline
I never bothered with HTTR expansions I already bought those scenarios twice with RDOA and HTTR..I am will to buy the COTA ones again though when that comes out..

_____________________________

My Tactical wargame facebook page.

https://www.facebook.com/Tacticalwargame


(in reply to redwolf)
Post #: 7
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command Ops Series >> What do I need to play latest version Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.070