Matrix Games Forums

Ageod's To End All Wars is now availableTo End All Wars is now available!Deal of the Week: Field of GloryTo End All Wars: Video, AAR and Interview!Ageod's To End All Wars: Video, AAR and Interview!To End All Wars: Artillery Battle Academy 2: Eastern Front - End of Early Access Space Program Manager unveils its multiplayer modes Another update for Commander: The Great War!Distant Worlds: Universe gets a new update
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Trying to add Canada v.104

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [World War II] >> Time of Fury >> Design and Modding >> Trying to add Canada v.104 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Trying to add Canada v.104 - 2/8/2013 3:41:17 AM   
rmonical

 

Posts: 1389
Joined: 4/1/2011
Status: offline
Started with 1939 Grand Campaign

Edited Canada onto the map with Montreal. Rearranged the sea zones and create the Saint Lawrence Seaway.
Saved the new map. Copied the v104 .ini and unit files back into the mod. So the changed files from stock are:
map.wim
cities.csv
sea_nodes.csv
countries.csv
Info.ini
Sea_edges.csv

Here is where it crashes. Am I pushing a rope?

[thread: 25740, -2] Loading INI file data\scenarios\GC-NewMap\consts.ini ...
[thread: 25740, -2] Loaded
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳潆瑲渀慴敧敐慮瑬䙹牯慅档潆瑲敌敶lȸ켩斤䞀˲ || 0.100000
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳汐楡n慴敧敐慮瑬䙹牯慅档潆瑲敌敶lȸ켩斤䞀˲ || 1.000000
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳潆敲瑳愀敧敐慮瑬䙹牯慅档潆瑲敌敶lȸ켩斤䞀˲ || 1.500000
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳潒杵h愀敧敐慮瑬䙹牯慅档潆瑲敌敶lȸ켩斤䞀˲ || 1.700000
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳睓浡p愀敧敐慮瑬䙹牯慅档潆瑲敌敶lȸ켩斤䞀˲ || 1.250000
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳楈汬s愀敧敐慮瑬䙹牯慅档潆瑲敌敶lȸ켩斤䞀˲ || 1.400000
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳潍湵慴湩攀敐慮瑬䙹牯慅档潆瑲敌敶lȸ켩斤䞀˲ || 2.000000
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳敄敳瑲渀攀敐慮瑬䙹牯慅档潆瑲敌敶lȸ켩斤䞀˲ || 1.000000
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳楃祴琀渀攀敐慮瑬䙹牯慅档潆瑲敌敶lȸ켩斤䞀˲ || 2.000000
[thread: 25740, -2] (null) DEFBUG : 慌摮潃扭瑡敄敦摮牥潍楤楦牥⽳敎牡祢敄敦摮牥噳污敵愀档潆瑲敌敶lȸ켩斤䞀˲ || 0.050000
[thread: 25740, -2] Progress = 15%
[thread: 25740, -2] Otwieram plik z pa�stwami ze �cie�k�...
[thread: 25740, -2] data\scenarios\GC-NewMap\countries.csv
[thread: 25740, -2] Otwarcie OK
Post #: 1
RE: Trying to add Canada v.104 - 2/23/2013 8:57:55 PM   
Razz


Posts: 2522
Joined: 10/21/2007
From: CaLiForNia
Status: offline

I assume you copied the existing map and renamed it. Then made modifications.
I could never get the editor to load correctly and work.

I'm not sure the editor remakes the links. Did you update the map after changes? Usually there is an update button.

There are allot of links that need to be changed and then you have to add connections for the AI to recognize the city.

I don't know if you can add another line for a country.


Try creating Canada and making it active and Allied, then you have to set relations.

No matter what you can not create convoy as they are programmed behind the scenes.

(in reply to rmonical)
Post #: 2
RE: Trying to add Canada v.104 - 3/1/2013 5:45:48 AM   
rmonical

 

Posts: 1389
Joined: 4/1/2011
Status: offline
Canada is already in the country list. It is just not a real country in TOF. Since I was only adding land and cities, the connections were pretty easy. I think I got the sea zones landing hexes and ports right - but who knows.

I did not edit the relations. Having done so it crashes in the same place. The messages do not show an error and what happens next in a clean stare - loading the Polish country flag, appears to be innocuous.

[thread: 19012, -2] Loading file "data\gfx\Flags\Poland.png" (1) [OK]
[thread: 19012, -2] Added country Iceland (ID: 4, AllianceID: 0)
[thread: 19012, -2] Loading file "data\gfx\Flags\Norway.png" (1) [OK]
[thread: 19012, -2] Added country Norway (ID: 5, AllianceID: 0)

It may be that it crashes loading Canada without leaving any country load messages

[thread: 19012, -2] Added country Ethiopia (ID: 50, AllianceID: 0)
[thread: 19012, -2] Loading file "data\gfx\Flags\Liberia.png" (1) [OK]
[thread: 19012, -2] Added country Liberia (ID: 51, AllianceID: 0)
[thread: 19012, -2] Loading file "data\gfx\Flags\Canada.png" (1) [OK]
[thread: 19012, -2] Added country Canada (ID: 52, AllianceID: 0)
[thread: 19012, -2] Loading file "data\gfx\Flags\USA.png" (1) [OK]

(in reply to Razz)
Post #: 3
RE: Trying to add Canada v.104 - 3/2/2013 3:58:27 AM   
Razz


Posts: 2522
Joined: 10/21/2007
From: CaLiForNia
Status: offline
There are two types of connections, land and sea.

Make sure land is to land and sea to sea.

Was there a way to delete the connections before you started?

Originally the hexes were sea, so you have to delete all those connections.

One thing to do is to change Canada to alliance 1, as 0 is neutral.

Have you set a Capital?

Did you make the country active?

Maybe you can post a snap shot of Canada here and then post the country, city, sea node files here.

(in reply to rmonical)
Post #: 4
Page:   [1]
All Forums >> [Current Games From Matrix.] >> [World War II] >> Time of Fury >> Design and Modding >> Trying to add Canada v.104 Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.063