Matrix Games Forums

To End All Wars: Artillery Battle Academy 2: Eastern Front - End of Early Access Space Program Manager unveils its multiplayer modes Another update for Commander: The Great War!Distant Worlds: Universe gets a new updateDeal of the Week: Eagle Day to Bombing the Reich Advanced Tactics Gold is coming to SteamMatrix Games now speaks German!A little bit of history with To End All WarsBattle Academy 2 gets a release date!
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Pilot Request - Yes/No Box Display Bug (Please confirm)

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Pilot Request - Yes/No Box Display Bug (Please confirm) Page: [1]
Login
Message << Older Topic   Newer Topic >>
Pilot Request - Yes/No Box Display Bug (Please confirm) - 12/13/2012 6:08:38 PM   
Kull


Posts: 1056
Joined: 7/3/2007
From: El Paso, TX
Status: offline
I don't want to bother Michael with this unless it's real, so if others could please confirm, I'd appreciate it!

(Playing as Japan vs. AI, Scenario 1, Beta 1120b)

- Pick any air unit
- Set the source of new Pilots as "Replacements"
- Click the "Request Veteran" button
- In the window, select any pilot on the list and you get the "Yes/No" Confirmation box
- The Box graphic is missing, although the text is present and the yes/no buttons work:





Attachment (1)

_____________________________

AE-Japan Setup

AE-Allied Setup

Japan Air-Engine Plan
Post #: 1
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/13/2012 6:09:22 PM   
Kull


Posts: 1056
Joined: 7/3/2007
From: El Paso, TX
Status: offline
By contrast:

- Pick the same air unit
- Set the source of new Pilots as "Reserve" ("Any" and "TRACOM" also work)
- Click the "Request Veteran" button
- In the window, select any pilot on the list and you get the "Yes/No" Confirmation box
- The Box graphic appears and everything works as it should:




Attachment (1)

_____________________________

AE-Japan Setup

AE-Allied Setup

Japan Air-Engine Plan

(in reply to Kull)
Post #: 2
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/13/2012 6:47:09 PM   
pompack


Posts: 2520
Joined: 2/8/2004
From: University Park, Texas
Status: offline
If you reboot the computer does it continue to occur?

(in reply to Kull)
Post #: 3
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/13/2012 7:03:14 PM   
Kull


Posts: 1056
Joined: 7/3/2007
From: El Paso, TX
Status: offline
quote:

ORIGINAL: pompack

If you reboot the computer does it continue to occur?


Yes.

Edit: As a partial check, I loaded the game on a different computer and had the same display issue. So it's not related to game settings or cpu or even operating system.

< Message edited by Kull -- 12/13/2012 7:06:48 PM >


_____________________________

AE-Japan Setup

AE-Allied Setup

Japan Air-Engine Plan

(in reply to pompack)
Post #: 4
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/13/2012 7:53:12 PM   
pompack


Posts: 2520
Joined: 2/8/2004
From: University Park, Texas
Status: offline

quote:

ORIGINAL: Kull

quote:

ORIGINAL: pompack

If you reboot the computer does it continue to occur?


Yes.

Edit: As a partial check, I loaded the game on a different computer and had the same display issue. So it's not related to game settings or cpu or even operating system.



Good try though. I have a similar recuring problem that can be fixed that way.

(in reply to Kull)
Post #: 5
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/15/2012 12:52:49 AM   
KHawk

 

Posts: 52
Joined: 7/3/2004
Status: offline
Kull,

I have the same problem. I think it started around beta 1120a, give or take one beta.

(Playing as Allies vs. AI, Scenario The Babes B, Beta 1120f)

KHawk

(in reply to pompack)
Post #: 6
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/15/2012 2:05:42 AM   
michaelm


Posts: 9081
Joined: 5/5/2001
From: Sydney, Australia
Status: online
I don't seem to have the problem.
But I noticed on the screen shot above that it says "Assigned to 3rd Sentai" but doesn't show the second line "Transfer to 4th Sentai" like the next one did.

I'm wondering if the second line is somehow overflowing and causing some error in the display engine.

If it can be produced, can you send me a save and how to reproduce it?





Attachment (1)

< Message edited by michaelm -- 12/15/2012 2:07:10 AM >


_____________________________

Michael

(in reply to KHawk)
Post #: 7
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/15/2012 7:08:32 AM   
Kull


Posts: 1056
Joined: 7/3/2007
From: El Paso, TX
Status: offline
quote:

ORIGINAL: michaelm

I don't seem to have the problem.
But I noticed on the screen shot above that it says "Assigned to 3rd Sentai" but doesn't show the second line "Transfer to 4th Sentai" like the next one did.

I'm wondering if the second line is somehow overflowing and causing some error in the display engine.

If it can be produced, can you send me a save and how to reproduce it?


Sure! As noted above, I'm playing as Japan vs. AI, Scenario 1, Beta 1120b. Start up the saved game, go to Kobe and select the 4th Sentai (Nate), makes sure the pilot source is set to "Replacements" and then click the "Request Veteran" button. Pick any pilot from the list of choices and you should see something identical to the picture in my first post. Thanks!

Attachment (1)

_____________________________

AE-Japan Setup

AE-Allied Setup

Japan Air-Engine Plan

(in reply to michaelm)
Post #: 8
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/15/2012 8:05:07 AM   
michaelm


Posts: 9081
Joined: 5/5/2001
From: Sydney, Australia
Status: online
Yep, just as I suspected. The 'to group' name wasn't decoded so was wiping out the rest of the display data.
Only shows up in the release code, and not my debug code.

Will fix in next build

_____________________________

Michael

(in reply to Kull)
Post #: 9
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/15/2012 10:40:30 AM   
PaxMondo


Posts: 5658
Joined: 6/6/2008
Status: offline
Thanks for great ongoing support Michael!!!



_____________________________

Pax

(in reply to michaelm)
Post #: 10
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/15/2012 4:17:34 PM   
Kull


Posts: 1056
Joined: 7/3/2007
From: El Paso, TX
Status: offline
quote:

ORIGINAL: michaelm

Yep, just as I suspected. The 'to group' name wasn't decoded so was wiping out the rest of the display data.
Only shows up in the release code, and not my debug code.

Will fix in next build


Many thanks Michael!


_____________________________

AE-Japan Setup

AE-Allied Setup

Japan Air-Engine Plan

(in reply to michaelm)
Post #: 11
RE: Pilot Request - Yes/No Box Display Bug (Please conf... - 12/15/2012 11:13:57 PM   
KHawk

 

Posts: 52
Joined: 7/3/2004
Status: offline
Thanks for all the effort you put into this for us.

"Never was so much owed by so many to so few"


KHawk

(in reply to michaelm)
Post #: 12
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Pilot Request - Yes/No Box Display Bug (Please confirm) Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.080