Matrix Games Forums

Deal of the Week Pride of NationsTo End All Wars Releasing on Steam! Slitherine is recruiting: Programmers requiredPandora: Eclipse of Nashira gets release dateCommunity impressions of To End All WarsAgeod's To End All Wars is now availableTo End All Wars is now available!Deal of the Week: Field of GloryTo End All Wars: Video, AAR and Interview!Ageod's To End All Wars: Video, AAR and Interview!
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

LCU Rebuilding unit bug

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> LCU Rebuilding unit bug Page: [1]
Login
Message << Older Topic   Newer Topic >>
LCU Rebuilding unit bug - 10/18/2012 4:12:19 PM   
koniu

 

Posts: 2181
Joined: 2/28/2011
From: Konin, Poland, European Union
Status: offline
I think something is broken with rebuilding of units

I have rebuild 3 Tank Div, It also happen to me for 2 Tank Div
michaelm@ I do not want to give to much details about where that unit is so find 13 Tank regiment and rebuild division
Units is rebuilding but numbers of squads and devices in unit are double TOE after rebuild


Game version is 1117e checked also under 1119a

Picture of unit after rebuild (TOE in red looks ok)





When i do calculations it look like after rebuild number of devices is
"all devices from organic sub units + TOE" Something must be wrong in rebuild formula

Attachment (1)

< Message edited by koniu -- 10/19/2012 7:21:37 AM >


_____________________________

"Only the Dead Have Seen the End of War"
Post #: 1
RE: Rebuilding unit bug - 10/18/2012 4:14:25 PM   
koniu

 

Posts: 2181
Joined: 2/28/2011
From: Konin, Poland, European Union
Status: offline
And save before rebuild



Attachment (1)

_____________________________

"Only the Dead Have Seen the End of War"

(in reply to koniu)
Post #: 2
RE: Rebuilding unit bug - 10/18/2012 5:49:07 PM   
koniu

 

Posts: 2181
Joined: 2/28/2011
From: Konin, Poland, European Union
Status: offline
It is only happens when rebuilding unit from original units comanies, regiments. etc.

When i split unit to thrre parts and rebuild it everything is ok.

Also it look like all those devices are created for free. No HI, vehicle, armament or manpower use from pools

_____________________________

"Only the Dead Have Seen the End of War"

(in reply to koniu)
Post #: 3
RE: Rebuilding unit bug - 10/19/2012 7:21:44 AM   
koniu

 

Posts: 2181
Joined: 2/28/2011
From: Konin, Poland, European Union
Status: offline
Can anyone can confirm that bug in his game?

_____________________________

"Only the Dead Have Seen the End of War"

(in reply to koniu)
Post #: 4
RE: Rebuilding unit bug - 10/19/2012 7:42:35 AM   
koniu

 

Posts: 2181
Joined: 2/28/2011
From: Konin, Poland, European Union
Status: offline
Another unit.
As You can see after rebuil organic units from sub units go to new unit but also new unit get all devices for new TOE for free





Attachment (1)

< Message edited by koniu -- 10/19/2012 7:55:42 AM >


_____________________________

"Only the Dead Have Seen the End of War"

(in reply to koniu)
Post #: 5
RE: Rebuilding unit bug - 10/19/2012 7:42:38 AM   
Alfred

 

Posts: 3650
Joined: 9/28/2006
Status: offline
How many devices did each of the sub units have before they were combined? If they totalled more than the new TOE, the excess ise not lost and therefore it would not be a bug.

Alfred

(in reply to koniu)
Post #: 6
RE: Rebuilding unit bug - 10/19/2012 7:45:43 AM   
koniu

 

Posts: 2181
Joined: 2/28/2011
From: Konin, Poland, European Union
Status: offline
quote:

ORIGINAL: Alfred

How many devices did each of the sub units have before they were combined? If they totalled more than the new TOE, the excess ise not lost and therefore it would not be a bug.

Alfred


Alfred it always after rebuild is adding free devices in numbers exactly as TOE of new unit.
TOE is ok - i have check in editor.

< Message edited by koniu -- 10/19/2012 7:49:44 AM >


_____________________________

"Only the Dead Have Seen the End of War"

(in reply to Alfred)
Post #: 7
RE: Rebuilding unit bug - 10/19/2012 8:35:41 AM   
JocMeister

 

Posts: 4899
Joined: 7/29/2009
From: Sweden
Status: offline
Alfred,

I think what koniu is trying to say is that as soon as you combine units and their TOE is changed it gets filled instantly. Without drawing anything from the pool or any cost in construction. Its obvious in post #5 as several CD guns for example are instantly there as soon as the units is combined.

(in reply to koniu)
Post #: 8
RE: Rebuilding unit bug - 10/19/2012 8:44:02 AM   
koniu

 

Posts: 2181
Joined: 2/28/2011
From: Konin, Poland, European Union
Status: offline
quote:

ORIGINAL: JocMeister

Alfred,

I think what koniu is trying to say is that as soon as you combine units and their TOE is changed it gets filled instantly. Without drawing anything from the pool or any cost in construction. Its obvious in post #5 as several CD guns for example are instantly there as soon as the units is combined.


Example for SNLF Squad:

Kure 6th SNLF have 24 squads
Yokosuka 7th SNLF have 24 squads

So Combined 8th SNLF should have 48 squads. But he have 96 (48 from organic subunits and 48 added for free)

And because sub units dot have CD guns, after recombining they get only free guns in number like TOE of that unit


< Message edited by koniu -- 10/19/2012 8:54:57 AM >


_____________________________

"Only the Dead Have Seen the End of War"

(in reply to JocMeister)
Post #: 9
RE: Rebuilding unit bug - 10/19/2012 10:15:54 AM   
michaelm


Posts: 9113
Joined: 5/5/2001
From: Sydney, Australia
Status: offline
The rebuilding of editor sub-units and normal sub-units was enhanced in last patch, but the assumption was the editor parent of editor sub-unit was a skeleton. Wrong.
The lines to zero out the starting device numbers was left out. Me bad!
Will fix for the next build.

_____________________________

Michael

(in reply to koniu)
Post #: 10
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> LCU Rebuilding unit bug Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.094