Matrix Games Forums

War in the West gets its first update!Flashpoint Campaigns: Red Storm version 2.08 is now available!Command gets huge update!Order of Battle: Pacific Featured on Weekly Streaming SessionA new fight for Battle Academy!Buzz Aldrin's Space Program Manager is out for Mac!The definitive wargame of the Western Front is out now! War in the West gets teaser trailer and Twitch Stream!New Preview AAR for War in the West!War in the West Manual preview
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Problems with Equipment Editor

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [World War II] >> Norm Koger's The Operational Art Of War III >> Scenario Design >> Problems with Equipment Editor Page: [1]
Login
Message << Older Topic   Newer Topic >>
Problems with Equipment Editor - 8/19/2012 11:57:26 AM   
76mm


Posts: 2220
Joined: 5/2/2004
From: Moscow
Status: offline
I'm having some strange problems with the equipment editor (v 1.2) and was hoping that someone could help me out. I am trying to create an East-front-only equipment file but am encountering the problems described below. As base, I've tried using the original equipment file and two different user-created WWII files (WWII 2.0 and SWWDB), all with the same result.

I have created scenario called scenarioname , then created a subfolder in the graphics folder with the same name and copied the equipment file to that subfolder and gave the equipment file the same name. However, if I make any significant changes to the equipment file (for instance, delete nodes from the tree (helicopters, etc), when I try to create units in the TOAW III scenario editor, the force editor seems to be using a hybrid equipment file which includes my revised equipment file and the original equipment file. For instance, the "Tanks" category is repeated twice, once with my revised version and once with the original database, or "Helicopters" are reinserted, etc.

I can't really determine whether the equipment editor is somehow screwing up my revised equipment files, or if the force editor is somehow looking at two equipment files instead of one (which seems unlikely).
Post #: 1
RE: Problems with Equipment Editor - 8/19/2012 12:17:34 PM   
Oberst_Klink

 

Posts: 1357
Joined: 2/10/2008
From: Germany
Status: offline

quote:

ORIGINAL: 76mm

I'm having some strange problems with the equipment editor (v 1.2) and was hoping that someone could help me out. I am trying to create an East-front-only equipment file but am encountering the problems described below. As base, I've tried using the original equipment file and two different user-created WWII files (WWII 2.0 and SWWDB), all with the same result.

I have created scenario called scenarioname , then created a subfolder in the graphics folder with the same name and copied the equipment file to that subfolder and gave the equipment file the same name. However, if I make any significant changes to the equipment file (for instance, delete nodes from the tree (helicopters, etc), when I try to create units in the TOAW III scenario editor, the force editor seems to be using a hybrid equipment file which includes my revised equipment file and the original equipment file. For instance, the "Tanks" category is repeated twice, once with my revised version and once with the original database, or "Helicopters" are reinserted, etc.

I can't really determine whether the equipment editor is somehow screwing up my revised equipment files, or if the force editor is somehow looking at two equipment files instead of one (which seems unlikely).

Tom,

send me the .EQP I'll have a look at it. I would use one scenario with an already modified .eqp and rename it, as a kind of dummy scenario with it's own equipment file.

Klink, Oberst

_____________________________

Ceterum censeo Carthaginem esse delendam
(Marcus Porcius Cato Censorius)

Visit the Gefechtsstand!

(in reply to 76mm)
Post #: 2
RE: Problems with Equipment Editor - 8/19/2012 12:56:32 PM   
76mm


Posts: 2220
Joined: 5/2/2004
From: Moscow
Status: offline
OK, I will try to send the file shortly. In the meantime, here are screenshots of what I did in the Editor (revised WWII DB so that it was only East Front), and below, what I got in the force editor. The categories within the red box are not in the file I created in the equipment editor, and if you look in them, you'll see that they include modern equipment which was not even in the WWII DB which I started from. Weird...



I should mention that I received an error message when I save the file in the equipment editor, and when I opened the scenario editor, it warned me that I was using the "wrong" equipment file.


(in reply to Oberst_Klink)
Post #: 3
RE: Problems with Equipment Editor - 8/19/2012 1:04:00 PM   
76mm


Posts: 2220
Joined: 5/2/2004
From: Moscow
Status: offline
hmmm, I don't see how I can attach a file to the e-mail that this forum allows me to send to you, or how to attach to this post. Could you pm your e-mail?


(in reply to 76mm)
Post #: 4
RE: Problems with Equipment Editor - 8/19/2012 4:16:12 PM   
Curtis Lemay


Posts: 7236
Joined: 9/17/2004
From: Houston, TX
Status: offline
You can try contacting Parminio (it's his editor), or you can try it again using the original BioEd. I doubt it's anything TOAW is doing, so it must be a bust in the editor or you did something it doesn't allow.

(in reply to 76mm)
Post #: 5
RE: Problems with Equipment Editor - 8/19/2012 7:48:23 PM   
76mm


Posts: 2220
Joined: 5/2/2004
From: Moscow
Status: offline
For some reason I can neither e-mail or PM Parmenio from this forum, so hopefully he checks in these days. I've also sent an e-mail to Bill Wilson (whose DB I'm hoping to use), asking whether he created his DB with Parmenio's editor or BioEd. At this point I'm curious what is going on with these eqp files...

(in reply to Curtis Lemay)
Post #: 6
RE: Problems with Equipment Editor - 8/19/2012 8:57:25 PM   
Panama


Posts: 1362
Joined: 10/30/2009
Status: offline
My guess is that there are a minimum number of equipment catagories that the game looks for and if that number isn't reached in your equipment file the game goes to the generic equipment file and 'fills in' the blanks. It's not really strange that the editor can pick up the missing stuff because if I recall the generic equipment file is hard coded into the game.

If you would put in a minimum equipment categories that problem could quite possibly go away. (try using spares). But then why bother? Just use the equipment files with all of the equipment instead of deleting all the other things that belong to non East Front countries.

< Message edited by Panama -- 8/19/2012 9:00:51 PM >

(in reply to 76mm)
Post #: 7
RE: Problems with Equipment Editor - 8/19/2012 9:59:35 PM   
Oberst_Klink

 

Posts: 1357
Joined: 2/10/2008
From: Germany
Status: offline
oberst.w.klink@gmail.com

Did you try Andy's Editor?

http://homepage.ntlworld.com/a.edmiston/toaweqpedit.htm

Klaus aka Oberst Klink

_____________________________

Ceterum censeo Carthaginem esse delendam
(Marcus Porcius Cato Censorius)

Visit the Gefechtsstand!

(in reply to 76mm)
Post #: 8
RE: Problems with Equipment Editor - 8/20/2012 3:52:01 AM   
76mm


Posts: 2220
Joined: 5/2/2004
From: Moscow
Status: offline
Oberst, thanks, I've sent Bill Wilson's original file and my modified one, please take a look when you have a moment. And yes, Andy's editor is the one I've been using--is there another one other than BioEd?

Panama, what you say makes sense--I didn't realize that the original eqp is hard-wired into the game (of course why it's hard-wired is another question...). If that is correct, there is indeed no point in messing with it. From what I've seen, Bill Wilson's eqp file is very good (and I can't imagine how much work went into it), so I can use that if I have to.

(in reply to Oberst_Klink)
Post #: 9
RE: Problems with Equipment Editor - 8/20/2012 2:43:13 PM   
76mm


Posts: 2220
Joined: 5/2/2004
From: Moscow
Status: offline
Just to keep everyone in the loop, I got a response from Bill about his DB.

He is pretty sure that the eqp database looks for a set number of entries, which is one of the reasons that he has so many spare slots in his DB. If that's the case, no point in messing around with it further.

Just for fun, however, I will try one more thing in the editor, and that is to "erase" rather than "delete" the entries that I don't want; I doubt that will help, but I want to find out before completely giving up.

(in reply to 76mm)
Post #: 10
RE: Problems with Equipment Editor - 8/20/2012 4:10:50 PM   
Panama


Posts: 1362
Joined: 10/30/2009
Status: offline
Since the program looks for a set number of slots to fill it's database you need to make every slot you don't use a 'Spare Equipment'. You can leave the data. Just change the name to something like Spare Equipment and replace the 2D icon with the blank bar. Erasing or deleting anything will still leave a database slot that the program MUST fill with something.

(in reply to 76mm)
Post #: 11
RE: Problems with Equipment Editor - 8/20/2012 4:20:18 PM   
Oberst_Klink

 

Posts: 1357
Joined: 2/10/2008
From: Germany
Status: offline
Tom,

'Delete' will remove the slot, therefore creating a new 'empty slot'. 'Erase' will keep the slot, without any data though. Like I emailed you earlier on; there's no issue when I use your DB.

Klink, Oberst

_____________________________

Ceterum censeo Carthaginem esse delendam
(Marcus Porcius Cato Censorius)

Visit the Gefechtsstand!

(in reply to 76mm)
Post #: 12
RE: Problems with Equipment Editor - 8/20/2012 6:02:51 PM   
76mm


Posts: 2220
Joined: 5/2/2004
From: Moscow
Status: offline
Oberst, I've been using the eqp editor which you forwarded to me the whole time, with the results described in this thread. I tried erasing rather than deleting the data, same result. No big surprise there...

Finally I thought that if I couldn't actually delete the non-East Front entries, I would at least move them lower in the list so that Germany and the Soviet Union were in the first two spots. Alas, that did not work either--the entries remained in the original spot in the game editor--now that was rather frustrating!

(in reply to Oberst_Klink)
Post #: 13
RE: Problems with Equipment Editor - 8/20/2012 9:02:13 PM   
Panama


Posts: 1362
Joined: 10/30/2009
Status: offline

quote:

ORIGINAL: 76mm

Oberst, I've been using the eqp editor which you forwarded to me the whole time, with the results described in this thread. I tried erasing rather than deleting the data, same result. No big surprise there...

Finally I thought that if I couldn't actually delete the non-East Front entries, I would at least move them lower in the list so that Germany and the Soviet Union were in the first two spots. Alas, that did not work either--the entries remained in the original spot in the game editor--now that was rather frustrating!


You can set up the equipment database any way you want. You just have to do it all manually. No easy fixes here. Then set the slots that don't get used as Spare Equipment, same as Bill did for his.

(in reply to 76mm)
Post #: 14
RE: Problems with Equipment Editor - 8/20/2012 9:54:51 PM   
Oberst_Klink

 

Posts: 1357
Joined: 2/10/2008
From: Germany
Status: offline

quote:

ORIGINAL: 76mm

Oberst, I've been using the eqp editor which you forwarded to me the whole time, with the results described in this thread. I tried erasing rather than deleting the data, same result. No big surprise there...

Finally I thought that if I couldn't actually delete the non-East Front entries, I would at least move them lower in the list so that Germany and the Soviet Union were in the first two spots. Alas, that did not work either--the entries remained in the original spot in the game editor--now that was rather frustrating!

I'll get rid of the 'Spares' and send you the cleaned up version of your DB. As I said, no problems with your DB here (see screenshot).

Klink, Oberst




Attachment (1)

_____________________________

Ceterum censeo Carthaginem esse delendam
(Marcus Porcius Cato Censorius)

Visit the Gefechtsstand!

(in reply to 76mm)
Post #: 15
RE: Problems with Equipment Editor - 8/21/2012 3:47:02 AM   
76mm


Posts: 2220
Joined: 5/2/2004
From: Moscow
Status: offline
Oberst, frankly I'm confused--why aren't you having problems with this file, and why will removing the spares solve the problem for me? Based on other responses, I thought that the problem was caused by having too few DB entries, so removing the spares would only make things worse?

(in reply to Oberst_Klink)
Post #: 16
Page:   [1]
All Forums >> [Current Games From Matrix.] >> [World War II] >> Norm Koger's The Operational Art Of War III >> Scenario Design >> Problems with Equipment Editor Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.086