Matrix Games Forums

Space Program Manager Launch Contest Announced!Battle Academy 2 is out now on iPad!A closer look at rockets in Space Program ManagerDeal of the Week - Pride of NationsA new update for Piercing Fortress EuropaNew screenshots for War in the West!Pike & Shot is now available!Server Maintenance Battle Academy 2 gets updated!Deal of the Week: Advanced Tactics Gold
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Empire policy changes not taking affect 1.7.0.16

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Empire policy changes not taking affect 1.7.0.16 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Empire policy changes not taking affect 1.7.0.16 - 8/14/2012 6:29:38 PM   
MartialDoctor


Posts: 383
Joined: 3/7/2011
Status: offline
Unfortunately, I am not at my home computer and won't be for a while. I'll supply a saved game and info when I get back in a few weeks.

The empire policy changes to things such as fleet sizes and what ships the AI builds does not seem to be having any effect (I checked in the editor to verify this). The AI seems to be ignoring these areas of the empire policy.

I had changed fleet sizes to a larger size, fleet percentages to a higher percentage, and reduced escort amounts while increasing other ship percentages. None of these seem to have done anything.

Anyways, I just wanted to get a notification out. I'll get save info and a copy of my policy files when I get access to them again.

< Message edited by MartialDoctor -- 8/14/2012 6:30:11 PM >
Post #: 1
RE: Empire policy changes not taking affect 1.7.0.16 - 8/20/2012 2:23:18 PM   
ASHBERY76


Posts: 1978
Joined: 10/10/2001
From: England
Status: offline
Agreed.I changed fleet sizes but the A.I seemed to use the same 15 default.

(in reply to MartialDoctor)
Post #: 2
RE: Empire policy changes not taking affect 1.7.0.16 - 8/25/2012 7:05:40 PM   
ArchMike

 

Posts: 22
Joined: 8/25/2012
Status: offline
I concur. I started the game as Human and set everything to Automated (to learn how to play). The design fine tuning in the empire policy was inadequate for military ships (no weapon, no shield, no armor), even though the TXT policy file for Human had positive values for these settings. So my empire kept producing ships without weapons (only some nuclear bombs).

I tried loading other policy files and the same problem about design fine tuning appeared. It seems that the game does not read the good informations.

< Message edited by ArchMike -- 8/25/2012 7:28:17 PM >

(in reply to ASHBERY76)
Post #: 3
RE: Empire policy changes not taking affect 1.7.0.16 - 8/25/2012 9:24:12 PM   
Theluin


Posts: 184
Joined: 5/13/2011
From: Europe, Terra
Status: offline
It's all caused by the same bug that makes almost all ships have no weapons on gamestart. From what I gather the 1.7.0.16 update introduced numbers with decimal places into the policy files. However those files use dots as the decimal separator (like in the UK I think) while in most other countries commas are used for that purpose. As someone mentioned in some other thread here there are 2 solutions to this problem:
a) get some program like Notepad++ and use the replace function to change dots into commas in all the policy files, or
b) go to control panel -> Clock, language & region (Or something similar) -> Change date. time, number formats -> Additional settings -> decimal separator and change it to a dot

Hope this helps,

< Message edited by Theluin -- 8/25/2012 9:25:22 PM >

(in reply to ArchMike)
Post #: 4
RE: Empire policy changes not taking affect 1.7.0.16 - 8/25/2012 11:54:26 PM   
ArchMike

 

Posts: 22
Joined: 8/25/2012
Status: offline
Thanks for the info !

(in reply to Theluin)
Post #: 5
RE: Empire policy changes not taking affect 1.7.0.16 - 8/26/2012 4:48:28 PM   
ASHBERY76


Posts: 1978
Joined: 10/10/2001
From: England
Status: offline
Another area the policy files are not having an effect is using blockades.I set all the A.I polcies to use DiplomacyTradeSanctionsUseBlockades;N but they still do.


(in reply to ArchMike)
Post #: 6
RE: Empire policy changes not taking affect 1.7.0.16 - 9/2/2012 3:26:41 PM   
ASHBERY76


Posts: 1978
Joined: 10/10/2001
From: England
Status: offline
Atfer testing a bit more I think changing the A.I policies only take effect when you start a new game and not on the fly.The A.I is no longer using blockades and setting fleet sizes to what I choose for them in a new game.

(in reply to ASHBERY76)
Post #: 7
RE: Empire policy changes not taking affect 1.7.0.16 - 9/3/2012 1:23:44 AM   
ehsumrell1


Posts: 2146
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline

quote:

ORIGINAL: ASHBERY76

Atfer testing a bit more I think changing the A.I policies only take effect when you start a new game and not on the fly.The A.I is no longer using blockades and setting fleet sizes to what I choose for them in a new game.


I agree Ashberry, I believe that the policy for a race is set (loaded) from the beginning of a
new game. Just like the shipset used, Home system setup, and the like.

_____________________________

Shields are useless in "The Briar Patch"...

(in reply to ASHBERY76)
Post #: 8
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Empire policy changes not taking affect 1.7.0.16 Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.072