Matrix Games Forums

Happy Easter!Battle Academy is now available on SteamPlayers compare Ageods Civil War to Civil War IIDeal of the week - An updated War in the East goes half Price!Sign up for the Qvadriga beta for iPad and Android!Come and say hi at Pax and SaluteLegends of War goes on sale!Piercing Fortress Europa Gets UpdatedBattle Academy Mega Pack is now availableClose Combat: Gateway to Caen Teaser Trailer
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Error (019):

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [World War II] >> Panzer Command: Ostfront >> Error (019): Page: [1]
Login
Message << Older Topic   Newer Topic >>
Error (019): - 8/6/2012 4:46:23 AM   
Andy Brown

 

Posts: 81
Joined: 2/20/2001
Status: offline
"Unknown Unit Type 'Pak 36 Mobile' in Battle File" when I attempt to start a 1 Inf Div random campaign.

Is this a result of something I've done (bigger squads mod) or has something been overlooked?

Thanks,

Andy
Post #: 1
RE: Error (019): - 8/6/2012 5:15:20 AM   
junk2drive


Posts: 12883
Joined: 6/27/2002
From: Arizona West Coast
Status: offline
The mod probably does not have the new mobile ATGs.

(in reply to Andy Brown)
Post #: 2
RE: Error (019): - 8/6/2012 8:33:15 AM   
Andy Brown

 

Posts: 81
Joined: 2/20/2001
Status: offline
Junk,

I thought that might be the case so I deleted and reinstalled the game. Even used the updater again to re-download the patch. Everything tells me I have the 329f patch but when I check the Data\Infantry subfolder, I see "German 37mm PaK 36.xml" and "German 37mm PaK 36_Late.xml" but nothing that includes the string "Pak 36 Mobile"?

Andy

(in reply to junk2drive)
Post #: 3
RE: Error (019): - 8/6/2012 9:11:56 AM   
Rick

 

Posts: 11833
Joined: 4/20/2000
Status: offline

quote:

ORIGINAL: Andy Brown

Junk,

I thought that might be the case so I deleted and reinstalled the game. Even used the updater again to re-download the patch. Everything tells me I have the 329f patch but when I check the Data\Infantry subfolder, I see "German 37mm PaK 36.xml" and "German 37mm PaK 36_Late.xml" but nothing that includes the string "Pak 36 Mobile"?

Andy


If you open the 37mm PaK 36.xml you should see a tag that shows unit type Pak 36 Mobile. The unit type is defined inside the file, not by the file name (though usually they are similar).

I just did a quick check and generated a 1st Inf Div long campaign and started the first battle, I checked my OOB and it did have the Pak 36 Mobile and the battle stated fine. I surrended in the first order phase and then started the second battle and it also had the PaK 36 and I didn't get any errors. this was on an unmodded version just the latest patch.

Can you try this without the big squad mod?

Thanks
rick

(in reply to Andy Brown)
Post #: 4
RE: Error (019): - 8/6/2012 9:29:23 AM   
Rick

 

Posts: 11833
Joined: 4/20/2000
Status: offline
I just checked the Big squad mod (10 man) and junk is right, the PaKs in there do not have the Mobile designator.

If you are using JSGME to manage your mods, an easy fix that will let you keep using the mod is simply delete the PaK 36 and Pak 36 late xmls from the MOD itself. I think you also need to delete the russian 45mm AT gun xml from the MOD. By deleting those files from the mod, it will leave the official file in the Infantry directory when yo uactivate the mod. Make sure you deactivate the mod make the file deletions in the JSGME mod folder then activate the mod.

Thanks
rick.


(in reply to Rick)
Post #: 5
RE: Error (019): - 8/6/2012 10:26:30 AM   
Andy Brown

 

Posts: 81
Joined: 2/20/2001
Status: offline
Rick,

Thanks for taking the time to explain that. A little knowledge was clearly dangerous !! Wrt the PaK 36, everything seems to be working fine now.

But my next attempt to generate a 1 Inf Div long campaign ended with this:

Error(003): BUILDATTEMPTS = 20

Unable to place core platoon(s) '81mm Mortar, JU-87 Stuka' with this template!

Dump:

Dates: (6/1/1941 - 6/24/1944 - 8/31/1944)
Battle: German Summer 1944(Defend) - 1st Inf Div
Template: Summer Map (|9a)
Models: Summer.

This was with a freshly installed and patched 329f, no mods of any kind applied.

Cheers,

Andy

(in reply to Rick)
Post #: 6
RE: Error (019): - 8/6/2012 5:54:17 PM   
Rick

 

Posts: 11833
Joined: 4/20/2000
Status: offline

quote:

ORIGINAL: Andy Brown

Rick,

Thanks for taking the time to explain that. A little knowledge was clearly dangerous !! Wrt the PaK 36, everything seems to be working fine now.

But my next attempt to generate a 1 Inf Div long campaign ended with this:

Error(003): BUILDATTEMPTS = 20

Unable to place core platoon(s) '81mm Mortar, JU-87 Stuka' with this template!

Dump:

Dates: (6/1/1941 - 6/24/1944 - 8/31/1944)
Battle: German Summer 1944(Defend) - 1st Inf Div
Template: Summer Map (|9a)
Models: Summer.

This was with a freshly installed and patched 329f, no mods of any kind applied.

Cheers,

Andy


Try generating it again. I beleive someone else had this problem as well, though I thought it was related to adding an off-map unit to your core force. I'll look into this a bit more.

Thanks
Rick

(in reply to Andy Brown)
Post #: 7
RE: Error (019): - 8/7/2012 3:53:29 AM   
Andy Brown

 

Posts: 81
Joined: 2/20/2001
Status: offline
Rick,

Appeared to generate without problems on second attempt. Some sort of mismatch between certain force compositions and that particular map?

Andy

(in reply to Rick)
Post #: 8
RE: Error (019): - 8/7/2012 4:38:13 AM   
Rick

 

Posts: 11833
Joined: 4/20/2000
Status: offline
quote:

ORIGINAL: Andy Brown

Rick,

Appeared to generate without problems on second attempt. Some sort of mismatch between certain force compositions and that particular map?

Andy


Yes, I think it might be using kessel with no support setup (off-map units). but I see that the core force contains off-map units, and it should only be using the kessel with support setup. I think I know how to avoid this. I'll do some testing and if it works I'll post a solution. and

Thanks!
rick

< Message edited by Rick -- 8/7/2012 4:39:01 AM >

(in reply to Andy Brown)
Post #: 9
RE: Error (019): - 8/9/2012 1:59:50 AM   
WallysWorld


Posts: 164
Joined: 12/21/2006
From: Calgary, Alberta
Status: offline
quote:

ORIGINAL: Rick
I just checked the Big squad mod (10 man) and junk is right, the PaKs in there do not have the Mobile designator.
If you are using JSGME to manage your mods, an easy fix that will let you keep using the mod is simply delete the PaK 36 and Pak 36 late xmls from the MOD itself.


Interestingly this mod now works for me after I deleted the two xmls Rick mentioned from the mod and used the two vanilla xmls instead. Before the mod used to cause PzCO to crash when I clicked on any unit.

Thanks for that hint, Rick.


< Message edited by WallysWorld -- 8/9/2012 2:00:16 AM >

(in reply to Rick)
Post #: 10
RE: Error (019): - 8/9/2012 2:34:12 AM   
Rick

 

Posts: 11833
Joined: 4/20/2000
Status: offline

quote:

ORIGINAL: WallysWorld

quote:

ORIGINAL: Rick
I just checked the Big squad mod (10 man) and junk is right, the PaKs in there do not have the Mobile designator.
If you are using JSGME to manage your mods, an easy fix that will let you keep using the mod is simply delete the PaK 36 and Pak 36 late xmls from the MOD itself.


Interestingly this mod now works for me after I deleted the two xmls Rick mentioned from the mod and used the two vanilla xmls instead. Before the mod used to cause PzCO to crash when I clicked on any unit.

Thanks for that hint, Rick.



Good to hear!

Thanks
rick

(in reply to WallysWorld)
Post #: 11
RE: Error (019): - 8/14/2012 4:58:33 AM   
Rick

 

Posts: 11833
Joined: 4/20/2000
Status: offline

quote:

ORIGINAL: Rick


quote:

ORIGINAL: Andy Brown

Rick,

Thanks for taking the time to explain that. A little knowledge was clearly dangerous !! Wrt the PaK 36, everything seems to be working fine now.

But my next attempt to generate a 1 Inf Div long campaign ended with this:

Error(003): BUILDATTEMPTS = 20

Unable to place core platoon(s) '81mm Mortar, JU-87 Stuka' with this template!

Dump:

Dates: (6/1/1941 - 6/24/1944 - 8/31/1944)
Battle: German Summer 1944(Defend) - 1st Inf Div
Template: Summer Map (|9a)
Models: Summer.

This was with a freshly installed and patched 329f, no mods of any kind applied.

Cheers,

Andy


Try generating it again. I beleive someone else had this problem as well, though I thought it was related to adding an off-map unit to your core force. I'll look into this a bit more.

Thanks
Rick


I've uploaded a mod that improves the generation of random battles when you have off-map support. It's located in the following thread: http://www.matrixgames.com/forums/fb.asp?m=3163149

Thanks!
Rick

(in reply to Rick)
Post #: 12
Page:   [1]
All Forums >> [Current Games From Matrix.] >> [World War II] >> Panzer Command: Ostfront >> Error (019): Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.075